Running application through Citrix and getting errors.

I am trying to run an application through Xenapp 6.5 called Data Trace.  Its a simple application that saves all its settings in the AppData part of the users profile.  The application is working correctly in the older Xenapp farm., but not the new one.  I have the users profile redirected to a network share.  I checked all the permissions on the folder to make sure its not a permission issue.  I tried doing this as admin and non admin.  I deleted the Citrix profile and tried again.  I am at my wits end with this.  I am attaching a screenshot of the error.  within the application you click on a link that that retrieves an image, which uses a java script to do so.  I am getting this error:

Error Message
Chad FranksSenior System EngineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TunerMLSystems EngineerCommented:
Versions of your various software, O/S, Citrix XenApp might assist, however right away I would ask if the correct version of Java installed on the XenApp Server serving the application?
Chad FranksSenior System EngineerAuthor Commented:
Citrix Servers Windows 2008R2
Xenapp 6.5
Chad FranksSenior System EngineerAuthor Commented:
when I look in the logs of the application I see this:

Error: BrowserHandler.ExecJScript() - Error calling script updateActionItemForHistoryPanelScroll('print') due to browser readystate: interactive. Attempt # 10.
Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

TunerMLSystems EngineerCommented:
Are there any particular browser settings you may need to enable or disable? Remember the 2008 Browser is Enhanced security by default you may need to disable this for users and enable some of the settings within the security tab under options.
Chad FranksSenior System EngineerAuthor Commented:
the application is published - once a user logs into the web interface they click on the icon and a separate application opens up.  Why would it have to do with IE?
TunerMLSystems EngineerCommented:
Okay, thought it may have been a web application,
Hate to say it, but you may need to run a ProcMon trace in order to find out exactly why this is happening.  Of course, it can be downloaded from sysinternals.

The trace will tell you a lot more than what you wanted to know, but the answer will be embedded in there.  Be sure to keep your trace as short as possible; anything over a couple of minutes will yield you over a million entries.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.