Solved

Netgear ReadyNAS Stuck on "Checking FS"

Posted on 2014-10-17
34
877 Views
Last Modified: 2016-10-27
I have a Netgear ReadyNAS NV+ that has frozen with the message "Checking FS" on its LCD screen. It has been stuck here for about a week. I have tried unplugging the power & restarting & it ends up back to the same message. I have googled this & found people with the same problem without a solution so far.

The Raidar software finds it but doesn't allow any way to stop this. Also I can no longer connect to it via the network.

I would like to know if anyone has any suggestions as to what maybe going on as well as anyway to get it back up & running? Any help would be greatly appreciated.
0
Comment
Question by:Blinkr
  • 14
  • 9
  • 5
  • +1
34 Comments
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 40388672
1) Pray it hasn't gotten a lot worse letting it run for a week. Turn it off.
2)  Get the trial version of http://www.HDTune.com and check the drives by attaching them to a working PC (Mark which slot they are taken out of, use the connectors for the DVD drive, and abort CHKDSK if it tells you it wants to run it)  Look at the Health tab and, if the value of Reallocated sector count is anything but zero, that drive is failing.  Check them all!
3) Get a replacement drive for any that are failing.  ( They can be the same or slightly larger; but, do not cross any boundaries (i.e. 2TB))
4) Get a copy of RAWCOPY ( http://www.roadkil.net/program.php?ProgramID=22 ), hook the replacement drive and the failing drive as 2 and 3 (I lay a minitower on its side and put heavy cardboard over the drive/PSU side to lay the drives on) and use RawCopy to clone the physical drives.
5)  Put the drives back in the NAS, fire it up, and pray!
0
 
LVL 30

Expert Comment

by:pgm554
ID: 40388927
Here's a trouble shooting guide.

It's basically a Linux ext3 partition,so mounting the disks and running an fsck separate may be the preferred troubleshooting method.

http://jim-st.blogspot.com/2012/07/mouning-readynas-drives-on-x86-systems.html

Here are some paid utilities which may prove useful.

https://www.runtime.org/data-recovery-products.htm
0
 
LVL 1

Author Comment

by:Blinkr
ID: 40388963
Great suggestion, DavisMcCarn! Now these drives obviously are in a raid, so running HDTune isn't going to effect the raid, will it??

I already have Acronis TI that I use for cloning, will that work as well as the Rawcopy??

I have a 2 drive external cradle connected to my work computer so I can use that to connect the drives to the work system.

Thanks again! I will post results after trying this.
0
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 40389104
No, HDTUNE does not do any writing on the drives unless you force it to.  The key to recovery is in cloning the failing drive to one which isn't and putting them all back in their proper places.
0
 
LVL 1

Author Comment

by:Blinkr
ID: 40389199
So you are saying that my Acronis TI disk cloning will work for this, correct??
0
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 40389263
I've never used it; but, a quick check says NO.  It won't do a complete sector by sector copy so would skip any damaged areas, no matter how trivially they were damaged.
0
 
LVL 1

Author Comment

by:Blinkr
ID: 40389327
OK in HDDTune the Reallocated sector count has several columns: Current, Worst, Threshold, Data, & Status. They are consecutively 200, 200, 140, 0, ok. So what column are you referring to. I am assuming its the Data, but the Status is also "ok".
0
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 40389379
I already said the DATA column; but, just to be completely sure, I'll run the error scan to verify there are no bad sectors.  Have you checked all of the drives yet?
0
 
LVL 1

Author Comment

by:Blinkr
ID: 40389398
"...Look at the Health tab and, if the value of Reallocated sector count is anything but zero, that drive is failing..."

I'm sorry but I don't see anything about "Data" in the above sentence.

But yes I just tested all of the drives & all of the data columns were "0". I also did an error scan & all of them passed with no problems.

It appears that it has something to do with the NAS unit itself & the drives are OK. If I set it to factory settings, will it break the raid?? But I don't know how to get it back to factory settings as the Raidar interface doesn't offer much help since the unit is still trying to finish the "Checking OS". Any ideas on that??

Thanks for all of the suggestions, they were definitely a help in ruling out the drives.
0
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 40389976
If you restore it to factory settings you'll undo the raid, the users, and their permissions.  With all of the drives being OK, I have to think something is wrong with the NAS.  Does it have any ram that could be swapped?  Are you comfortable with a voltmeter and can you check the voltages?
0
 
LVL 30

Accepted Solution

by:
pgm554 earned 200 total points
ID: 40390519
That's XRAID which is proprietary to Netgear,so sticking in two other disks to see if it's a firmware issue might be the best way to tell if the unit is bad.

As long as you keep the old disks in correct order when replacing them,you should be good.
0
 
LVL 7

Expert Comment

by:Stampel
ID: 40391440
How many disks you have in your current configuration ?

If you have 2 disks only then you could try to boot with the first disk only (after removing the 2nd disk)
In case its not wortking you could try to boot from the second after replacing the first one in its original location.
0
 
LVL 1

Author Comment

by:Blinkr
ID: 40395952
The only problem is that I don't want to mess the raid up. By booting up with only one or 2 of  the drives it may break the raid. I have 4 drives in this raid.

I like the idea of using 2 drives without a raid & try to create a new one with these 2 drives without messing with my present raid.

I have several older drives that I can use to do this. I will post the results as soon as I have time to test it.
0
 
LVL 30

Expert Comment

by:pgm554
ID: 40396031
Have you seen this and tried to access the boot menu to skip the file check?

http://kb.netgear.com/app/answers/detail/a_id/21411
0
 
LVL 7

Expert Comment

by:Stampel
ID: 40396316
If you have 4 drives, with X-RAID, i am afraid you are using RAID5 and you will not be able to boot on 2 disks only.
On RAID5 you need 3 valid disks on a total of 4 to boot.
Except if you have done some manual config to force two RAID1 or one RAID10 ?
0
 
LVL 1

Author Comment

by:Blinkr
ID: 40409252
Thanks Stampel! I will have to dig up 2 more drives to test it.

Will testing it with 4 other drives effect the raid setup on the 4 drives that were originally in the NAS?? I have them numbered & taken them out. I'm going to use 4 more drives to test the NAS unit itself, but want to make sure that when I put the original drives back in, they will still be good on the original raid.
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 42

Expert Comment

by:Davis McCarn
ID: 40409559
Your smartest option is to make sure the new drives are the same capacity as the original, set them up in the same raid array, and then, after seeing that work, try the old drives.
0
 
LVL 7

Expert Comment

by:Stampel
ID: 40409602
After writing down each disk number before removal to be sure to put them in the same place.
You can boot with one single disk to see if it will be able to boot.
If yes, boot with 2 disks ...
Also reinstall / upgrade firmware as soon as you get the opportunity to do it.
0
 
LVL 1

Author Comment

by:Blinkr
ID: 40409610
Stampel, are you referring to the original disks or new ones??
0
 
LVL 7

Assisted Solution

by:Stampel
Stampel earned 150 total points
ID: 40409626
I was refering to original disks still.
But i have new information for you ...

I have found someone with your problem and the solution was :
"after leaving the NASBox alone for a week it has completed the check and fired up. We have 1.2TB storage running RAID5. The result was Disk2 Dead. I was on the rig 3 days prior to this and changed out disk4. All was working great but the NASBox lost power after the UPS gave up."
From : http://www.readynas.com/forum/viewtopic.php?f=64&t=77043&p=428920

What is the size of your 4 original disks ?
0
 
LVL 1

Author Comment

by:Blinkr
ID: 40411959
Thanks Stampel, I just read the thread & will set things up & let it run. We did run it for about 3 or 4 days without it every coming out of the "Checking FS". So I guess I should let it run for another week or so.

All of the disks are 1 TB.
0
 
LVL 42

Assisted Solution

by:Davis McCarn
Davis McCarn earned 150 total points
ID: 40412161
What bothers me about the path you are on is that we already verified that all of the drives were fine using HDTune including a full read error scan.
My bet is on something hinky with the readynas.  Have you tried plugging 4 other drives in and setting them to the same raid?
0
 
LVL 7

Expert Comment

by:Stampel
ID: 40412751
The guy said in the thread it lasted like a week for only 1.2To, i guess you must have something like 3To if you are using XRAID/RAID5 on 4 disk of 1To, that probably could take long if the thread is right.
Hope it will work.
Cheers.
0
 
LVL 1

Author Comment

by:Blinkr
ID: 40431200
I'm  letting the unit run for a few more days to see if it finally come out of it'so FL check.
0
 
LVL 1

Author Comment

by:Blinkr
ID: 40448514
Well everyone, its coming up on 3 weeks running with the same message "Checking FS" on the screen. Would everyone agree that there must be something wrong with the hardware or software within the NAS now that it has been running for this long??

Don't you think it would have been up & running after booting for 456+ hours???

If there isn't anything else to do, I'm going to consider all of the data lost.

Thanks
0
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 40448648
Yup, after 3 weeks I'd say that something is really hosed; though I did suggest you try the NAS with some different drives.  If they hose too, I'd think there was something wrong with the NAS itself.
0
 
LVL 1

Author Comment

by:Blinkr
ID: 40450638
Would I have to use the same amount of drives? I have 2 identical drives I could use. I don't have enough to build another 4 drive raid with it.

Thanks!
0
 
LVL 30

Expert Comment

by:pgm554
ID: 40450694
All you need to do is see is if the NAS will boot.
End of story.
Even one would suffice.
Eliminate the obvious.
0
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 40452113
I would use two so you could test a raid setup and I don't care what the drives are.
0
 
LVL 1

Author Comment

by:Blinkr
ID: 40496248
Well I just finished a test with 2 empty drives & still no joy. So I have to assume that the firmware or circuitry is hosed for whatever reason.

Thanks for all of the help!!
0
 
LVL 1

Author Comment

by:Blinkr
ID: 40496265
All of the suggestions were great & each one addressed different issues. So I know that this would be a great help to anyone else working with a NAS that won't boot.

But I have to anyone else dealing with this situation, there is always that there is always that possibility that the whole unit could have gone south.

Thanks again everyone!!
0
 
LVL 30

Expert Comment

by:pgm554
ID: 40496361
Need to object to the accepted answer as I suggested using two disks to trouble shoot way before the accepted answer of using two

>That's XRAID which is proprietary to Netgear,so sticking in two other disks to see if it's a firmware issue might be the best way to tell if the unit is bad.
0
 
LVL 1

Author Comment

by:Blinkr
ID: 40497342
I'm sorry about this. I will wait until a monitor responds as to how I can correct this.
0

Featured Post

Complete Microsoft Windows PC® & Mac Backup

Backup and recovery solutions to protect all your PCs & Mac– on-premises or in remote locations. Acronis backs up entire PC or Mac with patented reliable disk imaging technology and you will be able to restore workstations to a new, dissimilar hardware in minutes.

Join & Write a Comment

A Short Story about the Best File Recovery Software – Acronis True Image 2017
We have come a long way with backup and data protection — from backing up to floppies, external drives, CDs, Blu-ray, flash drives, SSD drives, and now to the cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now