MS Excel 2007 Cannot Open .xltm files

We have a forms program created as an .xltm file stored on a shared mapped drive. Users have Windows 7 and MS Office 2007 installed on their workstations. When clicking on this .xltm document, Excel automatically opens and shows the right path to where the file is stored; however there is a message popup "The file could not be opened as Excel detected it as bring  corrupt". On other workstations with the same configurations it seems to work just fine and once the macros are deactivated the program opens. This has become a problem as all new installations are running into this problem. Any help would be appreciated.
GeneratorAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
bigeven2002Connect With a Mentor Commented:
Ok thanks for the update, seems like something is still amiss in excel.  On one of the problem computers, can you try performing an uninstall and reinstall of office 2007.  Then after reinstall, reapply all updates and service packs, this also includes windows updates as some of them also control office behavior.  If this works then it may be an issue with deployment.

Also, if you copy the xltm file to the local drive and open it from there, does the security issue also occur?
0
 
bigeven2002Commented:
Hello,

Since it is working on previous installations and assuming the new installations are also Office 2007, compare the installed updates with the old installations vs. the new installations.  Chances are there is an update or two that needs to be applied to the new installation such as a windows patch or latest office service pack.

On the new installation, have you set the network location to be a trusted path?  In Excel 2007, go to the Office orb, choose Excel Options, then select Trust Center, then Trust Center Settings.  Go to Trusted Locations and check the box at the bottom for "allow trusted locations on my network".  Then add a new location that points to the path to the XLTM file.
0
 
GeneratorAuthor Commented:
No change with the above instructions. When opening the file in Excel I click on  "Security Warning - Some content has been disabled" - OPTIONS. This brings up the MS Office Security Options window. I then have two choices under "Security Alert and "Links" - I normally choose the two radio buttons that "Enable this Content". However under "Security Alert" I now have no options other than  "Help protect me from unknown content (recommended)". The other workstations that are working properly have a second option under the "Security Alert" section to be able to allow this unknown content. So basically I need that second option be able to get the program running. Thanks.
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
GeneratorAuthor Commented:
I have tried the re-install route but with the same results. Just wondering if an Office 2010 installation would make a difference. I'm going to test that tomorrow. Yes, I have copied the file to the local drive with the same results. I'll keep you up to date. Thanks.
0
 
bigeven2002Commented:
I see.  Ok yes go ahead and try office 2010.  I would try with a local copy of the xltm file first with 2010 just in case it makes modifications that break backward compatibility with 2007.  No reason why it should but just to be prepared.  Also I would created a backup of the network copy first too just in case.
0
 
GeneratorAuthor Commented:
Well the problem got solved when I updated Office 2007 to SP3. For some reason some of the stations were not updating properly. Thanks for your help.
0
 
bigeven2002Commented:
Certainly, glad I could help.
0
All Courses

From novice to tech pro — start learning today.