Solved

Voip phone as computer connection

Posted on 2014-10-17
8
252 Views
Last Modified: 2014-12-05
I found a strange setup at a client where they only have one drop per desk so they use their VOIP phone as network connection for the computer. I'm not very familiar with this design so I was wondering if this could cause any kind of issues in the network...


Thank you!
0
Comment
Question by:Alan Dala
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 12

Assisted Solution

by:DarinTCH
DarinTCH earned 250 total points
ID: 40387824
it is very common
Cisco...Avaya
it actually has a mini switch builtin
so the single drop runs to the phone and handles all traffic
the phone separates data and voice
the PC is plugged into the back of the phone @ the data port

the only issue is the very first connection ..when plugged in it takes a few minutes sometimes....it has to work out the 2 signals so the signal gets segregated ....usually its a separate vlan anyway
otherwise they should continue to work well
0
 
LVL 25

Assisted Solution

by:Mohammed Khawaja
Mohammed Khawaja earned 125 total points
ID: 40387837
This is common as most phones are powered over ethernet, thus they connect to the wall jacks and then the phones have a jack for PCs.  They were designed this way to ensure no additional network jacks are required (i.e. no capacity upgrade for switchports).  VOIP devices usually run on a different VLAN to ensure QoS (Quality of Service) can be implemented for voice.
0
 

Author Comment

by:Alan Dala
ID: 40389269
Thank you for your responses!

What I'm not sure that I understand is how you separate traffic with Vlans if the phone is basically the network drop for the computer. The Vlan should be created at the main switch, right? Am I missing something here?

Thank you for you help.
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
LVL 12

Expert Comment

by:DarinTCH
ID: 40389290
yes the Vlan work happens @ the switch/router
and the traffic is tagged.....with a vlan ID

but both streams of traffic head to the 'device'

inside the phone - the builtin switch decides if it is Voice or data

the voice traffic heads to the headset tagged as voice vlan

the data traffic heads to the other port - which connects tot the PC
0
 

Author Comment

by:Alan Dala
ID: 40389311
So, if I create two VLANs on the HP switch, how is the computer traffic forwarded to VLAN 1 for example and VOIP traffic to VLAN 2?

Thanks again.
0
 
LVL 25

Expert Comment

by:Mohammed Khawaja
ID: 40389341
On a Cisco switch, the configuration is as follows where two VLANs are made, 100 for data and 500 for voice:

Switch(config)#interface range fastethernet 0/1 - 2
Switch(config-if)#switchport mode access
Switch(config-if)#Switchport access vlan 100
Switch(config-if)#switchport voice vlan 500

It must be similar on a HP switch, to configure voice and data VLANs:

hostname "HPSwitchA"  
qos dscp-map 101110 priority 6 (101110 turns on Expedited Forwarding EF)  
snmp-server community "public" Unrestricted  
vlan 100  name "Vlan-Data"  
untagged 1-28  
ip address 192.168.10.1 255.255.255.0  
exit  
vlan 500  
name "Vlan-Voice"  
ip address 10.10.10.1 255.255.255.0  
qos dscp 101110  
tagged 1-28  
voice  
exit

Below is how you configure switch ports:

interface FastEthernet0/1-8
description HQ-SW-2 ===> IP Phone and PC
switchport access vlan 100
switchport mode access
switchport voice vlan 500
spanning-tree portfast
0
 
LVL 25

Assisted Solution

by:mikeleebrla
mikeleebrla earned 125 total points
ID: 40427272
Mohammed  is exactly correct. I just wanted to add that the above cisco switch setup will only work for cisco phones as it uses the proprietary CDP (Cisco Discovery Protocol) to determine that the device directly connected to the switch is a cisco phone (so it gets put in the voice vlan).

In the HP setup he provided, LLDP is used.  (Link Layer Discovery Protocol). Cisco Phones support this as well. IE if you wanted to have a Cisco Phone plugged into an HP switch, the above setup would be correct.
0
 
LVL 12

Accepted Solution

by:
DarinTCH earned 250 total points
ID: 40427704
the traffic ends up where if belongs in the long run....
it just flows thru the same physical port to get there..
the physical port being the one on the back of the VoIP phone
and the port can receive traffic from multiple vLans
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question