WSUS Error

Every time I open WSUS, it comes back with the error in the picture below.
Anyone have any ideas?

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Seth SimmonsSr. Systems AdministratorCommented:
when did this start?  were there any updates installed prior to this happening?
You might have to rebuild the WSUS by uninstall/reinstall.

Do you have the most current WSUS installed?

If its an MMC error you can try the following:

Go to the following: %appdata%\Microsoft\MMC\

Delete the wsus MMC that is in there
Seth SimmonsSr. Systems AdministratorCommented:
scroll to the last comment and see if that helps
it worked without reinstalling WSUS

WSUS (MMC) not opening
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

Is this the WSUS Server?
The WSUS console is not a native component of Windows Server. You do have to install the console to use it.
Seth SimmonsSr. Systems AdministratorCommented:
You do have to install the console to use it.

if the console wasn't installed there wouldn't be a screenshot with 'update services' mmc
Another thing to check:

Under services make sure "Update Services" is running.  If it is not running try and see if the event log is showing an error message under SQL Server and if so repair the most current version of .NET Framework to see if that fixes the error.
wonker2Author Commented:
I tried extracting the install.msp as that other article suggested and got:
As far as updates go, I am sure some have been added to Server 08. I don't got in WSUS too often, so very possible there have been some added to the server os.

Update services is running. Renaming the WSUS file didn't help.

Clients still seem to be able to check for updates but for whatever reason, I cannot get into the mmc to manage anything.
Two things:

1.  Can you create another admin profile for the server and login with it and see if that works and if so there could be an issue with your profile.

2.  Have you tried repairing .Net Framework?
Seth SimmonsSr. Systems AdministratorCommented:
do you have SP2 installed?
wonker2Author Commented:
I ran .net framework tools, no help. Haven't tried another user.
I do have, well did have SP2. When I try to run the installer the normal way, it says it needs to uninstall the services.  It tries and says an error occurred, so I cannot even uninstall/reinstall.
Seth SimmonsSr. Systems AdministratorCommented:
did you try removing the role through server manager?
wonker2Author Commented:
I get the same not  completed message... I feel as tho I am getting quite stuck.
wonker2Author Commented:
Windows Server Update Services: Removal failed
   Error: Attempt to un-install Windows Server Update Services failed with error code 0x80070643.  Fatal error during installation
wonker2Author Commented:
Seth SimmonsSr. Systems AdministratorCommented:
what database are you using?  WID or a separate SQL installation?
wonker2Author Commented:
Whatever the defaults are... WID I assume.
Seth SimmonsSr. Systems AdministratorCommented:
ok...i found an article about this error and refers to a permissions issue accessing the SQL database but seems it doesn't apply here if you are using WID.  will wait to see if that article you found resolves it
If all else fails here is something I just tested on a virtual machine:

1.  Open REGEDIT in and locate: HKLM\Software\Microsoft\Update Services\Server\Setup
2.  Change the value of “wYukonInstalled” to 0×0 (zero) and ensure that the value of “SqlInstanceIsRemote” is 0x0 (zero).
3.  Download and run the WSUS 3.0 SP2 installer. Try and uninstall the WSUS service and then re-install

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wonker2Author Commented:
This was the answer. You hit the nail right on the head! Many thanks.

Now to figure out why Server 2012R2 will not talk to WSUS SP2.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.