Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 102
  • Last Modified:

Exchange 2010 Sp3 - Kill antispam agents

In trying to determine why a couple of my users did not receive emails that passed through our spam filter, I've ran into an issue where those email's deliveries FAILED because of 'Source: AGENT'

So now Im at the point of disabling all antispam agents on that server to help figure out which one is causing this.  However right-clicking on the rules and selecting 'Disable" then restarting the Transport service does not actually disable the rules.

The GUI says the rules are all disabled, however get-transportagent still says every rule is enabled.  And the test messages still fail delivery.

I've tried restarting the transport server, as well as the mail submission, information store, EdgeSync, Service Host, and still the rules stay Enabled.

Do I have to reboot the entire server before this bloody Rules will be disabled?
0
Ben Hart
Asked:
Ben Hart
1 Solution
 
Simon Butler (Sembee)ConsultantCommented:
Do
get-transportagent | disable-transportagent

Then restart Transport. That should disable the agents.

Simon.
0
 
Ben HartAuthor Commented:
Thanks Simon.  Funny how searching for 'disabling transport agents' did not list results about this specific cmdlet.
0

Featured Post

Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now