Asterisk/Elastix/FreePBX - replace caller ID using custom context

I followed the instructions here: article in order to remove the incoming Caller ID.  The manager wants the calls to be unknown so that annoying customers are not avoided by the staff.   They have 2 lines which are answered differently so they want to know which line was called in on.  They are using an FXO card.

I edited /etc/asterisk/extensions_custom.conf to include:
[from-zaptel-callline1]
exten => _X!.1.Set(CALLERID(num)=Line1)
exten => _X!,n,Goto(from-zaptel,${EXTEN},1)

[from-zaptel-callline2]
exten => _X!.1.Set(CALLERID(num)=Line2)
exten => _X!,n,Goto(from-zaptel,${EXTEN},1)

Open in new window

I then set the context in /etc/asterisk/dahdi-channels.conf to:
;;; line="2 OPVXA1200/12/1 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel-callline1
channel => 2
callerid=
group=
context=default

;;; line="3 OPVXA1200/12/2 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel-callline2
channel => 3
callerid=
group=
context=default

Open in new window


After amportal restart incoming calls are terminated with the following:
   -- Starting simple switch on 'DAHDI/4-1'
  == Starting DAHDI/4-1 at from-zaptel-callline1,s,1 failed so falling back to exten 's'
  == Starting DAHDI/4-1 at from-zaptel-callline1,s,1 still failed so falling back to context 'default'
    -- Executing [s@default:1] Playback("DAHDI/4-1", "vm-goodbye") in new stack

Open in new window


Any help fixing the context so it does not fail but rather replaces the caller ID as it should would be appreciated.

Thanks.
LVL 2
YMartinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PhonebuffCommented:
Well,

      You set set the Verbosity and debug levels up in your CLI, but I suspect that your "=Line1" is not a valid numeric variable and that your use of it as the right side of your assignment is incorrect.    

http://www.voip-info.org/wiki/view/Setting+Callerid

     ============
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
YMartinAuthor Commented:
Thanks Phonebuff,

I think that is the problem.  I have tried to schedule a test of the new code with the client but he has been too busy.  I will let you know but I am pretty sure this was the problem.
0
YMartinAuthor Commented:
That was one problem. the other problem was periods instead of commas and also since I didn't need to match numbers changed it to this and its now working.  This code now blocks the caller ID name and number.  That's how they want it.

exten => s,1,Set(CALLERID(all)=Line1 <0>)
exten => s,n,Goto(from-zaptel,${EXTEN},1)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Voice Over IP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.