Error: Unable to find the requested .Net Framework Data Provider. It may not be installed.

Receiving this error once published to Webyhost4life server (see here http://www.bribie.soccerclubstats.com/)

I guess the problem is with my connection string? Not really sure. I'm also not sure why the error references the physical location of my application on my local PC (where it works fine with an alternative connection string)

Here is the connection string section from my config...

  <connectionStrings>
  <add name="SQLiteEntities" connectionString="metadata=res://*/Model1.csdl|res://*/Model1.ssdl|res://*/Model1.msl;provider=System.Data.SQLite;provider connection string=&quot;data source=~/App_Data/1.080000.iKeepScore;&quot;"   providerName="System.Data.EntityClient" />
  </connectionStrings
LVL 7
Clever_BobAsked:
Who is Participating?
 
David Johnson, CD, MVPOwnerCommented:
Webhost4lite doesn't support sqlite.
this is what they support
MS Access (Multi Language) 
MySQL Database
MSSQL 2008 Database
Microsoft SQL Server Management Studio
MSSQL Fulltext Search

Open in new window

0
 
sammySeltzerCommented:
Two things:

One, if it is referencing your local PC, can you make sure that you are uploading the correct files?

Second, this might be an instance where your .net framework is corrupt.

This link explains how you can repair that if it were the problem.

http://support.microsoft.com/kb/306160/en-us
0
 
Clever_BobAuthor Commented:
thanks for the input.

Do you mean the framework on the server? Its hosted by Webhost4life

I'm using the 'Publish' feature in Visual Studio 2010, so presumably the publishing mechanism is sound
0
 
Clever_BobAuthor Commented:
Thanks David - how can they unsupport it though? Can they specifically disable it somehow? Its just a file sitting in the application directory.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.