Solved

Disable Java update on Terminal Server

Posted on 2014-10-21
5
277 Views
Last Modified: 2014-10-23
I need a way to control Java Versioning on our Terminal Server Box. Users are continually getting prompted to update and of course do so and it breaks some of our web applications.  What ways are there to control this. I am looking to keep it at Java7 Update60. Running on 2008 R2.

Thanks
0
Comment
Question by:ICSLogistics
  • 2
  • 2
5 Comments
 
LVL 37

Expert Comment

by:Gerwin Jansen
ID: 40394741
The Java applet in the Control Panel?
0
 

Author Comment

by:ICSLogistics
ID: 40394755
Doesn't work on Terminal Servers. Also have added registry key in:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft\Java Update\Policy

which is supposed to suppress non-administrators from getting update prompts.

Also have added Deployment.Properties as follows:

#deployment.properties
#Wed Jul 16 12:03:34 EDT 2014
deployment.modified.timestamp=1405526614354
deployment.version=7.21
deployment.security.level=MEDIUM
deployment.expiration.check.enabled.10.60.2=false
deployment.security.mixcode=HIDE_RUN
deployment.javaws.shortcut=NEVER
deployment.javaws.autodownload=NEVER
deployment.expiration.check.enabled=false
deployment.user.cachedir=D\:\\JavaCache
deployment.capture.mime.types=true
deployment.javapi.cache.update=true
deployment.browser.path=C\:\\Program Files (x86)\\Internet Explorer\\iexplore.exe
#Java Deployment jre's
#Wed Jul 16 12:03:34 EDT 2014
deployment.javaws.jre.0.registered=true
deployment.javaws.jre.0.platform=1.7
deployment.javaws.jre.0.osname=Windows
deployment.javaws.jre.0.path=C\:\\Program Files (x86)\\Java\\jre7\\bin\\javaw.exe
deployment.javaws.jre.0.product=1.7.0_60
deployment.javaws.jre.0.osarch=x86
deployment.javaws.jre.0.location=http\://java.sun.com/products/autodl/j2se
deployment.javaws.jre.0.enabled=true
deployment.javaws.jre.0.args=

Nothing has worked.
0
 
LVL 33

Expert Comment

by:Big Monty
ID: 40394845
did you try disabling it using msconfig?

try these steps:
- go to Start->Run and type in msconfig
- click on the start up tag
- find "Java Platform SE Auto Updater" and un-check it
- Click Apply and reboot

source
0
 
LVL 37

Accepted Solution

by:
Gerwin Jansen earned 500 total points
ID: 40395153
0
 

Author Closing Comment

by:ICSLogistics
ID: 40399273
Seems so simple but did a great job of what I was trying to do.
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
how can i Return this word's max repeat count? 2 16
jqury 17 28
why $(this).attr('id'); function not returning value ? 9 33
innerHTML 7 12
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question