SQL Developer frequently disconnecting

I connect with SQL developer on my Windows 7 machine to my server Centos 6.5 running Oracle XE 11G.

I am having an issue where SQL Developer is frequently disconnecting if I don't run a query or do anything for about few minutes. I keep having to reconnect.

Is there anyway to fix this? Thanks.
sysautomationAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Gerwin Jansen, EE MVETopic Advisor Commented:
I don't experience this, is your CentOS virtual?

You could try this keep alive plugin: https://scristalli.github.io/SQL-Developer-4-keepalive/
0
sysautomationAuthor Commented:
Yes my CentOS is virtual
0
Gerwin Jansen, EE MVETopic Advisor Commented:
The it's probably the virtual env that's causing this, do you have other connections to the same server that disconnect as well?
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

sysautomationAuthor Commented:
Ssh doesn't disconnect. I am using Xen
0
Gerwin Jansen, EE MVETopic Advisor Commented:
Try the plugin or enable DBMS output and set polling frequency to one minute.
0
johnsoneSenior Oracle DBACommented:
I would set the SQLNET.EXPIRE_TIME parameter in the sqlnet.ora file on the client and the server.

Documentation for the parameter is here -> http://docs.oracle.com/cd/E11882_01/network.112/e41945/profile.htm#sthref823

It can cause disconnects.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Gerwin Jansen, EE MVETopic Advisor Commented:
@johnsone - Interesting, I never set that parameter, no disconnects for me. Think it's a server-only parameter btw
0
johnsoneSenior Oracle DBACommented:
It has a default value which works most of the time, but it can be a cause for this.

I do believe it is a server only parameter, but it never hurts to set it on both sides.
0
sysautomationAuthor Commented:
There's no file sqlnet.ora in $ ORACLE_HOME/network/admin in XE.
I checked several XE servers.
0
johnsoneSenior Oracle DBACommented:
No file just means you are taking all the defaults.  You can create the file and put the one line in it.
0
Gerwin Jansen, EE MVETopic Advisor Commented:
No closing  comment, means that the expire_time setting works?
0
sysautomationAuthor Commented:
I did it on the server and informed the developer. I haven't received his feedback yet.
0
Gerwin Jansen, EE MVETopic Advisor Commented:
>> I haven't received his feedback yet
Hmm, would have been nice if you closed after confirmation. If the setting doesn't work we may need to re-open this question for you ;)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.