Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 715
  • Last Modified:

Crystal reports 2013 only showing first letter of memo field

We have recently upgraded to Windows 7 and Crystal Reports 2013. And now I have a simple report that has a memo field that Crystal is only pulling through the first character. I have checked the field and ticked 'can grow etc'.

If I go back to Crystal 2008 in Windows XP, the full data of the field is pulled through.
If I use Crystal 2008 on Windows 7, only the first character is pulled through.

To me it looks like something to do with Windows 7. On XP we use the Microsoft ODBC connection to our Oracle database, on Windows 7, we use the Oracle 11g client ODBC connection. (As Microsoft ODBC is no longer available with Windows7)

What do the experts know? Is there something within Crystal 2013 that we need to do differently to use the memo field. Or is there an MDAC for Windows 7 we can install (and if so where/how)

Or, can we convert the memo field within Crystal to another type to then get it to display. However I guess if Crystal isn't getting the data through the connection in the first place, then a conversion is not going to work.
0
nicbak13
Asked:
nicbak13
1 Solution
 
nicbak13Author Commented:
Found answer ------> Crystal 2013 requires you to use its internal drivers for Oracle. Once you update (Set Database location) using the internal drivers, the problem is fixed.

Clever me I guess
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now