Solved

Out of Office email doesn't work for all mailbox in one database only.

Posted on 2014-10-22
23
318 Views
Last Modified: 2014-10-24
Hi People,

May I know what could be the culprit or problem when all mailbox users in one particular database only cannot send Out Of Office email ?

This is happening on Exchange Server 2010 SP2.

Thanks,
0
Comment
  • 13
  • 10
23 Comments
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40397980
Can you run the Synchronization, Notification, Availability, and Automatic Replies test from www.exrca.com for one of those problem users and post the result here?
0
 
LVL 7

Author Comment

by:Senior IT System Engineer
ID: 40398338
Ok, here's the result for the failed part only:

Setting and retrieving user OOF settings.
       The Microsoft Connectivity Analyzer failed to set and retrieve user Automatic Reply (OOF) settings.
       
      Additional Details
       
Elapsed Time: 1339 ms.
       
      Test Steps
       
      Getting user Automatic Replies (OOF) settings and confirming them against expected values.
       The Microsoft Connectivity Analyzer failed to retrieve and confirm user OOF settings.
       
      Additional Details
       
The Automatic Replies (OOF) test can't be performed because Automatic Replies are enabled.
Last EWS request:
<Trace Tag="EwsRequest" Tid="53" Time="2014-10-23 00:28:22Z" Version="15.00.1029.000">
<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:m="http://schemas.microsoft.com/exchange/services/2006/messages" xmlns:t="http://schemas.microsoft.com/exchange/services/2006/types" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<t:RequestServerVersion Version="Exchange2007_SP1" />
<t:TimeZoneContext>
<t:TimeZoneDefinition Id="Pacific Standard Time" />
</t:TimeZoneContext>
</soap:Header>
<soap:Body>
<m:GetUserOofSettingsRequest>
<t:Mailbox>
<t:Address>a-test@domain.com</t:Address>
</t:Mailbox>
</m:GetUserOofSettingsRequest>
</soap:Body>
</soap:Envelope>
</Trace>

Last EWS response:
<Trace Tag="EwsResponse" Tid="53" Time="2014-10-23 00:28:23Z" Version="15.00.1029.000">
<?xml version="1.0" encoding="utf-8"?>
<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/">
<s:Header>
<h:ServerVersionInfo MajorVersion="14" MinorVersion="2" MajorBuildNumber="247" MinorBuildNumber="3" Version="Exchange2010_SP2" xmlns:h="http://schemas.microsoft.com/exchange/services/2006/types" xmlns="http://schemas.microsoft.com/exchange/services/2006/types" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" />
</s:Header>
<s:Body xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<GetUserOofSettingsResponse xmlns="http://schemas.microsoft.com/exchange/services/2006/messages">
<ResponseMessage ResponseClass="Success">
<ResponseCode>NoError</ResponseCode>
</ResponseMessage>
<OofSettings xmlns="http://schemas.microsoft.com/exchange/services/2006/types">
<OofState>Scheduled</OofState>
<ExternalAudience>All</ExternalAudience>
<Duration>
<StartTime>2014-10-22T23:00:00Z</StartTime>
<EndTime>2014-10-23T23:00:00Z</EndTime>
</Duration>
<InternalReply xml:lang="en-AU">
<Message>&lt;html&gt; &lt;body&gt; &lt;div style="font-size:13px; font-family:Tahoma"&gt;&lt;strong&gt;&lt;font color="#ff0000" size="4"&gt;O3 ! to internal&lt;/font&gt;&lt;/strong&gt;&lt;/div&gt; &lt;/body&gt; &lt;/html&gt; </Message>
</InternalReply>
<ExternalReply xml:lang="en-AU">
<Message>&lt;html&gt; &lt;body&gt; &lt;div style="font-size:13px; font-family:Tahoma"&gt;&lt;strong&gt;&lt;font color="#ff0000" size="4"&gt;O3 ! to external&lt;/font&gt;&lt;/strong&gt;&lt;/div&gt; &lt;/body&gt; &lt;/html&gt; </Message>
</ExternalReply>
</OofSettings>
<AllowExternalOof>All</AllowExternalOof>
</GetUserOofSettingsResponse>
</s:Body>
</s:Envelope>
</Trace>

Elapsed Time: 1339 ms.
0
 
LVL 7

Author Comment

by:Senior IT System Engineer
ID: 40398342
in my environment I only got Exchange 2010 SP2 servers, but how come there is Exchange 2007 SP1 entry listed in the XML reply ?

<t:RequestServerVersion Version="Exchange2007_SP1" />
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40398512
<t:RequestServerVersion Version="Exchange2007_SP1" />

I believe that is just looking for a minimum of Exchange 2007 SP1.

Looks like the test failed because the test account already has Out of Office turned on. Can you turn Out of Office off and try again.
0
 
LVL 7

Author Comment

by:Senior IT System Engineer
ID: 40398521
Hi Gareth,

Somehow the behaviour is strange. It only affects all users in certain mailbox database.

when my own mailbox and the test mailbox resides in any other mailbox DB in Server-A, everything works great, OOF delivered successfully without issue.

but when I moved myself and the test mailbox into the Server-B within this one particular mailbox DB, no OOF can be delivered at all ? not even sent out based on my Message Tracking log.

how come this problem only affects one single mailbox DB only ? but works great when the mailbox migrated outside this mailbox Database in any server ?
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40398523
So is the issue affecting a single database or a single server? Or, is this the only database on that other server? I was unaware you had more than one server.

If so, then it is likely an issue with your URLs.

But really need you to run this test against one of the problem users with their OOF disabled.
0
 
LVL 7

Author Comment

by:Senior IT System Engineer
ID: 40398526
There are 2x mailbox server that is stand alone no DAG configured, namely PRODMBX01 and PRODMBX02.

The content of Exchange mailbox database in PRODMBX01 are:
Development Team DB
Architecture DB
New Clients DB
IT Department DB

The content of Exchange mailbox database in PRODMBX02 are:
Executive Team DB
ATM Monitoring Team DB
Treasury Team DB
Head office users DB

Somehow when I moved my mailbox from PRODMBX01\IT Department DB into PRODMBX02\Executive Team DB, the OOF is not working. But when I migrate myself back to any other DB within PRODMBX02 or in PRODMBX01 all is good.
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40398530
How many users are we talking about in Executive Team DB? The quick fix could be to create a new DB and move all users to it. Then remove the problem database.

With two mailbox servers, any reason you didn't go for a DAG?
0
 
LVL 7

Author Comment

by:Senior IT System Engineer
ID: 40398533
ok, when I re-execute the test again after turning of the OOF message on the test mailbox and also moving back the test mailbox into the PRODMBX02\Executive Team DB, the result was all good with no error, except one warning with the alternative / potential autodiscover URL

      Attempting to test potential Autodiscover URL https://domain.com:443/Autodiscover/Autodiscover.xml
       Testing of this potential Autodiscover URL failed.

        Attempting to test potential Autodiscover URL https://autodiscover.domain.com:443/Autodiscover/Autodiscover.xml
       Testing of the Autodiscover URL was successful.
0
 
LVL 7

Author Comment

by:Senior IT System Engineer
ID: 40398535
The reason is that I don't have the storage capacity yet to hold all mailboxes DB in one Site.

There are 115 mailboxes affected for senior managers and C-level execs affected. not sure why this particular mailbox DB having the issue with OOF.
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40398554
Just to take a step back. These users can set the OOF. But it never sends out when configured?

Any Transport Rules in place?

Try running on one of the problem users and list the output here.

Get-Mailbox *problemuser* | fl *oof*
0
 
LVL 7

Author Comment

by:Senior IT System Engineer
ID: 40398560
yes, it never sends out at all.

After I set my OOF setting from my Outlook 2010, it works fine when I'm not in the PRODMBX02\Executive Team DB.
no, there is no Transport Rules in place to stop the OOF to be sent out.

here's the script htat I use to check OOF email was sent:

Get-TransportServer | Get-MessageTrackingLog -Sender 'IT-admin@domain.com' -Start '21/10/2014 10:00 AM' -End '23/10/2014 6:00 PM' -ResultSize Unlimited -EventId SEND | ? {($_.MessageSubject -match "Automatic reply:")} | Select Timestamp, ClientHostname, Sender, Recipients, MessageSubject, RecipientStatus | ft

Open in new window


I can't see any result when my mailbox is in the PRODMBX02\Executive Team DB
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40398562
Try running on one of the problem users and list the output here.

 Get-Mailbox *problemuser* | fl *oof*
0
 
LVL 7

Author Comment

by:Senior IT System Engineer
ID: 40398565
ok, the result is

ExternalOofOptions : External

Open in new window

0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40399259
That looks normal. I am running out of ideas. I would still say creating a new database and moving these users could be a quick fix. But if you want to investigate further I can alert the mods to find more experts to weigh in.
0
 
LVL 7

Author Comment

by:Senior IT System Engineer
ID: 40399267
yes please.

I'm not sure why this OOF message was not even sent out from the mailbox. the message tracking log returns no result at all.
0
 
LVL 7

Author Comment

by:Senior IT System Engineer
ID: 40400658
FYI: At midnight when I tried to send email from my home GMail account to the test mailbox and my own mailbox, I can receive the OOF email externally, but not during the business day time as it is now.
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40400902
I wonder if you are just receiving the limit for OOFs. It could be the OOF is limited to one OOF per sender per 24 hours.
0
 
LVL 7

Author Comment

by:Senior IT System Engineer
ID: 40400936
ok so in this case, where to see that limit from Exchange Server 2010 ?
0
 
LVL 7

Author Comment

by:Senior IT System Engineer
ID: 40400991
Does the Out of office email message get send once every 12 hours or 24 hours for one email sender ?
0
 
LVL 31

Accepted Solution

by:
Gareth Gudger earned 500 total points
ID: 40403400
I think its every 24 hours. They basically do it to prevent OOF infinite loops. And even the possibility someone could DoS attack you by creating countless OOF loops.

Basically, someone sends a message and then sticks on their OOF (or maybe they never turned if off). That message goes to a recipient who has an OOF turned on. And before you know each OOF is just replying to one another in an endless loop.

Get enough of those going and its going to be bad.

I did some research but I don't see a way to change this default interval.
0
 
LVL 7

Author Comment

by:Senior IT System Engineer
ID: 40403455
Cool so in this case it is a known default behaviour of OOF.

Thanks for the clarification
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40403457
Glad to help.
0

Join & Write a Comment

Suggested Solutions

In this article, we will see the basic design consideration while designing a Multi-tenant web application in a simple manner. Though, many frameworks are available in the market to develop a multi - tenant application, but do they provide data, cod…
This article will help you understand what HashTables are and how to use them in PowerShell.
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now