• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 130
  • Last Modified:

Excel CELL Formatting

Hello

I have a sheet with one column and 15 lines

Like in example, some cells are in numeric data in text format  (like A1 to A7) and some cells are in text format (like A8 to A12)

I recognize evey type all cells by the littre green triangle upper left of the cells

I want to convert all cells as TEXT (no more numéric data formated as text)
So the green triangle disapears and all data become text data

Thank you
FFF.xlsx
0
gadsad
Asked:
gadsad
  • 3
  • 2
  • 2
  • +1
1 Solution
 
Haris DjulicCommented:
Just use the TEXT formula

+TEXT(A1;"0")

I used the formula on you sample, you can find it attached
FFF.xlsx
0
 
gadsadAuthor Commented:
Fine

But when I try to convert the formula to TEXT (copy, paste options + values) the little triangle comes back

How do I convert the formula (which works fine) to real text labels, without coming back to values  ?

Thanks
0
 
Rory ArchibaldCommented:
I don't follow. The data already is text - that's what the triangle is telling you. If you just don't want to see the warning any more, either turn it off in Excel options, or select all the data, then click Ignore Error in the smart tag.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
gadsadAuthor Commented:
in A1 I have 0000025 (with the triangle)
in B1 I have =TEXT(A1;"0000000") and 0000025 displays fine without the triangle (that is the correct answer I am looking for)

I want finally to replace A1 by B1 but I need first to convert the formula to something before copying

("copy/paste as value", return the 0000025 to value)

I hope it is clear

Thanks
0
 
Haris DjulicCommented:
Then you format columns as text and copy/paste as value to it
0
 
Rob HensonIT & Database AssistantCommented:
The little green triangle is a Warning Message telling you that you have "Numbers formatted as text".

As Rory said earlier, you have a few options:
1) Switch off the Error Warning in Excel Options
2) Highlight the area, right Click and Ignore Warning
3) Convert to numbers and have formatted such that you see the leading zeros

Thanks
Rob H
0
 
Rory ArchibaldCommented:
The only reason B1 doesn't have the indicator is because it's a formula. If you convert it to values, you'll see the triangle again. Just turn the warning off.
0
 
gadsadAuthor Commented:
Its finally OK

THanks to all
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now