Solved

Trouble with Internet Settings in GPO Not applying

Posted on 2014-10-23
4
504 Views
Last Modified: 2014-10-24
Hello - we have a Windows 2008 R2 AD network with Windows 7 clients.  We are trying to push out an Internet proxy through a GPO using the registry settings updates through the GPMC and a policy we built on a Windows 7 machine that has the correct proxy settings.  The GPO created successfully, and a test Win7 machine seems to take the policy ok, but the Internet Settings (IE11) do not change.  Not sure why.

thanks
0
Comment
Question by:Damian_Gardner
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 29

Expert Comment

by:becraig
ID: 40401108
You will need to download the IE11 GPO templates:

There is a complete walkthrough at the url below:
http://www.alexheer.co.uk/it-blog/configuring-ie11-settings-via-group-policy
0
 

Author Comment

by:Damian_Gardner
ID: 40402167
Ok great.  And this should then allow Internet proxy settings to be set across the LAN for IE 10/11 users?

thanks
0
 
LVL 29

Accepted Solution

by:
becraig earned 500 total points
ID: 40402408
As indicated in the post:
Proxy settings
So, as tried above, I was unable to set the proxy server using the 'Internet Settings' GPO options. I also tried without success, using the 'Internet Explorer Maintenance' settings, which is what I had always used in IE9 and previous versions.
I therefore had to set the proxy settings using the registry and Group Policy Preferences (GPP).

In the GPO, I expanded User Configuration > Preferences > Registry. I then created three new registry items for the following:

HKCU\Software\Microsoft\Windows\CurrentVersion\InternetSettings\ProxyEnable To enable, set the REG_DWORD to 00000001
HKCU\Software\Microsoft\Windows\CurrentVersion\InternetSettings\ProxyServer Set the REG_SZ to your proxy server’s IP or hostname:8080 (i.e proxy:8080 or 192.168.1.10:8080)
HKCU\Software\Microsoft\Windows\CurrentVersion\InternetSettings\ProxyOverride
Set the REG_SZ to list all the sites which should bypass the proxy, separated by a semi-colon ‘;’. If  you need to enable the option ‘Do not use proxy server for local (Intranet) addresses’ then you will need to add ‘;<local> at the end of the ProxyOverride key. There is no separate key for this setting.

As far as which computers pick this up, will be based on which OU / Computers you apply the GPO to.
0
 

Author Closing Comment

by:Damian_Gardner
ID: 40402904
Great - this worked.  thanks
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article runs through the process of deploying a single EXE application selectively to a group of user.
This article explains the steps required to use the default Photos screensaver to display branding/corporate images
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question