Solved

Why are MS Access 2000 files in the networked file share opening as Read Only when I have full control?

Posted on 2014-10-23
33
305 Views
Last Modified: 2014-10-31
I uploaded an Access 2000 db from a backup to a File Share in Windows Server 2003.
I am an administrator and have full control in the File Share and the Access DB.

No issue opening the DB locally. However, when accessed over the network from the File Share the DB will only open as read only even though I have full control.  Any ideas?  Thanks,
0
Comment
Question by:PDSWSS
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 17
  • 12
  • 4
33 Comments
 
LVL 58
ID: 40400814
Not sure I understand the ok local part....but Right  click on the file and make sure it's not read only for a start.

J
0
 

Author Comment

by:PDSWSS
ID: 40400825
local part =  on computer  - already did that - checked all permissions and read only is not chosen.

I am an admin who set up the computer and have full control. Therefore read only is difficult to understand.
These files were on a shared drive on another server (until it died) without this issue. Seems specific to this server. Thanks
0
 
LVL 58
ID: 40400842
Sorry, should have been clearer:  was talking about file attributes,  not permissions.   Also, did you place it in a directory you made or a pre-existing one?   Some directories in windows are special,  like c:\program files

Jim
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 75
ID: 40400861
Any chance it;s in a ZIP file ?
0
 

Author Comment

by:PDSWSS
ID: 40400878
no
0
 

Author Comment

by:PDSWSS
ID: 40400885
Please see attached.  I have never seen this message when opening an MS Access File on a network share before.  Have either of you seen this?  Maybe this has something to do with the issue.

Thanks,
Screen-Shot-2014-10-23-at-6.24.03-PM.png
0
 

Author Comment

by:PDSWSS
ID: 40400891
Just tested an excel file. Don't get the message and opens normally.  Must be specific to Access DB on this server?
0
 
LVL 75
ID: 40400918
Is this DB in a Trusted Location ?
If not ... various errors will occur ... possibly this one ...

Also ... do you have the setting shown below on your local workstation:

Macro (in)Security
0
 
LVL 58

Accepted Solution

by:
Jim Dettman (Microsoft MVP/ EE MVE) earned 500 total points
ID: 40400923
Yes, the network detection is not seeing the shared folder as a trusted site

Open control panel,  select Internet options, the select the security tab.

You can click on local network or trusted sites.   Add the drive letter or IP address of the server.

Clear the require server verification check box.

Save and close.  Should be able to open db now without the message.

Jim
0
 

Author Comment

by:PDSWSS
ID: 40402122
Database MX-  this is an Access 2000 DB. Do you know how to enable all macros in Access 2000?
0
 

Author Comment

by:PDSWSS
ID: 40402229
Jim Dettman

I added the IP address of the server to Trusted sites - didn't solve issue.

"Add drive letter or ..."    What is the correct format to add the file share path to Trusted sites?
0
 
LVL 75
ID: 40402244
I never used A2007 ... but it's somewhere on the Options menu ...
Jim ?
0
 
LVL 58
ID: 40402246
If I enter a drive letter, it ends up looking like this:

screen shot security settings
 at this client, even though all servers are on the same subnet, I get the warning unless the entry is added.

Jim.
0
 
LVL 58
ID: 40402254
BTW, in Access 2000, trusted locations didn't exist and neither does macro security.

Jim.
0
 

Author Comment

by:PDSWSS
ID: 40402282
"at this client, even though all servers are on the same subnet, I get the warning unless the entry is added."

Do you mean this entry  "file://IP"  ?
0
 
LVL 58
ID: 40402321
Yes.  I type P: in the box, and it converted it to what you see.

The auto network detection didn't work, so I had to add it under the local intranet tab.  Once I did that, the message went away.

I never dug into it, but I believe it was related to a security patch as the message kick-in after several years (it may have been when IE 11.0 was installed, but not positive).

Jim.
0
 

Author Comment

by:PDSWSS
ID: 40402342
Tried on a share on a server with Windows Server 2008 R2 and didn't have the issue. Unfortunately for security reasons can not use this server for access to this DB.

Something about the server is causing the Read only issue.  Not clear what it is.
0
 

Author Comment

by:PDSWSS
ID: 40402348
FYI wrote the previous post before seeing your last post. Thanks
0
 

Author Comment

by:PDSWSS
ID: 40402367
"The auto network detection didn't work, so I had to add it under the local intranet tab.  Once I did that, the message went away."

Tried this and did not make a difference.  Since do not get the read only message on a different server
must have something to do with the security configuration of the server. But don't know what.  Thanks,
0
 
LVL 58
ID: 40402400
Hum....just to be clear, are we talking about different errors or is it just the one that you posted the screen shot above for?

If the latter, did you add it under "Local Intranet"?

If yes, then the security settings for that designation may be set to high or have been customized.

You may also want to try "Trusted sites".

Jim.
0
 

Author Comment

by:PDSWSS
ID: 40402442
Hum....just to be clear, are we talking about different errors or is it just the one that you posted the screen shot above for?
Same error
If the latter, did you add it under "Local Intranet"?
Yes. Tried trusted sites first. Then local intranet.

If yes, then the security settings for that designation may be set to high or have been customized.
Since I was able to open the Access 2000 db without the read-only message from a Share on another server don't think this would be the issue.

You may also want to try "Trusted sites".  Please see above

Very strange issue. Will create another file share on this server and test from the new share.
0
 
LVL 58
ID: 40402458
<<If yes, then the security settings for that designation may be set to high or have been customized.>>

<<Since I was able to open the Access 2000 db without the read-only message from a Share on another server don't think this would be the issue.>>

 Another server maybe falling into another zone, but testing with a new file share would be a good idea.

Generally when you can't figure out what's going on, it's often helpful to re-trace your steps.

Jim.
0
 

Author Comment

by:PDSWSS
ID: 40402594
Set up a new file share and now don't get the issue.

However, as you probably know the default setting for a new file share is  "read only"
So the file share is  "read only" and the Access Files Open as if they were NOT "read only."
Appears to solve the issue but not really comfortable with a solution that does not appear to make sense.
Have you ever seen this type of absurdity?  Makes my mind spin.  


Thanks
0
 
LVL 58
ID: 40403979
<<So the file share is  "read only" and the Access Files Open as if they were NOT "read only.">>

 That's quite odd.  The files should be read-only.

 File share and directory/file permissions are separate of course, but the most restrictive are supposed to be what's used between the two.

 I don't think I'd rest until I figured this one out.

Jim.
0
 

Author Comment

by:PDSWSS
ID: 40413967
Still testing this solution. Will award points when done.  Thanks
0
 

Author Comment

by:PDSWSS
ID: 40414290
Jim Dettman:

I have looked at this issue more carefully. I had assumed when I unset read only attribute that
the folder was "read-only."  Very strange but setting to read only after I choose apply and close does not
hold.  When I recheck security on the folder its back to read only. Tried unsetting read only many times.

Please advise.  What is going on with this server?
0
 

Author Comment

by:PDSWSS
ID: 40414865
Jim Dettman,

Your solution appeared to work for me but not other clients.  They still get "read only" when opening
MS access dBs on the file share even though they have full control.

The read only attribute will not remain unchecked. I uncheck apply, close and when I reopen it is greyed out.
I have asked another question to address this issue. Please take a look. Thanks
0
 
LVL 58
ID: 40415546
<<Very strange but setting to read only after I choose apply and close does not
hold.  When I recheck security on the folder its back to read only. Tried unsetting read only many times.>>

  The read-only attribute is tied to a feature in the OS (forget which one off-hand).   You can work around it by setting the read-only attribute from the cmd line with ATTRIB -r

 Also, I believe taking ownership of the file helps work around the issue and allows you to then set it through the GUI.

 Last, I know with executable's, you often need to "unblock" them from the file properties dialog, at which point they become read-write.  That should not be the case here though.

  I haven't worked with 2010 directly myself yet, so I'm not sure what's going on.  Always seems to be a new wrinkle with every new OS or security patch when it comes to security.

I just had a client this morning have a problem with the ADP web site.  Worked fine two weeks ago, but some type of security patch was applied, and as a result, she couldn't view any documents.

Jim.
0
 

Author Comment

by:PDSWSS
ID: 40415688
Thanks for the feedback. However, this is  Access 2000 not 2010.
0
 

Author Comment

by:PDSWSS
ID: 40415753
Jim Dettman

Looked more closely and see that its only the folders that continue to have the greyed out check box for read only.

The files inside the folders have an empty box next to read only attribute yet some users still only get read only when opening  Access 2000 dbs.  Thanks
0
 
LVL 58
ID: 40415806
<<Thanks for the feedback. However, this is  Access 2000 not 2010. >>

I'm bating well today; got my questions mixed up, plus a typo.   I meant (and thought) I was referring to Windows 2012 server.

 What is the path your storing the DB in?

 If it's your own, then there is no harm in resetting the owner and security from the top root all the way down.   I'd make the owner the "everyone" group as a test, with full control.

 or if you'd like, take some screen shots of the share, directory security, and the file property box for one of the DB's and post here.

Jim.
0
 
LVL 75
ID: 40416116
Good thing you get a break next week Jim :-)
0
 
LVL 58
ID: 40416176
<<Good thing you get a break next week Jim >>

Hah...one would think, but for me it will even be busier than usual.  See you soon.

Jim.
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You need to know the location of the Office templates folder, so that when you create new templates, they are saved to that location, and thus are available for selection when creating new documents.  The steps to find the Templates folder path are …
Did you know that more than 4 billion data records have been recorded as lost or stolen since 2013? It was a staggering number brought to our attention during last week’s ManageEngine webinar, where attendees received a comprehensive look at the ma…
Learn how to number pages in an Access report over each group. Activate two pass printing by referencing the pages property: Add code to the Page Footers OnFormat event to capture the pages as there occur for each group. Use the pages property to …
With Microsoft Access, learn how to start a database in different ways and produce different start-up actions allowing you to use a single database to perform multiple tasks. Specify a start-up form through options: Specify an Autoexec macro: Us…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question