Solved

How to Get DHCP from a Windows 2012 Server for a VLAN

Posted on 2014-10-24
5
220 Views
Last Modified: 2014-11-11
Hello,
    We have the following Situation:
VLAN 1 = DATA
VLAN 20 = PHONES
Windows Server 2012 - DC & DHCP - This is a VM
Cisco 3560 Switch

Basically, we need the port that the Server is plugged into to be able to process DHCP requests from both VLANS. Unfortunately, each port can only belong to one VLAN, and even if we set Voice-Vlan as 20 on the port, it does not hand out DHCP addresses. If we set it as a member of 20, we loose data connectivity. How do we go about doing this?
0
Comment
Question by:JesusFreak42
5 Comments
 
LVL 6

Accepted Solution

by:
Tim Phillips earned 350 total points
ID: 40402648
You need to do IP Helper addresses.  This is setup on your router.  The router is told where to get DHCP leases.  Do you have a Cisco router?  Then the request is correlated with your IP Scopes on the server.
0
 
LVL 6

Assisted Solution

by:Wylie Bayes
Wylie Bayes earned 150 total points
ID: 40402657
To follow up what Tim is saying about the IP Helper addresses he is correct.

It is very much possible to have more than one vlan assigned to a single port.  It's called "Trunking" , specifically 802.1q.   So by configuring a port as a Trunk you can say allow vlans 1, 2, 3, 4 and 5 to all talk on this port.
0
 
LVL 11

Expert Comment

by:naderz
ID: 40402659
Before we begin: it is best practice to NOT use Vlan 1. Create another Vlan for Data and use that instead of 1.

Whether you use Vlan 1 or not here is the procedure:

On the switch create two virtual interfaces: one for the Data Vlan and one for the Voice Vlan. I will use your examples above:

interface vlan 1
 description Data
 ip address give-it-some IP address

interface vlan 20
 description Voice
 ip address give-it-some IP address
 ip helper-address ip-address-of-the-dhcp-server

plugin the dhcp server in an interface on the Data Vlan (in your case Vlan 1)

And, as long as your DHCP scopes are setup correctly all should work.

Please ask if any of this is not clear.
0
 
LVL 8

Expert Comment

by:R_Edwards
ID: 40402660
VMware recommends utilizing VLAN technology to establish dedicated subnets for ESX/ESXi management, VMotion, and iSCSI network traffic.

 Unnecessary VLAN traffic on a TRUNK port that connects to ESX can cause major performance issues.

you basically need to trunk your switchport on your switch.

•interface GigabitEthernet1/1
•description VMware ESX - Trunk A - NIC 0 – Port Description
•switchport trunk encapsulation dot1q – ESX only supports dot1q and not ISL
•switchport trunk allowed vlan 100,200 – Allowed VLANs
•switchport mode trunk – Enables Trunk
•switchport nonegotiate – ESX/ESXi does not support DTP dynamic trunking protocol. When configuring trunk port, set it to nonegotiate.
•spanning-tree portfast trunk – Enables PortFast on the interface when it is in trunk mode


on the vm vswitch side
•esxcfg-vswitch [options] [vswitch[:ports]]
•esxcfg-vswitch -v [VLANID] -p [port group name] [vswitch[:ports]]
•esxcfg-vswitch -v 200 -p "Virtual Machine Network 2" vSwitch1


here is a link:

http://kb.vmware.com/selfservice/search.do?cmd=displayKC&docType=kc&docTypeID=DT_KB_1_1&externalId=1004074

-=Richard
0
 
LVL 11

Expert Comment

by:naderz
ID: 40402665
I must have been typing when Tim was posting. sorry about that. IP Helper-Address is recommended
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Netgear switch to Cisco switch VLAN not passing traffic 8 33
Windows 2012 R2 DHCP Policies 10 74
extend vlan through a layer 3 connection 31 85
Link issue 11 52
I see many questions here on Experts Exchange regarding switch port configurations and trunks. This article is meant for beginners in the subject to help to get basic knowledge about Virtual Local Area Network (VLAN (http://en.wikipedia.org/wiki/Vir…
A Cisco router can be configured as a DHCP Server. There are advantages and disadvantages in making your Cisco router work as DHCP Server. Almost all the features for windows DHCP can be configured on Cisco-based DHCP server. Some of the features me…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.
A simple description of email encryption using a secure portal service. This is one of the choices offered by The Email Laundry for email encryption. The other choices are pdf encryption which creates an encrypted pdf of your email and any attachmen…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

25 Experts available now in Live!

Get 1:1 Help Now