Cannot uninstall Exchange from SBS 2003 - fails with version error

I followed a very well written guide on how to migrate from  SBS 2003 to Server 2008 w/ Exchange 2010.  Every step went well until I got to the point of removing Exchange from SBS.  When I go into the Add/Remove Programs and select Change/Remove for Windows Small Business Server 2003, I get an immediate pop-up window stating:

"You are attempting to install a version that is earlier than the current version.  You can only upgrade to a newer version.  Otherwise, complete a new installation of the previous version"

I have done some searches but come up empty.  Can anyone give me a suggestion as to how to proceed?

Many thanks!
AbsentMindedProfAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Gareth GudgerCommented:
Why not directly related to the Exchange piece it is related to SBS. And I think it is the same issue but a different component. Check the answer in this thread.
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q_21676560.html
0
bas2754Commented:
This is a common issue.  You can try 1 of 2 things:

1. Insert SBS CD 2 which contains exchange, and go to the exchange’s exe file in the I386 folder, see if you can use it to uninstall the exchange

2. If the CD still not works for you, please follow the procedure in KB 833396 to remove the exchange 2003 (Link: http://support.microsoft.com/kb/833396).  You will have to follow the procedure to manually remove the server.  I have had to do this about half of the time when migrating from SBS 2003.

Hope this helps!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AbsentMindedProfAuthor Commented:
Option 1 worked.  Thanks!

Then I got the "attached mailbox" error.  Took care of that.

Now I'm getting the error "A problem has been encountered in the Microsot Exchange Messaging and Collaboration Services setup component" LOL!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.