server 2012 certificate

I have installed the following cert. as the https (port 443) in my IIS manager in the default website AND in my Remote Desktop Services gateway on server 2012 R2 :
ticktockit-sbs.ticktock.local

When I access from the network:
https://ticktockit-sbs.ticktock.local/RDWeb
I get a vert nofification

I install the certificate in the Root certificate location
I then proceed to the RDWeb access interface and get my icons to launch
When I launch them I get the following:

Your computer can't connect to the remote computer because your computer or device did not pass the Network Access Protection requirements set by your network administrator

Please help
doctorbillTechAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MaheshArchitectCommented:
In RD Gateway Manager console on RD Gateway Server, ensure that resource access policies (RAP) are allowed to all users and all computers \ intended ones
doctorbillTechAuthor Commented:
where exactly is this please
doctorbillTechAuthor Commented:
Found it
It is enabled and allowing All Domain users
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

tshearonCommented:
What kind of cert did you get? Is it a self signed one or from a trusted public CA? If the cert is good (x.509 that meet the requirements of RD Gateway) then you should install/import it into the personal certificate folder on the local machine I'm sure.

Anyway, this site should help you resolve.

http://technet.microsoft.com/en-us/library/dd320345(v=ws.10).aspx
doctorbillTechAuthor Commented:
self signed
Still not working
doctorbillTechAuthor Commented:
I still get this:

Your computer can't connect to the remote computer because your computer or device did not pass the Network Access Protection requirements set by your network administrator

Please concentrate on this message only
tshearonCommented:
So did you check that article and make sure you have done everything it has asked for self signed certs?
tshearonCommented:
I apologize, I see what you are saying.

Have you checked here to make sure your NAP policy is configured the way you want?

http://technet.microsoft.com/en-us/library/cc732172(v=ws.10).aspx

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
doctorbillTechAuthor Commented:
which policy do I need to check - specific please
tshearonCommented:
It's in the article I posted. Specifically you would start with the system requirements for the TS Gateway NAP scenario. It would be impossible for me to tell you specifically what your issue is because I do not know how you have it configured.
doctorbillTechAuthor Commented:
This is all configured but I still get the message
MaheshArchitectCommented:
U have checked that all users are allowed through RAP.
Have you checked that all computers are allowed in RAP policies under RD gateway manager ?
The RAP is nothing but you are accessing NAP policies only, but from RD Gateway manager

Ensure that The name (Common Name) of certificate and RD Gateway FQDN both are same, otherwise you will get errors no matter certificate is self signed \ domain based \ 3rd party

Also you must update RDP client on Win7 Machines to 8.1 version (Latest one)
http://support.microsoft.com/kb/2923545

Check new features of RDP 8.1 client
http://support.microsoft.com/kb/2830477

After client updating check if you are able to connect, it is required to connect to 2012 \ 2012 R2 RDS servers
doctorbillTechAuthor Commented:
If I access the site on the server it all works fine so it is definitely linked to remote access
doctorbillTechAuthor Commented:
The RDP client works fine

I am using the web access client:
https://ticktock-sbs/RDWeb
I can log on no problem and get all the remote desktop icons but when I click on them I get the message described above

Sorry - I thought I made that clear in the opening question
MaheshArchitectCommented:
Login into web access and accessing web app icon is two different things

When you use web app to connect to application hosted on RD Session host server, the requests are routed through RD Gateway server via RDP client

Can you please check RDP client version installed on client machine from where you are accessing RD Web Access URL
Open RDP client and right click top and check what is the version of RDP client
doctorbillTechAuthor Commented:
version 6.3.9600
doctorbillTechAuthor Commented:
Many ideas
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.