Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

L3 Etherchannel Configuration

Posted on 2014-10-25
10
618 Views
Last Modified: 2014-10-26
I have configured LACP Etherchannel L2 and it seems like it works fine. However when I try L3 it does not work.  I wonder if I need to type "No Switchport" on Port-channel interface or on each interface that make up the Port-channel or on both ?
Though it looks like to me when I configure L3, it breaks the LACP etherchannel.

Thanks

SW1#sh etherchannel 1 summary
 Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Et0/0(P)       Et0/1(P)      

Last applied Hash Distribution Algorithm:   -
SW1#

SW2#sh etherchannel 1 summary
Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Et0/0(P)       Et0/1(P)      

Last applied Hash Distribution Algorithm:   -
SW2#

l3
0
Comment
Question by:jskfan
  • 4
  • 3
  • 2
  • +1
10 Comments
 
LVL 28

Expert Comment

by:Predrag Jovic
ID: 40404161
Give your interface configuration, please (e0/0 e0/1 and Po1). And is this GNS3, or switch?
0
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 300 total points
ID: 40404166
To see which method is currently configured, use the "show ether load-balance" command.

To change it, use the "port-channel load-balance" command.

Not all platforms support all the load distribution methods.
0
 

Author Comment

by:jskfan
ID: 40404181
SW1#sh run
 hostname SW1
!
boot-start-marker
boot-end-marker
!
!
no logging console
!
no aaa new-model
clock timezone CET 1
!
ip cef
!
no ipv6 cef
 spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
 interface Port-channel1
 no switchport
 ip address 10.10.10.1 255.255.255.252
!
interface Ethernet0/0
 no switchport
 no ip address
 duplex auto
 channel-group 1 mode active
!
interface Ethernet0/1
 no switchport
 no ip address
 duplex auto
 channel-group 1 mode active
!
interface Ethernet0/2
 duplex auto
!
interface Ethernet0/3
 duplex auto
!
interface Vlan1
 no ip address
!
!
ip forward-protocol nd
no ip http server
! 
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
 transport input all
!
end

SW1# 

Open in new window


SW2#sh run
 hostname SW2
!
boot-start-marker
boot-end-marker
!
!
no logging console
!
no aaa new-model
clock timezone CET 1
!
ip cef
!
no ipv6 cef
 spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
 interface Port-channel1
 no switchport
 ip address 10.10.10.2 255.255.255.252
!
interface Ethernet0/0
 no switchport
 no ip address
 duplex auto
 channel-group 1 mode passive
!
interface Ethernet0/1
 no switchport
 no ip address
 duplex auto
 channel-group 1 mode passive
!
interface Ethernet0/2
 duplex auto
!
interface Ethernet0/3
 duplex auto
!
interface Vlan1
 no ip address
!
!
ip forward-protocol nd
no ip http server
 control-plane
 line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
 transport input all
!
end

SW2#

Open in new window


SW1#sh etherchannel 1 sum
 Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(RD)         LACP      Et0/0(w)       Et0/1(w)       

Last applied Hash Distribution Algorithm:   -

Open in new window



SW2#sh etherchannel 1 summary 
 Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(RD)         LACP      Et0/0(w)       Et0/1(w)       

Last applied Hash Distribution Algorithm:   -

SW2#

Open in new window

0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 300 total points
ID: 40404185
Your channel isn't up. The (w) means it's waiting to be aggregated (added to the channel). And the capital "D" under the Port-Channel column means that it's down.

This is most likely due to not having a port-channel interface.  I've never seen the channel-group command not create the port-channel interface, but that could be because you're on a virtual environment.

Go to the two switches and create an interface "po1". And make it a layer 3 interface and assign an IP address to it.

You're also creating a layer 3 etherchannel. Is that what you wanted?
0
 
LVL 28

Assisted Solution

by:Predrag Jovic
Predrag Jovic earned 100 total points
ID: 40404186
Everything looks OK except this down. Is this GNS3?
!
vlan internal allocation policy ascending
 interface Port-channel1
 no switchport
 ip address 10.10.10.2 255.255.255.252
!

This should be under Po1 interface, not under vlan internal allocation policy ascending

If this is GNS3 - this is what Cisco packet tracer do better - try that.
0
 

Author Comment

by:jskfan
ID: 40404284
I agree....in GNS 3 or IOU , Etherchannel does not work well
0
 
LVL 18

Assisted Solution

by:Akinsd
Akinsd earned 100 total points
ID: 40404389
L3 etherchannel on L3 ports (Routed ports)
L2 etherchannel on L2 ports (Non routed ports)

You have to 1st convert the ports to L3 prior to configuring etherchannel. The choice of commands available are different (more or less) based on L2 or L3 state of the ports
And yes, No switchport command will do that for you.
I'll also recommend defaulting the ports especially with the issues you're experiencing and start all over
eg default int range fa0/1 - 4
0
 

Author Comment

by:jskfan
ID: 40404959
No switchport
Will this be applied just for the Port-Channel interface, OR it should be applied also to Physical interfaces that make up the Etherchannel ?
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 300 total points
ID: 40404981
If the channel is functional, you can apply it to the port-channel interface and it will automatically be applied to the physical interfaces.

But if the channel is not functional, you will need to apply the command to both the port-channel interface AND the physical interfaces.
0
 

Author Closing Comment

by:jskfan
ID: 40405356
Thank you Guys!
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This tutorial will go through the steps required to write a script that will back up the configuration settings of a HP-ProCurve switch. You will need to get the following things to follow this tutorial: Telnet Scripting Tool e.g. TST10.exe …
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

808 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question