• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 466
  • Last Modified:

Windows 7 DNS Server Not Responding

Hi,

I have just had a bit of a shock. Norton told me that it had fixed some adware problem on my Windows 7 PC. I looked up how to get rid of it totally and ran adwcleaner and malwarebytes. I let it remove everything that looked like the problem, saving files I know I use. Since then, when I try to access the internet I get the message DNS Server not responding. There was certainly no item in the files removed by either program that mentioned DNS in any way.

My PC normally accesses the internet via a router on a home network.
The PC is a LAN wired connection.
It can see the router in a browser if given an IP address but not the name.
In Windows Explorer it can see all the other devices on the network and access files on them.
The router sees the PC as connected with the correct name.
The DNS Client is running on the PC.
It fails even in safe mode.
I have cleared the DNS cache and re-booted both the PC and the router.
The PC is set to obtain a DNS address automatically, as are the other devices on the network that are working.

I can't think of anything else that would be relevant at the moment.

I live in hope that someone can help me identify what may have been corrupted while trying to clean the PC.

Cheers,

Joan
0
JoanEdington
Asked:
JoanEdington
  • 2
1 Solution
 
RizzleCommented:
Hi,

Can you try to run a Startup Repair from the Windows 7 disc and also try setting the DNS manually in the network and sharing center, also try checking your hosts files and see if there are any weird entries in there.
0
 
RizzleCommented:
Also can other clients on the network resolve the hostnames of websites correctly?

Maybe this may help?

https://social.technet.microsoft.com/Forums/windows/en-US/eeb84518-903d-46d1-9398-80cf211878d7/windows-7-dns-server-not-responding?forum=w7itpronetworking
0
 
John HurstBusiness Consultant (Owner)Commented:
Also run TCP/IP Reset:

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
Restart the computer

Look in C:\Windows\System32\Driver\Etc\Hosts and make sure it is only comments
0
 
JoanEdingtonAuthor Commented:
Many thanks for this. I had checked the DNS settings yesterday and it was set to loocalhost I changed it to automatic, restarted the PC, but it still didn't work. I went in to the settings again this morning to try the open DNS address and found that the DNS was set to use localhost again. I can't imagine why except that Adobe has added 2 localhost entries to my hosts file. Anyway, setting the DNS back to automatic has done the trick today.
Thanks ahain.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now