WDS Authentication

I'm currently trying to streamline a build process by removing the need for users to authenticate with our WDS. The role is installed in standalone mode on a Server 2012 R2 machine which is joined to our domain.  

The password prompt pops up in the PE environment. Once authenticated with a domain account you are then presented with the list of available images as expected.

Is there any way to remove the login prompt entirely?

Configuring permissions on the 'REMINST' share allowed me to select who is able to login but adding the 'Everyone' group and removing Authenticated users didn't work.
pxuserAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

 
Joshua GrantomSenior Systems AdministratorCommented:
Yes, you can use an WDS Unattend file. This automates the GUI prompts in Windows PE.

http://technet.microsoft.com/en-us/library/cc732280%28v=ws.10%29.aspx#ex1
0
 
pxuserAuthor Commented:
Thanks Joshua,

Just to go into a little more detail on what I did to resolve this issue encase anyone else is wondering...

I created an Unattend file in WSIM like so:

 wds2.png
The Output:

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="windowsPE">
        <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <WindowsDeploymentServices>
                <Login>
                    <Credentials>
                        <Domain>[b]DOMAIN HERE[/b]</Domain>
                        <Password>[b]PASSWORD HERE[/b]</Password>
                        <Username>[b]USERNAMEHERE[/b]</Username>
                    </Credentials>
                </Login>
            </WindowsDeploymentServices>
        </component>
    </settings>
    <cpi:offlineImage cpi:source="wim://blah/e$/oooooosh/asdf.wim#asdf" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>

Open in new window


wds3.png
Then in the WDS console at server level, select properties. Under the client tab select 'Enable unattended installation' and browse to your unattended file for your desired architecture.
0

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
 
pxuserAuthor Commented:
It works?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.