Solved

Cannot browse internet via WiFi, but can via ethernet cable

Posted on 2014-10-27
12
342 Views
Last Modified: 2014-11-18
Users cannot browse the internet when connected to WiFi, but they can when connected to the LAN via cable.

DHCP and DNS is done on the server (SBS 2011). 192.168.1.3

Modem/Router is Netcomm NB604N. 192.168.1.1

When a client connects to WiFi, the connection shows Limited Connectivity.

If I set the IP details to static on a WiFi client and point the DNS to 192.168.1.3, the internet starts working.
0
Comment
Question by:cgruber
  • 4
  • 2
  • 2
  • +3
12 Comments
 
LVL 11

Expert Comment

by:epichero22
ID: 40407460
If you're browsing with static IP settings, but not dynamic, then it's definitely a DHCP configuration error.  Is your wireless router giving them settings instead of the server?  Be sure that you only have one device managing DHCP.
0
 
LVL 6

Accepted Solution

by:
Wylie Bayes earned 500 total points
ID: 40407462
So when connected on wireless are the clients actually getting an IP via DHCP? Or is it getting set to a 169.xx.xx.xx address?

Is the wireless setup as Bridge?   If it is not setup as a bridge (AP MODE) then the NAT (Network Address Translation) will kill your DHCP traffic.  

If you wish you leave it as is, you need to have the wifi router also act as a DHCP server and hand out addresses on that subnet.  So all wireless clients would use the gateway address of the Wifi router, and all wired clients would use the gateway address of the Netcomm.

I would recommend changing the wireless router to a bridge (AP mode) and only run 1 DHCP server.
0
 

Author Comment

by:cgruber
ID: 40407477
DHCP is turned off on the modem/router.

When connected to wireless, clients get an IP address and the correct default gateway, but the DNS server comes up as 127.0.0.1
0
 

Author Comment

by:cgruber
ID: 40407488
This page allows you to configure wireless bridge features of the wireless LAN interface. You can select Wireless Bridge (also known as Wireless Distribution System) to disable access point functionality. Selecting Access Point enables access point functionality. Wireless bridge functionality will still be available and wireless stations will be able to associate to the AP. Select Disabled in Bridge Restrict which disables wireless bridge restriction. Any  wireless bridge will be granted access. Selecting Enabled  enables wireless bridge restriction. Only those bridges selected in Remote Bridges will be granted access.
Click "Refresh" to update the remote bridges. Wait for few seconds to update.
Click "Apply/Save" to configure the wireless bridge options.

ap settings
0
 

Author Comment

by:cgruber
ID: 40407489
see above for current ap settings
0
 
LVL 23

Expert Comment

by:Thomas Grassi
ID: 40407580
Go to the wireless network connection properties for the wifi  adapter

Select Internet protocol version 4 TCP/IPv4

On general tab

Obtain DNS Server address automatically. Must be selected

What do you have for that?

Ipconfig /all post
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:cgruber
ID: 40407653
These are iPhones, iPads, Galaxy phones, but anyway thats what you get

IP Address: 192.168.1.X
Subnet: 255.255.255.0
Gateway: 192.168.1.1
DNS: 127.0.0.1
0
 
LVL 23

Expert Comment

by:Thomas Grassi
ID: 40407698
Maybe your wifi router is blocking port 53
Or the servers firewall

I would check the firewall settings
0
 
LVL 18

Expert Comment

by:Akinsd
ID: 40408669
DNS 127.0.0.1
Is that the address issued to the cliens. If yes, then that's the problem. Replace with actual address of the router
0
 
LVL 6

Expert Comment

by:Wylie Bayes
ID: 40408684
If everything is set to "obtain automatically" then the DHCP server is delivering 127.0.0.1 as the DNS settings.

What do your wired clients get?

What are your other options on the ap settings page besides AP ?
0
 
LVL 12

Expert Comment

by:profgeek
ID: 40408705
Are the devices showing 192.168.1.3 as their DHCP server?
0
 
LVL 18

Expert Comment

by:Akinsd
ID: 40408727
Check the DHCP scope and replace the 127.0.0.1 with 192.168.1.3
Force the clients to renew their IP
Everything should work afterwards
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

This subject  of securing wireless devices conjures up visions of your PC or mobile phone connecting to the Internet through some hotspot at Starbucks. But it is so much more than that. Let’s look at the facts: devices#sthash.eoFY7dic.
This paper addresses the security of Sennheiser DECT Contact Center and Office (CC&O) headsets. It describes the DECT security chain comprised of “Pairing”, “Per Call Authentication” and “Encryption”, which are all part of the standard DECT protocol.
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now