Solved

How to configure Exchange server 2007 email

Posted on 2014-10-27
6
124 Views
Last Modified: 2014-11-05
I installed Exchange Server 2007 on a server with MS Server 2008 R2 Std. It is connected to the Internet through WAN 1 which comes through a Zyxel Zywall USG 100 firewall. The domain is through Godaddy who is also providing the current IMAP email service. I added MX & A records in Godaddy to point it to the server using the static public IP address. I used MXToolbox to test the connection. It shows the server at mail."mydomain".com & the public IP address but fails the SMTP test because of no response on port 25.  On the Exchange Management Console/Microsoft Exchange/Server Configuration/Hub Transport/Receive Connectors/Default "server name" the FQDN is mail."mydomain".com & under the network tab ports 25, 80 & 443 are available for all IP addresses to receive mail. Anonymous users are permitted under Permission Groups. I unchecked Exchange Server authentication under the Authentication tab to allow changing the FQDN. I have not modified any settings on the Windows or Zyxel firewalls because I read that SMTP was built in on the server & I assumed the ZyXel firewall would allow it by default since it already works with POP & IMAP. I also used Microsoft Remote Connectivity Analyzer using a test email address created in the server & had the same results.
0
Comment
Question by:Albatross1953
6 Comments
 
LVL 16

Accepted Solution

by:
Joshua Grantom earned 250 total points
ID: 40407646
I think you still need to allow the ports 25,10,443 through your firewall for the public IP to the exchange server.
0
 
LVL 23

Expert Comment

by:Thomas Grassi
ID: 40407706
Also allow port 1025

Most providers block port 25

Allow both plus above

In the router check your port forwarding  access list etc
0
 
LVL 63

Assisted Solution

by:Simon Butler (Sembee)
Simon Butler (Sembee) earned 250 total points
ID: 40408255
"Also allow port 1025"

Where did you get that port from? Opening another port for SMTP access is not going to help at all, because everyone else is using port 25. Therefore that advice is completely useless.

"...25,10,443..."

I presume you meant 80 there. Again not required and poor security practise to do so. The only ports that you need to open for Exchange to work correctly are 25 and 443. No others. Everything else is optional.

Changing the FQDN on the receive connector is a waste of time. People only do it to pass the dumb tests at MXtoolbox. I would encourage you to reverse that change and leave it as the default. It will have no effect on the operation of your email.

This is either a firewall misconfiguration or the ISP blocking the port.
Check if the ISP allows inbound port 25, they may do so, but you have to call them first.

Simon.
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 16

Expert Comment

by:Joshua Grantom
ID: 40408279
No I did not mean port 80, I meant port 110 but yes it is optional. If they're going to use any type of POP3 client.

Also, when calling the ISP make sure that they create the reverse DNS record.
0
 

Author Comment

by:Albatross1953
ID: 40415468
This installation failed. The domain went offline while I was trying to open a port on the firewall. I had to shut down the exchange server to get it working again. I'll remove it & start over tomorrow when the office is empty. Port 110 & 80 must already be open because the POP3 email is working with those ports. Port 25 did not work so that mat be the problem.
0
 

Author Comment

by:Albatross1953
ID: 40423177
I have port 25 open on the firewall. I got a response on MX lookup. It said email was ready to use. When I try to create an exchange account in Outlook it says The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete. I ran Mircrosoft Remote Connection analyzer & failed because the certificate names didn't match. I installed a certificate & got the same results. Godaddy said to create a CName record using Autodiscover as Host. That kicked the MX lookup back to the old server. The business owner wants this working yesterday. What else should I do?
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Utilizing an array to gracefully append to a list of EmailAddresses
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question