Solved

Server 2012 RDP Slow

Posted on 2014-10-28
4
206 Views
Last Modified: 2016-11-23
Hi guys

We recently deployed out serveral servers all running server 2012 at various clients. They are all mostly Dell R410's or Dell R520's.

We have noticed that the RDC connections to these servers are far slower than the connections to our 2003 and 2008 servers that run on the same networks.

We have tried to add the following registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters as mentioned in other support articles but our connection is still slow.

Has anyone else foudn this sort of issue with server 2012 RDP.
0
Comment
Question by:DeonLubbe
4 Comments
 
LVL 26

Expert Comment

by:Dan McFadden
ID: 40410651
I have many Server 2012's deployed and no apparent speed issues with RDP.  I am also using Dell servers, models R710s and R720s.

Have you verified the binding order of the protocols and the NIC order on these servers?  Microsoft default are not the best setup.

1. Go to:  Control Panel > All Control Panel Items > Network and Sharing Center
2. Click "Change adapter settings"
3. hit the "ALT" key once, the file menu will appear
4. click "Advanced" then select "Advanced Settings"
5. On the tab "Adapters and Bindings > Connections area :: make sure you NIC(s) are in the order in which you want them used... Make sure the object "[Remote Access Connections]" is on the bottom.
6. In the Bindings for "YourNicName" section, make sure TCP/IPv4 is above v6
7. On the tab "Provider Order" > Network Providers area :: make sure "Microsoft Windows Network" is first.

Click thru all OKs.  Then give it a test.

Dan
0
 
LVL 11

Expert Comment

by:hecgomrec
ID: 40411596
Besides Dan recommendations, I will make sure your DNS are working OK.

Also, because you said this issue is only for this kind of server, make sure you have the latest drivers and check all their setting to match your network settings needs.

I don't have those servers but I have experience slow connections on LAN cards if they are not configured properly either at server or switch level.

Good Luck!!!
0
 
LVL 15

Accepted Solution

by:
ZabagaR earned 500 total points
ID: 40426998
If networking checks out okay, look at the power settings under control panel.  Make sure you're set to maximum for performance. Balanced or custom can cause some lag time.
0
 

Author Closing Comment

by:DeonLubbe
ID: 40493228
Thanks guys It turned out to a number of issues including DNS but i am sure all the recommendations helped.
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Recently, I was assigned the task of performing a hardware refresh in the datacenter. The previous Windows 2008 systems were connected to the SAN via fiber channel HBA’s and among other thing, had PowerPath installed in order to provide sufficient f…
Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
In this Micro Tutorial viewers will learn how to restore their server from Bare Metal Backup image created with Windows Server Backup feature. As an example Windows 2012R2 is used.
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now