Connection failed with iSCSI on Hyper-V Server

I have a Windows 2012 Storage Server with multiple iSCSI targets defined.  I have three other servers, each connecting to one target.  One of the server is a Hyper V 2012 R2 Core Server.

The Hyper-V Server has its VMs on the iSCSI Drive.  The problem is, I reinstalled the Hyper V operating system today due to a disk failure, and the new installation is unable to connect to the iSCSI Drive.  Each time I try to Discover the iSCSI Targets I receive a Connection Failed error.  I receive the same when I try to enter the SNS server address.

There is obviously no problem with the Storage server as it worked before, and still works for the other two servers.  So I expect the problem to be on the Hyper-V server.  

I have set the iSCSI service to Automatic, and confirmed it is running.  I have enabled iSCSI in the Windows Firewall.  

I can ping in both directions, using DNS name and IP address, so the network addressing is okay.  I do not remember having to do anything other than that the first time I set it up to get iSCSI running.

I have confirmed the settings of the target to confirm the initiator settings are correct based on iqn and IP address.

I have also, just on the off chance, restarted both server.

So now I am at a loss.  I am hoping someone can tell me what step or setting I have missed.
LVL 6
townsmaAsked:
Who is Participating?
 
townsmaAuthor Commented:
I have resolved the problem.  

The iSNS ports were not opened on the Hyper-V server.  It is not mentioned in any of my internet searches.  I found is in the iSCSI User Guide for WIn Server 2008 Core.

Also, I changed the iSCSI target ACL for just the IP address, not using the iqn.

Now it works and is connected correctly.
0
 
kevinhsiehCommented:
Try to change the ACL on the volume so that either any initiator can connect, or limit to just the iSCSI initiator name. It's possible that you are requiring chap authentication or that the Hyper-V host is trying to connect from another IP that isn't allowed.
0
 
townsmaAuthor Commented:
I presume you mean on the target, not the volume?

I tried to limit it by the iqn only, No difference.

As we use this on a private development LAN we do not use any form of chap authentication.
0
 
townsmaAuthor Commented:
I have provided the solution.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.