I'm getting certificate errors when connecting to our RDS server

I'm running RDS on Windows 2012 R2 and connecting with some XP, 7 and 8 desktops.
On some of the XP desktops I'm getting the following Remote Desktop Connection error when connecting to the server:
"The connection has been terminated because an unexpected server authentication certificate was received from the remote computer.  Try connecting again.  If the problem continues, contact the owner of the remote computer or your network administrator."
The XP stations have had SP3 installed,  They are using Remote Desktop Connection Shell Version 6.1.7600.  Network Level Authentication and RDP 7.0 are supported.
I've looked for hours for solutions and have come up empty.  Any ideas please?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dennis JansonIT ManagerCommented:
I actually got this error yesterday on a couple of Thin Clients running WES 2009 and found that the latest Root Certificates for Windows XP KB931125 were nto installed. Here is a link. Try it and see if it works for you.

smoakinAuthor Commented:
I downloaded and ran that update earlier.  Unfortunately, it did not correct the problem.
So you say, it happens only on xp?
On any xp you tested with, with any user? Also on clean installations (only xp with SP3 and nothing else)?
SolarWinds® Network Configuration Manager (NCM)

SolarWinds® Network Configuration Manager brings structure and peace of mind to configuration management. Bulk config deployment, automatic backups, change detection, vulnerability assessments, and config change templates reduce the time needed for repetitive tasks.

smoakinAuthor Commented:
Yes, it only happens on XP desktops, and only some of the XP desktops.  There are no clean installs of XP, but all are the same hardware and are similarly configured.  Obviously there is a difference, but that's what I can't figure out.
smoakinAuthor Commented:
I've also installed the CredSSP Fix it 50588.
The difference can be found, only a question of effort you are willing to invest.
Take a clean system - it works.
-Install you most popular application - most probably it will still work.
-install the security suites you use - first crucial point and next test. if that still works...
-apply the computer GPOs that you normally apply and test. Next...
-apply the user GPOs
->if still no problem, install the less popular applications and test.
smoakinAuthor Commented:
Management decided to keep the older XP computers because it would save them money.  There are probably over 30 applications on each of those computers that can still be used.  It would be a very tedious process.  My instinct tells me it probably isn't one of the applications directly, but a system setting or two that were set at some point by the user while using the apps. I'm sure a fresh install of the OS would probably do the trick, but by the time that is done, they would have paid for a new computer.
I estimate the time investment to find out to be AT MAX between one and two hours depending on where the problem sits.
smoakinAuthor Commented:
The XP computers that are working are all using the same apps as those that are not working.  A fresh install of XP with updates and all apps will definitely resolve the problem.  The downside is that while we corrected the problem, we will never know what the cause was in order to correct it in the other XP desktops.  I was hoping to find a solution that could could correct the problem without rebuilds.

Now, if there is no other way to isolate the problem then we may have no choice but to replace the computers.  They definitely don't want to invest time and money into those old XP desktops.  I will need to discuss the alternatives with them.
"A fresh install of XP with updates and all apps will definitely resolve the problem" - if that would indeed be so, then all the computers where it is not working now are broken - they have the correct settings applied but "misbehave". That is simply not the case. There is a common factor for sure and it will not be some "bit corruption".
I recommend to do the analysis.
David Johnson, CD, MVPOwnerCommented:
I would investigate the certificate stores from a working machine and one that doesn't work.
smoakinAuthor Commented:
The certificate stores between a working and non-working machine are identical.
smoakinAuthor Commented:
Removed all apps one at a time until none remained.  Problem remained.  Wiped drive and reinstalled OS, followed by all apps, testing as I went.  The connection works fine.  I could not isolate a cause, and still do not know what the problem is, or how to go about fixing the other XP desktops.
If you can't find a common course, the last resort would be monitoring with procmon to record a successful action and compare it to the unsuccessful action's log of another machine.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Did you find something useful in the log? Or how was it solved?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.