windows cannot access the specific file, device, path or file

I keep getting the error "windows cannot access the specific file, device, path or file". I have a file share with a small exe on (winaudit.exe), I remote desktop onto various servers, map the share with the exe, and in 99% of cases I can run the exe file once remoted onto the server. In a few cases though I get "windows cannot access the specific file, device, path or file" which makes no sense, I right click the file and as I know I am on the ACL (full control). I have even tried copying the file off the share onto the desktop on the server I have remoted onto and running it that way, but again I get the same error. Any theories? I have been remoting onto many diferent OS (from 2000 - 2003 - 2008), I think the issue is mainly happening on 2003 systems, but it doenst affect all as sometimes I dont get this issue.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pma111Author Commented:
nobody can help?
Lionel MMSmall Business IT ConsultantCommented:
Well from what you have said it is not the exe since you say it works on some 200, 2003 and 2008 so the key has to be something on those servers on which it is not working. It may be 1) difference in user/admin rights 20 difference in file/folder (NTFS) permissions or rights. You know these servers best--what is different about those that are not working?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pma111Author Commented:
I dont get the permissions angle though - as they are permissions on a remote share to the exe (which i have full control over), and even if I copy them over to my desktop on the server, I get the same error

Are there any specific user rights you would focus on?
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

Mike SunSenior Systems Engineer (IBM - retired)Commented:
May be worth checking the "Effective Permissions" under the security tab - Advanced - Effective Permissions...
Lionel MMSmall Business IT ConsultantCommented:
If the share permissions are different then even if you NTFS full control it may fail if the share permission prohibit execute--however if both the share and the NTFS permissions are full control on the share AND on the system you are running it from then I suggest you run it from a command prompt and see if it may give an error we can see that you can't see via the GUI
pma111Author Commented:
Still lost as the share pemissions will be the same for all servers accessing the file, and in many cases it works fine. Maybe I have misunderstood, if so sorry.  Will try the cmd prompt way though.
pma111Author Commented:
I did read a note of similar issue where it claimed it could be the AV software..
Lionel MMSmall Business IT ConsultantCommented:
The key is to tell us the differences in the system on which it is not working. Are you are remoting on as the exact same user (same domain, same user), and does that user have the exact same local as well as domain rights?

You said this
I remote desktop onto various servers, map the share with the exe, and in 99% of cases I can run the exe file once remoted onto the server
My question then is
In that 1% of servers what are the differences?
pma111Author Commented:
same domain, same user - yes. I am not from a windows server background so its pretty new concept to me. Suffice to say if you are a domain admin should you not be able to rectify the issue yourself with permissions?
Lionel MMSmall Business IT ConsultantCommented:
please run this on a server that works and then on a server that doesn't--make sure they are the same version 2003 and 2003 and 2008 and 2008 etc, etc.

GPRESULT /USER Yourusername (the one you use to logon to all these servers) /V
and see if you notice in difference in GPO settings
Lionel MMSmall Business IT ConsultantCommented:
Another solution is to export the security template from a server that works (CRITICAL you use the same version including x32 and x64 version must be the same) and then import that security settings onto the server that does not work

You still have not told us how these servers are different, different anti-virus, different roles, different applications running on them--one an exchange server and another a SQL server, one with Norton another with McAfee--please how are these servers different
pma111Author Commented:
It was to do with trusted.locations
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.