Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 645
  • Last Modified:

Network PC's and Wireless clients not getting Gateway IP

The network server is Server 2008, 2 Nics (1 Disabled).
The ip of server is hard coded 192.168.1.2, with gateway of 192.168.1.1 (Router). And DNS at 192.168.1.2 (pointing to self)

Had regular gigabit router with no wireless builtin in place. Used an access Point. Wireless devices cannot get the gateway IP. Some hard wired PC's get limited connection at random intervals. Devices look and have been verified to be setup correctly.

Changed router to gigabit Netgear FVS318N wireless router, and same conditions, wireless clients do not get a gateway ip when connected but connect limited only. Some PC's do the same, limited connections, and if hard coded with the ip information, will work, but not permanently, they eventually get limited connection.

Phones do not pick up the gateway IP.

The router has been replaced, the switch has been replaced, Server is doing DNS and DHCP, and they are off in the wireless router.

We have 1 server, 5 pc's, 1 mfp printer. I have seen today all working, then my pc dropped the dns, connection said limited, 3 users on exchange showed disconnected, then came back shortly afterwards by themselves.

I have scanned for bugs on all, including server. Any ideas?
0
Kevin Caldwell
Asked:
Kevin Caldwell
  • 5
  • 4
  • 3
  • +6
3 Solutions
 
it_saigeDeveloperCommented:
It almost sounds as if you have a loopback problem on the network somewhere.  Ensure that the switch and router are just connected to each other with one cable.

Also please provide the output for: netsh interface ipv4 show config

From one of the computers with a limited connection.

-saige-
0
 
Wylie BayesCommented:
What is acting as DHCP server?  The 2008 machine or the router?
0
 
tmoore1962Commented:
switch managed or unmanaged? If managed make sure it is configured.  Check your DHCP config for scope options on the server and make sure your dns and router are configured there.  Since exchange is it a SBS server?  Anything in the eventlogs?  When system has limited do a IPCONFIG /ALL  and see if information is correct. Also does tracert to a web address work?
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
Kevin CaldwellOwner of RUseeingRed Tech SolutionsAuthor Commented:
I had to leave the site for another emergency.  I will check these things out in a little while.

The 2008 server is doing dhcp.
0
 
Kevin CaldwellOwner of RUseeingRed Tech SolutionsAuthor Commented:
ipconfig shows when limited, it is not getting the gateway IP as mentioned above.. I see an IP, the the subnet, but the g/w is blank. When it works as it should, it shows the gateway,, I can ALWAYS ping the router on .1 and the server on .2 even when limited.

This box is an exchange server as mentioned too. It is a managed switch, but I have not set it up, the previous IT source did, but it has been crazy up and down for a couple of months now.. It was working fine for a long time.
0
 
Kevin CaldwellOwner of RUseeingRed Tech SolutionsAuthor Commented:
the switch is connected to the router one cable, from port 2 from router to the uplink port in the managed switch..
0
 
Asif BacchusCommented:
I noted that you are using SBS?  If that's the case then you REALLY REALLY have to make sure that your NetGear router is not trying to act as the DHCP server.  SBS loves to be the DNS and DHCP server and gets very angry when it is not.  I've used the router you mentioned and there are several places to disable DHCP, so make sure you take a good look around.  Also, are you sure that the SBS is handing out gateway information in the DHCP scope/server options?  I've seen the wizard forget to explicitly add the gateway in the scope options before.
0
 
Kevin CaldwellOwner of RUseeingRed Tech SolutionsAuthor Commented:
R2 Standard Server 2008 is not SBS.. The server is set to dish out dhcp and dns,, the router is indeed turned off
0
 
Wylie BayesCommented:
The 2008 server is also a domain controller yes?  Have you configured DHCP to use custom authentication when doing dynamic DNS updates?
0
 
Dale McKayGlobal Principal ArchitectCommented:
What is the configured lease time on the DHCP server?
0
 
AkinsdNetwork AdministratorCommented:
Check your DHCP scopes on the server.

Also, run ipconfig /all on the computers and verify the DHCP server IP to ensure the devices are receiving DHCP offers from the correct server
0
 
Asif BacchusCommented:
This seems like the lease is being prematurely ended and the clients are not renewing automatically.  Dale had a good suggestion on checking lease times.  Some output from an ipconfig /all would be very helpful.  Also, anything in the event logs either on the server (DHCP and DNS logs) or the client?
0
 
hecgomrecCommented:
Open your DHCP on the server, under the IPv4:

Properties of the Scope:

General tab:

Start IP address: 192.168.1.30
End IP address:  192.168.1.254

Note: I leave 30 IP for static configuration of devices (printer, routers, servers, etc.)


Scope Options, make sure you have there:

003 Router = 192.168.1.1
006 DNS Servers = 192.168.1.2
015 DNS Domain Name = yourdomainname

Post back....
0
 
Dale McKayGlobal Principal ArchitectCommented:
What does you DHCP server say for a lease duration?

DHCP-Lease.jpg
0
 
AkinsdNetwork AdministratorCommented:
Also, run ipconfig /all on the computers and verify the DHCP server IP to ensure the devices are receiving DHCP offers from the correct server

DHCP
This is to eliminate possibility of a DHCP rogue server
0
 
Dale McKayGlobal Principal ArchitectCommented:
It appears to me that you are getting your DHCP addresses from an AT&T Wi-Fi DHCP server located at 192.168.1.254. It is also the default gateway for the 192.168.1.0 network. That's why you see the DNS domain as attlocal.net. BTW,, the lease is for a day which is standard for an AT&T provided device.

On your server,, can we get the output of  the command ipconfig /all?

Can you also add screen shots of the DHCP server configuration?
0
 
Dale McKayGlobal Principal ArchitectCommented:
Never mind on the AT&T comment...it's been a long day.

Still would like to see the ipconfig /all from the server and screenshots of how the DHCP server is configured.
0
 
Asif BacchusCommented:
I agree with Dale, ipconfig /all would be helpful along with his previously requested lease expiration times.  A screenshot of the scope options would also be very helpful to ensure that the proper gateway and DNS settings are being sent via DHCP.
0
 
AkinsdNetwork AdministratorCommented:
I posted the ipconfig screenshot as an example for the author. Author is yet to post his result.
0
 
Craig BeckCommented:
We need to know if the clients do actually get a gateway address, and that this isn't just a flaky DNS issue.

If clients have flaky DNS that would cause the Limited Connectivity issue, as a MS client tries to resolve www.msftncsi.com using its configured DNS server.  If it can't resolve that host's IP it will assume there is no internet connectivity.  If it can resolve that host's IP it will then try to down load file ncsi.txt from that address.  Again, if this fails the PC will assume there is no internet access available.
0
 
Kevin CaldwellOwner of RUseeingRed Tech SolutionsAuthor Commented:
Experts,
As a temporary fix, I moved the dhcp to the router and everything worked then.  So something is definitely wrong with the dhcp and dns on the server.   This weekend I moved the mail to the cloud so that was a one thing off of the server that I didn't have to worry about as much.  I believe what needs to happens is just zap the whole dhcp and dns on the server and go from there.  At least the customer is not going up and down with things.  Interestingly enough too, all the machines were hard coded with ip's and not on automatic.  I believe the problem has been there for a while.  I started handling this customer only a few months ago.  So the previous IT guy never fixed this.    
Thanks for the help!
0

Featured Post

New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

  • 5
  • 4
  • 3
  • +6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now