Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

QNAP NAS Fileshare locked out of shared folders

Posted on 2014-10-29
16
Medium Priority
?
482 Views
Last Modified: 2015-02-25
Hi,

I am having a reoccurring issue with my QNAP TS-420U. Basically every couple of days I seem get locked out of the Shared Folders. The shared folders are inaccessible and I get the error message attached when I try to access the Fileshare. In addition I tried to connect to the Web interface of the NAS and got a "502 proxy error" (screenshot has been attached for this issue). I have got the ISCSI volumes configured to the NAS which connect to my Hyper V server. This ISCSI volume hosts the Virtual Hard disk file for my SQL server. Whenever the lockout issue occurs I experience performance issues with the databases that are stored on the VHD file which sits on the ISCSI connection.

I had no choice but to perform a hard reboot of the NAS. However the problem with this is when the NAS  is not shutdown properly I get the error message "The Filesystem is not clean". (A screenshot of this error message is found below). I performed a repair on the filesystem last week however this issue has reoccurred.

I have reviewed the system event logs and couldn't locate anything that would have caused this issue.

Any advise would be much appreciated.

Thanks,
FILESHARE-INACCESSIBLE.PNG
ERROR-WHEN-CONNECTION-TO-THE-WEB-INTERFA
event-log.PNG
0
Comment
Question by:Contigo1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 7
16 Comments
 
LVL 6

Expert Comment

by:Tim Phillips
ID: 40412015
This may not be terribly helpful, but we have the same Qnap device and have decided to ditch it for a Synology for odd errors like what you are experiencing.  We have to power cycle the thing sometimes to get connectivity back.  Ours is connected to our Active Directory domain and gives us all kinds of permissions issues on our shares.  We now have a Synology and it is working MUCH better.  Plan on using it for Hyper-v as well.
0
 
LVL 7

Expert Comment

by:Stampel
ID: 40412839
Are you using the latest firmware for this QNAP ?
0
 
LVL 1

Author Comment

by:Contigo1
ID: 40412842
Yes. I have upgraded to the latest Firmware for this QNAP.
0
Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

 
LVL 7

Expert Comment

by:Stampel
ID: 40412846
I am using a few of this 420U for customers, for daily backup using iScsi target. Hopefully i never met this issue. Did you contact QNAP for support ?
RAID5 on 4 drives of 1To each.
0
 
LVL 1

Author Comment

by:Contigo1
ID: 40412855
I haven't contacted QNAP for technical support. I will contact them now to see if they can assist with this issue.
0
 
LVL 7

Expert Comment

by:Stampel
ID: 40412890
I have one model TS-420U
with firmware version QTS 4.0.2 Build 20130726
Uptime 103 days

Another is TS-412U
Uptime 240 days

In the log history, just after reboot event and on both systems i can see :
[RAID5 Disk Volume: Drive 1 2 3 4] The file system is not clean. It is suggested that you run "check disk".

But in the storage manager of TS-420U i can see status "Ready" for the logical volume so maybe it has been auto checked.
During my investigations on TS-412U i had problem with GUI not responding. When i tried to open another https session i had message "storage not initialized"

LOL
0
 
LVL 1

Author Comment

by:Contigo1
ID: 40412900
That is strange behaviour. I have logged a request with QNAP support to see if they can advise further.
0
 
LVL 7

Expert Comment

by:Stampel
ID: 40412923
I guess "The Filesystem is not clean" is normal and we would get that everytime shutdown is unexpected.
Im trying to update 412U firmware from 3.8.2 to 4.1.1 and see what happens :)
0
 
LVL 1

Author Comment

by:Contigo1
ID: 40412947
That's right. You get that error message when the NAS is not shutdown properly.
0
 
LVL 7

Expert Comment

by:Stampel
ID: 40412970
Finally 412U is back with it's new 4.1.1 interface and RAID5 in Ready status.
I will launch filesystem check just in case.
Did you manage to contact Qnap support ? Im curious if they are reactive
0
 
LVL 1

Author Comment

by:Contigo1
ID: 40412975
I have logged a ticket with them. Havent had a response as of yet.
0
 
LVL 7

Expert Comment

by:Stampel
ID: 40413796
By the way i think its a good idea to disable all the services you do not use, like music station , photo station , ...
0
 
LVL 1

Author Comment

by:Contigo1
ID: 40419218
Hi,

QNAP have come back with the following:

"Hi there,
The should be the filesystem issue which might be fixed by reinstall the firmware 4.1.1 build 1003 as the attached SOP.
by the way, please logon the HDD manufacturer web site and download/install disk check tool on your PC, power off the NAS, remove NAS HDD and connect it with PC and then use the disk check tool to scan the HDD. "

They are advising to reapply the firmware on the NAS. The problem is that this issue occurred when the NAS was on firmware version 3.8.3, I updated the firmware version to 4.1.1 on 15/10/2014, however this didn't resolve the issue. I have replied back to them advising I updated the Firmware a couple of weeks ago however this didn't resolve the issue. I also asked them if this a common problem with this particular model.

Any other suggestions/possible fixes would be much appreciated.

Thanks,
0
 
LVL 7

Expert Comment

by:Stampel
ID: 40419268
Do you have the possibility to export all the data and perform a restore to factory settings
+ recreate virtual disk and put your data back on it ?

I think i would try that and log this action into your QNAP case.
If the NAS still have the problem, i would ask QNAP for replacement refering the case.

Also disable all the services you do not use, like music station , photo station , ...
0
 
LVL 1

Author Comment

by:Contigo1
ID: 40424254
I don't think that would be a possibility as we have got a lot of data on this NAS and we don't have anywhere to put it. QNAP have come back with the following:

Hi ,
Please see the attached SOP to collect log to me.

(attachment is below). They basically want me to install and them the log files across to them. I'll send this back to them and see how far I get.
diagnostic-tool--2-.doc
0
 
LVL 7

Accepted Solution

by:
Stampel earned 2000 total points
ID: 40424374
At least they have a diagnostic tool, good to know. Lets see
0

Featured Post

Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Each year, investment in cloud platforms grows more than 20% (https://www.immun.io/hubfs/Immunio_2016/Content/Marketing/Cloud-Security-Report-2016.pdf?submissionGuid=a8d80a00-6fee-4b85-81db-a4e28f681762) as an increasing number of companies begin to…
A look at what happened in the Verizon cloud breach.
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
Suggested Courses

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question