PCI Device without driver Vostro 1500, Windows XP

I wouldn't be fixing an XP machine unless I had to.  So, I have to.
I cleaned it up of viruses and now it's running fine except:
When it boots it reports "Found new hardware" "PCI Device" and tries to install.  But it can't find a driver.

I've downloaded and installed all of the drivers I could figure might be the case.

The Device Manager doesn't show a modem.  I've installed modem drivers.  No change.

The Device Manager, in System Devices shows a PCI Device with a yellow exclamation point.  It shows:
PCI\VEN_8086&DEV_284B&SUBSYS_02281028&REV_02\3&61AAA01&0&D8

But, no luck.  Updating driver is the same as the attempt to install at boot.

How to get past this?
LVL 27
Fred MarshallPrincipalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dbruntonCommented:
Try the modem driver for the Dell Vostro 1400.

This link http://en.community.dell.com/support-forums/laptop/f/3518/t/19298111 describes a similar problem to yours and he solved it by using a 1400 modem driver.

The drivers are here but I'm not sure which one is correct for your system.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
☠ MASQ ☠Commented:
THe PCI/VEN code identifies the device as Microsoft's UAA Bus Driver for High Definition Audio on a Dell Vostro 15xx.

With XP you're going to need Microsoft's Hotfix KB888111 to get this running but with XP out of support I can't find a direct download from them. (WindowsXP-KB888111-x86-ENU.exe)

I found a copy here http://thehotfixshare.net/board/index.php?autocom=downloads&showfile=589 which checked clean with AV scanning.  You might prefer to find a copy from somewhere you trust more (some XP HD driver downloads contain the driver as part of the package).

Once installed and restarted then run the audio driver install again.

It's not really the modem driver you're missing but the audio driver provides support for the modem which is why that appears to be missing.
0
nobusCommented:
probably that driver is included in the sound driver - so update that one
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Fred MarshallPrincipalAuthor Commented:
Thanks!
The Conexant D330 HDA MDC v.92 modem.  It's the same file for the 1400 and the 1500.  I've tried it already.  Still no modem and still an unidentified PCI Device.

I also note that things are not apparently "OK" otherwise.  There's no sound / no sound device even though the audio part of Device Manager looks normal.  Maybe that's a clue.
I have already installed the Microsoft UUA driver.
I've installed all the sound drivers I can find on the Dell site for this computer.  Some of them won't install because they don't like this computer....

I haven't done one of these re: sound in a long time.  I'm wondering what might be suggested next steps?
0
nobusCommented:
post a screenshot of device manager with the problematic devices expanded : sound, problem device
0
Fred MarshallPrincipalAuthor Commented:
Well, it's fixed now.  Not a process that I expected nor have ever seen before.
When I was getting ready to do the screen shots, I decided to try to "roll back" the driver on the PCI Device with no driver installed.
As soon as I did that, the PCI Device entry disappeared, which I assumed was temporary.
Then a bunch of the drivers that I had tried to install before, went ahead and installed themselves.
The sound is now working.
AND, the PCI Device is GONE!!
I have the notion that this was a remnant of a parasite perhaps.

Thanks for your help!
0
Fred MarshallPrincipalAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for fmarshall's comment #a40414001

for the following reason:

This is what fixed it but I can't be sure that the advice given would not have been effective as well.
0
Fred MarshallPrincipalAuthor Commented:
I intended to award points - so I object to my own action.
0
☠ MASQ ☠Commented:
I intended to award points - so I object to my own action - LOL! -  You need to press "Object" not "Submit" then :)

Good to hear it's fixed  however it happened.
0
Fred MarshallPrincipalAuthor Commented:
I intended to award points - so I object to my own closure
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.