No Internet access warning after migrating workstations to new domain

Hi everyone,

After doing a domain/server migration from SBS2008 to 2012R2 in an all-Windows 7 Pro environment, the workstations are all showing 'No Internet access' in the system tray and in Network and Sharing center (red X between the domain and the Internet). However all workstations in fact DO have Internet access as well as full access to internal resources.

Some general notes:

- DNS on DC is configured with forwarding to OpenDNS servers
- DHCP running on DC (2012 R2)
- DHCP provides workstations one DNS IP only pointing to DC
- domain name is a .local
- pings to internal and external hosts from the workstation resolve instantly
- Windows Firewall is disabled via GPO on the workstations for the 'Domain network' and 'Home or work (private) network' zones

The staff keep mentioning the warning, which is reason enough to find a cause. I'm also seeing Outlook (2007/2010/2013) freezing issues on about 80% of the workstations and thought maybe this is related.

Thanks for any troubleshooting steps you may be able to provide.
tsprestonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

VB ITSSpecialist ConsultantCommented:
Check the permissions on the HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList key in the registry on one affected machine and make sure the NETWORK SERVICE and LOCAL SERVICE accounts have full access to the key.

If you have to add the permissions for these accounts to the above key then remember to go into Advanced and tick the box to Replace all child object permission entries with inheritable permission from this objectOK as permissions are not automatically inherited in the registry.

If everything looks right in the registry then have a read through this article for more troubleshooting steps: http://blogs.technet.com/b/networking/archive/2009/06/19/missing-network-map-under-network-and-sharing-center-in-windows-vista-or-windows-server-2008.aspx (I know the URL refers to Vista and 2008 however some of the fixes also apply to Windows 7/2008 R2)
tsprestonAuthor Commented:
Thanks for the reply, VB. The machine I'm troubleshooting did not have the two service accounts listed under the NetworkList key so I added them with full access and was sure to replace the permissions of the child objects. Unfortunately the problem remains after a reboot.

Interestingly, I checked another machine that is not exhibiting the issue. It doesn't have the service accounts listed in the same registry key.

I'm going through the Technet blog post you provided now to see if I can find a commonality.
tsprestonAuthor Commented:
Ok so I was going through the steps in the Technet blog you posted and nothing seemed to be working. So I removed Kaspersky (Kaseya Anti-Virus - KAV) and that solved the issue after a reboot.

What I don't understand is why 1/2 of the Win 7 Pro systems running the same version of KAV don't have this issue. And how can I configure KAV to unblock LLTD?
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

VB ITSSpecialist ConsultantCommented:
OK, that's strange that an AV product would cause that issue. How did you deploy Kaspersky in your environment? What version of Kaspersky specifically are you using?
tsprestonAuthor Commented:
It's Kaspersky through Kaseya 6.5; version 10.2.1.23. Like I said, it's odd as not all workstations are showing the same behavior. However this particular workstation's 'No Internet access' warning disappeared as soon as the AV was uninstalled and the PC rebooted. The warning returned when I reinstalled the AV and rebooted.
VB ITSSpecialist ConsultantCommented:
Managed to find this thread on the Kaseya forums, which suggests adding http://www.msftncsi.com/* and dns.msftncsi.com to the list of trusted sites to resolve the issue.

Here's the official TechNet article regarding the Network Connectivity Status Indicator (NCSI) http://technet.microsoft.com/en-us/library/cc766017%28v=ws.10%29.aspx

Try the above and let me know if it fixes the issue.
tsprestonAuthor Commented:
Thanks for the reply. Unfortunately I have already tried that, it didn't solve this particular PC's issue.
tsprestonAuthor Commented:
Oops, hold the phone. I just logged into said test PC and the warning is gone. I have had it locked and logged in since yesterday. I'm restarting now to see what state it comes up in.
tsprestonAuthor Commented:
Nope it came up with the warning still. It seems like it eventually sorts itself out. Can't get my head wrapped around it...
VB ITSSpecialist ConsultantCommented:
Sounds like it's definitely something in the KAV profile that's causing the issue though. Is it hindering your access to any programs? I know Office 365 relies on the NCIS for example.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Internet Protocols

From novice to tech pro — start learning today.