Solved

Windows OS System File Corruption, Could it be Caused by Misconfigured WSUS?

Posted on 2014-10-30
19
655 Views
Last Modified: 2014-11-04
Hello EE,

Is there any possibility that WSUS could cause Windows File Corruption?

For the life of me I can not get Group Policy Management installed on a Windows 7 box.

Fails trying to install the tools in "Turn Windows Features on or off".

Try to install Group Policy Management Tools via GUI
Installing Group Policy Management Tools via GUI
Installing Group Policy Management Tools via GUI
Installing Group Policy Management Tools via GUI ERROR
And when I try to install via DISM fatal error 1603.

DISM install GPMC fails fatal error 1603
I run the system file checker sfc /scannow and it does find files that need repair and says it repaired some.

I reboot run the sfc /scannow and it does find files that need fixing but unable to fix them.

Rinse and repeat, and this appears to be a loop of same results.

sfc /scannow results
This is not an issue on freshly imaged computers that get freshly joined to our domain.

http://www.microsoft.com/en-us/download/details.aspx?id=7887

I can install the RSAT... BUT...

I can never enabled the features via the "Turn Windows features on or off" GUI.

I have always had to run the DISM commands to install the tools I need.

My biggest question here is could our WSUS server cause this type of file corruption pushing out Windows Update improperly?

How can I get this package installed?

Could a Group Policy be blocking this ability to install?

My next try will be:

Dism /Online /Cleanup-Image /RestoreHealth

And see if I can re-run sfc /scannow and get better results.

This does not appear to be an issue with our image we deploy as a freshly imaged and joined computer can install these packages via DISM (No GUI), but over time with the computer being on the domain and receiving updates and group polices this becomes a problem.

Note: We are using a Proxy too, could the proxy play any role in this issue?

I could really use some help as this one has been bugging me so bad that I can not pin point the root cause. :-)
sfcdetails.txt
0
Comment
Question by:CheckThe Logs
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 4
  • 3
  • +1
19 Comments
 
LVL 55

Accepted Solution

by:
McKnife earned 500 total points
ID: 40414803
As for wsus: simply "no". WSUS does not push updates but clients pull and there is nothing that could go wrong pulling. Installing updates rarely ends in broken systems but is always possible.
I would try to install the system update readiness tool and if that does not help, do an inplace upgrade installation (aka repair) of windows.
0
 

Author Comment

by:CheckThe Logs
ID: 40414940
http://kickthatcomputer.wordpress.com/2014/04/11/windows-update-failing-with-proxy-authentication-required-0x8024401b-errors/

I know it's a long shot but I am thinking this could be similar to my problem...

Will add to this more details of my issue.

Thank you for your feedback and help very much appreciated. I will try the readiness tool I think I tried that already but will re verify.

Last resort will in place upgrade and report back any updates or results.
0
 
LVL 35

Expert Comment

by:Seth Simmons
ID: 40415617
can you post c:\windows\logs\dism\dism.log ?
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 

Author Comment

by:CheckThe Logs
ID: 40416078
DISM.log uploaded. CHECKSUR.log uploaded. And another log file that I edited out personal information but provides very similar issue as link I posted:

http://kickthatcomputer.wordpress.com/2014/04/11/windows-update-failing-with-proxy-authentication-required-0x8024401b-errors/

Appreciate all your help everyone! Happy Halloween! :-)
dism.log
checksur.log
0
 

Author Comment

by:CheckThe Logs
ID: 40416081
Forgot to add this one.
LOG.txt
0
 
LVL 55

Expert Comment

by:McKnife
ID: 40416091
The recommendation to inplace-upgrade still stands.
Happy Halloween!
0
 
LVL 35

Expert Comment

by:Seth Simmons
ID: 40416151
from checksur.log the recommendation from KB article 2700601 is to copy the 2 files from another system

http://support.microsoft.com/kb/2700601

the dism log refers to the cbs log
can you post c:\windows\logs\cbs\cbs.log ?
0
 
LVL 16

Expert Comment

by:joinaunion
ID: 40416361
You may want to give Chev65's fixes a shot here, http://www.sevenforums.com/network-sharing/71812-unable-install-remote-server-administration-tools.html

Lots of good links to fixes.
0
 

Author Comment

by:CheckThe Logs
ID: 40417238
Seth Simmons > CBS log uploaded, needed to split into 2 files it was too large to upload as one file. Looks like I will have to track down another Windows 7 box and see if I can find these 2 files to get on this machine:

Summary:
Seconds executed: 709
 Found 2 errors
  CBS MUM Corrupt Total count: 2

Unavailable repair files:
      servicing\packages\Microsoft-Windows-IE-Hyphenation-Parent-Package-English~31bf3856ad364e35~~~11.2.9412.0.mum
      servicing\packages\Microsoft-Windows-IE-Spelling-Parent-Package-English~31bf3856ad364e35~~~11.2.9412.0.mum
      servicing\packages\Microsoft-Windows-IE-Hyphenation-Parent-Package-English~31bf3856ad364e35~~~11.2.9412.0.cat
      servicing\packages\Microsoft-Windows-IE-Spelling-Parent-Package-English~31bf3856ad364e35~~~11.2.9412.0.cat

It just seems odd that these 2 files would cause me problems for installing GPMC but still worth a shot at replacing them.

Thank you for you help on this one, I more than likely will try this fix first and see if I can get past my issue with this fix.

joinaunion > Thank you for the link, I checked that one out and some of the links are dead on that forum for Chev65, but some are still working, but they appear to be a fix for reinstalling the RSAT which I already have installed. Could be an option, to remove and reinstall the RSAT and then install the tools I need via command line. I might give that a try, thank you for your help on this one.

McKnife > I am with you :-) I totally agree that an in place upgrade would probably fix this issue but I really want to use that as a last resort. This one has been driving me nuts for months and really want to narrow down the root cause to avoid this issue in the future. Thank you for the idea, it is very much appreciated.

It might take me until sometime on Monday to get more updates to this question, please bear with me and thanks again for all your help.

My gut is telling me if I delete the registry keys on this machine for the WSUS server and connect it up to an outside network and hit Windows Updates and try the command:

dism /online /enable-feature /featurename:RemoteServerAdministrationTools-Features-GP

That it would work and install, then connect back up to my network after the install.

My gut is telling me this is more proxy related than WSUS related at this point due to review of the WindowsUpdate.log which I have attached earlier named LOG.txt.

Updates to follow! Thanks again everyone @ EE!
CBS-Log-1.txt
CBS-Log-2.txt
0
 
LVL 16

Expert Comment

by:joinaunion
ID: 40417456
Can you run this tool and post back results please.
http://support2.microsoft.com/?kbid=836941
0
 

Author Comment

by:CheckThe Logs
ID: 40417737
joinaunion > Ran it and found some fixes

fix1.png
fix2.png
But still failed on me when trying to get the GPMC installed via DISM...

dism /online /enable-feature /featurename:RemoteServerAdministrationTools-Features-GP

fix4.png
I ran Windows Updates and it found an update for System Readiness Tool but basically hung for over a half hour installing a 413kb in size update.

Reboot and try DISM oonce more, no dice.

Try applying the GPMC via Turn Windows Feature on of off, same error as before.

Uploading the latest windows update log file, this is where I think the issue lies....

windowsupdate1.log

http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_update/error-code-80072ee2-unable-to-downlod-updates/80c5185b-2dab-4ee3-b578-3e1aa5e1bacf?page=1

I run the netsh winhttp show proxy command

fix5.png
But I do use a proxy which is set in the browser (IE) and appears to apply itself to other browsers such as Chrome and Firefox, not 100% sure if there is a GPO that applies proxy settings as well.

2014-11-01      17:26:17:679      1176      1e78      PT      WARNING: Cached cookie has expired or new PID is available
2014-11-01      17:26:17:679      1176      1e78      PT      Initializing simple targeting cookie, clientId = 4a5757e7-26bf-45ef-89aa-ad1c1beae24f, target group = , DNS name = computer.domain.net
2014-11-01      17:26:17:679      1176      1e78      PT        Server URL = http://sub.domain.net/SimpleAuthWebService/SimpleAuth.asmx
2014-11-01      17:27:18:587      1176      1e78      Misc      WARNING: SendRequest failed with hr = 80072ee2. Proxy List used: <X.X.X.X:80> Bypass List used : <(null)> Auth Schemes used : <>
2014-11-01      17:27:18:588      1176      1e78      PT        + Last proxy send request failed with hr = 0x80072EE2, HTTP status code = 0
2014-11-01      17:27:18:588      1176      1e78      PT        + Caller provided proxy = No
2014-11-01      17:27:18:588      1176      1e78      PT        + Proxy list used = X.X.X.X:80
2014-11-01      17:27:18:588      1176      1e78      PT        + Bypass list used = <NULL>
2014-11-01      17:27:18:588      1176      1e78      PT        + Caller provided credentials = No
2014-11-01      17:27:18:588      1176      1e78      PT        + Impersonate flags = 0
2014-11-01      17:27:18:588      1176      1e78      PT        + Possible authorization schemes used =
2014-11-01      17:27:18:588      1176      1e78      PT      WARNING: GetAuthorizationCookie failure, error = 0x80072EE2, soap client error = 5, soap error code = 0, HTTP status code = 200
2014-11-01      17:27:18:588      1176      1e78      PT      WARNING: Failed to initialize Simple Targeting Cookie: 0x80072ee2
2014-11-01      17:27:18:588      1176      1e78      PT      WARNING: PopulateAuthCookies failed: 0x80072ee2
2014-11-01      17:27:18:588      1176      1e78      PT      WARNING: RefreshCookie failed: 0x80072ee2
2014-11-01      17:27:18:588      1176      1e78      PT      WARNING: RefreshPTState failed: 0x80072ee2
2014-11-01      17:27:18:588      1176      1e78      PT      WARNING: PTError: 0x80072ee2
2014-11-01      17:27:18:588      1176      1e78      Report      WARNING: Reporter failed to upload events with hr = 80072ee2.

I guess my next attempt will be to remove this machine from this network and delete the WSUS registry keys and try this on a network without a proxy and see if I get any better results.

Has anyone ever seen a proxy cause these kinds of issues?

Thank you for all your help on this one appreciate all the great feedback! :-)
dism.log
checksur.log
cbs.log
0
 
LVL 16

Expert Comment

by:joinaunion
ID: 40418544
Error 1603. Permission issue.
Have you tried this fix here?
http://support.microsoft.com/kb/834484
0
 

Author Comment

by:CheckThe Logs
ID: 40419926
Seth Simmons > from checksur.log the recommendation from KB article 2700601 is to copy the 2 files from another system

http://support.microsoft.com/kb/2700601

I could not locate these files on other machines I have, so I could not do these steps.

joinaunion > Error 1603. Permission issue.
Have you tried this fix here?
http://support.microsoft.com/kb/834484

I am running Windows 7 ENT. x64. This fix outlines for XP only. Drive is not encrypted nor substitute.

Also, I even went as far as deleting the registry keys for the WSUS, took off this network and tired to hit Windows Updates and then ran command:

dism /online /enable-feature /featurename:RemoteServerAdministrationTools-Features-GP

And got the same 1603 error as before.

So my idea did not work either. :-( Sad Panda I am :-(
0
 
LVL 55

Expert Comment

by:McKnife
ID: 40419945
Do yourself a favor and do the inplace upgrade now.
There are errors that can't be explained or found. Those are wiped away using image backups or (if you don't have one) repair installations (aka inplace upgrade). We don't HAVE to worry, unless the problem reoccurs again and again.
0
 

Author Comment

by:CheckThe Logs
ID: 40420417
McKnife > Backing up data to be safe and will be running in place upgrade ASAP. I will report back after the in place upgrade and let you all know how thing go.

Thank you for the support and feedback! :-)
0
 
LVL 55

Expert Comment

by:McKnife
ID: 40420430
Just in case you have not done it before: it is advisable to use a win7 DVD with sp1 included, so you won't need to reinstall SP1.
0
 

Author Comment

by:CheckThe Logs
ID: 40420570
McKnife > I have an SP1 DVD running upgrade now crossing fingers :-)
0
 

Author Comment

by:CheckThe Logs
ID: 40421458
Updates: I have run the in place upgrade and it has resolved the issue, I now have access to install the GPMC and did it via the Turn Features On or Off.

Thank you all for your feedback and support and thank you McKnife you had the answer right away!
0
 

Author Closing Comment

by:CheckThe Logs
ID: 40421463
As much as I did not want to do the in place upgrade, this did resolve my issue. Granted I was not able to pin point the root cause, I was still able to fix my issues and move on.
0

Featured Post

Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Windows functions GetTickCount and timeGetTime retrieve the number of milliseconds since the system was started. However, the value is stored in a DWORD, which means that it wraps around to zero every 49.7 days. This article shows how to solve t…
An introduction to the wonderful sport of Scam Baiting.  Learn how to help fight scammers by beating them at their own game. This great pass time helps the world, while providing an endless source of entertainment. Enjoy!
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question