Solved

Why am I not able to unset the "read only" attribute on a file share?

Posted on 2014-10-30
15
465 Views
Last Modified: 2014-10-31
I set up a new file share and by default in attributes read only is checked.
I can uncheck the box, apply and close. When I reopen the file share folder or any file in the file share
the read only box is checked and greyed out. It will not remain unchecked.  Have unchecked several times
applied and closed and will always reopen with the check mark greyed out.
How do I solve this issue?  Thanks
0
Comment
Question by:PDSWSS
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 6
15 Comments
 
LVL 6

Expert Comment

by:Asif Bacchus
ID: 40414971
Do you have Full Control, or at least Modify, permissions on the share and on the files?  Are the files inheriting permissions from a parent folder?
0
 

Author Comment

by:PDSWSS
ID: 40415018
I have full control as administrator. Set up so the file share is not inheriting permissions from parent folder.
Thanks
0
 
LVL 6

Expert Comment

by:Asif Bacchus
ID: 40415035
I'm assuming you have both Full Control over the share and at the NTFS level also then.  Can you un-set read-only when you are working with the actual files and not via the share?  Are these files by chance located on the root of the system drive (usually C:)?
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 

Author Comment

by:PDSWSS
ID: 40415066
The file share is located  on the root of the system drive   C:   In the file share are Access 2000 DBs.  Same issue with file share and every file in the file share when accessed via network or directly on the server.  On a different computer,  tested one of the files downloaded from the share. On the desktop of this other computer read only is not checked as it should be.

What do you think?
0
 

Author Comment

by:PDSWSS
ID: 40415759
asifbacchus
Looked again and now see that its only the folders that continue to have the greyed out check box for read only.

The files inside the folders have an empty box next to read only attribute yet some users still only get read only when opening  Access 2000 DBs.  Thanks
0
 
LVL 6

Accepted Solution

by:
Asif Bacchus earned 500 total points
ID: 40416517
To be clear, the files are located in a folder that is in the root, correct?  So the path looks like C:\Folder?  If the files are actually in the root, that would be your problem.  If they are in a folder, then we can proceed.

Take a look at that folder and let's check the permissions.  First, remove the share.  Now, as a member of the administrators group, set the owner to the administrators group so you have complete control.  Apply this to all child objects as well.  Clear and remove all inheritable permissions, apply to child objects, and manually set Full Control and apply to child objects.  Now add permissions for your users/groups at the NTFS level.  Now, unset (i.e. check the box, uncheck the box and click apply) the read-only parameter on the folder itself and have that apply to all child objects as well.  Recreate the share and set the proper share permissions, remembering to give Full Control to the administrators/domain admins.  Now logoff and log back in and check the files and folder, as well as the share and see if the problem has been corrected.

Basically, we are taking ownership of everything, manually setting permissions and attributes and then remaking the share.  The logging off step is just to make sure the workstation is reading the new permissions/attributes and not some old cached data.
0
 

Author Comment

by:PDSWSS
ID: 40416581
"Now add permissions for your users/groups at the NTFS level."

I am the adman of the Server.  I assume since the share will be opened by users in the
active directory network the other users do not need NTFS permissions on the server that contains the file share. Correct?  thanks,
0
 

Author Comment

by:PDSWSS
ID: 40416582
Should be admin not adman.
0
 
LVL 6

Expert Comment

by:Asif Bacchus
ID: 40416588
Since we are removing all inherited permissions, you DO have to set permissions for your users at the NTFS level.  You can either specify individual users, groups or the default 'Users' group.  Depending on the access your users need, you can give them Read & Execute (read-only) or Write (allows changes, but not deletion), Modify (allows changes and deletion).  The nice thing is that once NTFS permissions are set, you don't have to worry about share permissions as much.
0
 

Author Comment

by:PDSWSS
ID: 40416656
Started with a new folder on C: and followed all your instructions except for adding admin\domain admin
I am not a domain admin but I am an admin so left administrators in the permissions box in the shared folder.

But appears I have taken a step backwards. Now when I open MS
access files  I get the read only message again.  The access files are all unset read only now (child folders unset read only).
What is going on here?  Is something wrong with the server or C drive?  Thanks,
0
 
LVL 6

Expert Comment

by:Asif Bacchus
ID: 40416664
What are your Sharing permissions on the folder and the NTFS permissions on both the folder and files?
0
 

Author Comment

by:PDSWSS
ID: 40416706
Thanks. Problem solved.  I had forgotten to configure the sharing permissions. Was only configuring the NTFS permissions which i had wrongly assumed were the sharing permissions.

Once I configured the sharing permissions the read only issue went away for me and hopefully will also no longer be an issue for the other users.  Thank you very much.

something that is not clear - on the first file share where the issue started - I did not get read only but the other users did.  The share permissions was configured to the default -  everyone - read only.
Strange that I did not get read only.  As long as it works now this issue could remain a mystery unless you have some idea.  Thanks again.
0
 

Author Closing Comment

by:PDSWSS
ID: 40416709
Thanks again and have a great weekend.
0
 
LVL 6

Expert Comment

by:Asif Bacchus
ID: 40416726
Glad it worked out for you! Have a good weekend also :-)

Regarding your question, it is likely because you are an administrator and had full rights set somewhere for admins, but that's just my best guess without looking at your specific setup.
0
 

Author Comment

by:PDSWSS
ID: 40416731
That would also be my best guess. Thanks again.
0

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question