Solved

WdsClient: There was a problem initializing WDS Mode

Posted on 2014-10-31
11
2,500 Views
Last Modified: 2014-11-21
Hi I am in need of any suggestions to fix an issue with WDS. Config: Server 2012R2 HyperV host, Server 2012R2 VM with AD, DNS, WSUS, WDS, DHCP installed. The server and the client are on an internal virtual switch (testing network). Generation 1 and Generation 2 VM's set up to test imaging. Boot wims created from a windows 8.1 DVD. Option 60 and 67 are configured in DHCP (67: set to boot\x64\wdsnbp.com). When I try and image a VM I get the following error after it loads the discovery wim WdsClient: There was a problem initializing WDS Mode. Any suggestions welcome as I am stumped. Thanks in advance
0
Comment
Question by:Dead_Eyes
  • 6
  • 3
  • 2
11 Comments
 
LVL 56

Expert Comment

by:Cliff Galiher
ID: 40416449
As I recall, when WDS and DHCP are hosted on the same server, you *don't* want to set options 60 or 67 in DHCP, or it causes conflicts. That'll cause WDS to not behave properly.
0
 

Author Comment

by:Dead_Eyes
ID: 40416940
thanks for the reply but Its the other way round, it restates this in the WDS options
0
 
LVL 56

Expert Comment

by:Cliff Galiher
ID: 40417025
Try not setting the options, and make sire both cheekbones are checked in the PXE response tab. If that doesn't work, go ahead and set option 60. Setting option 67 though will almost definitely make WDS misbehave. You'd only want to do that in special circumstances.
0
 

Author Comment

by:Dead_Eyes
ID: 40417070
I have tried option 60 and it behaves as expected and cannot find the PXE boot. 67 just specifies PXE boot file so is very useful for switching between CSM & UEFI boot loaders.
0
 
LVL 56

Expert Comment

by:Cliff Galiher
ID: 40417091
Regarding option 67, it is supposed to be WDS server that sends that information based on settings you choose in the WDS tabs.  If you set it via DHCP instead of letting WDS then WDS can't manage its response and you get errors.
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 

Author Comment

by:Dead_Eyes
ID: 40417113
True but I get the same response with option 67 on or off
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 40422966
Regarding DHCP options 60 and 66, 67, these are explained in my article (and its comments):
http://www.experts-exchange.com/Networking/Misc/A_2978-PXEClient-what-is-it-for-Can-I-use-PXE-without-it.html

Basically, DHCP Opt60 is to be set ONLY if your PXE server and DHCP server runs on the same host.
DHCP Opt66 and 67 should NEVER be set if you have a real PXE Server in place. This would prevent the PXE Server (WDS embeds one, of course) to send different PXE-Bootstraps for different architectures, for instance (x86 vs x64 etc.)

However, you do not seem to have a PXE problem, since the PXE portion of the boot process works and you are having your error when under the WinPE environment.
Unless you are getting a PXE-Boot and then a WinPE/WIM boot from a wrong WDS server... Better  check that before making any other assumptions.
0
 

Author Comment

by:Dead_Eyes
ID: 40432364
I agree its got nothing to do with PXE and I have redone the boot wims and re-installed and still getting the same error
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 40438965
I did not say that it had nothing to do with PXE for sure.
It COULD be a PXE6based problem if you got the wrong PXE bootstrap because you specified DHCP opt 66 and 67 and that would prevent the PXE server to send the correct bootstrap.
You should make sure that it is not the case.
You can use a packet analyzer (Network Monitor, Wireshark) to examine what is happening on the wire, check logs etc.
In any case, you must remove DHCP option 66 and 67, they are useless and dangerous when there is a real PXE server in charge of sending PXE details.
0
 

Accepted Solution

by:
Dead_Eyes earned 0 total points
ID: 40441538
I found the problem, for anyone else experiencing similar it occurs when you install WDS on a fully updated VM running Server 2012R2. The solution is to install the WDS component before updating the server. Wish I could say why but after several rebuild tests it holds true every time (I think the culprit update is the big 600-800MB one you usually find on the second round of updates). Oh and as a bonus fail if you are installing WSUS on the same server update the server before installing WSUS or that can encounter issues. I will leave this open for the next few days if anyone can shed any further light on the issue and serve to assist those that really don't want to rebuild the server but in my tests it was only way and held true in 3 separate tests on different host machines, different install disks and different domains.
0
 

Author Closing Comment

by:Dead_Eyes
ID: 40456972
Possible fault in Server 2012R2, No other solutions posted
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
If you need to start windows update installation remotely or as a scheduled task you will find this very helpful.
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now