Corrupt E00.log file in Exchange 2010


I have a small business server 2011 and exchange will not mount.

It appears that the E00.log file is corrupt. I have tried running the /r switch is exeutil on it but it fails. I cannot delete this file as is says it is corrupt.

Is there a way of deleting it and then remounting the mailbox database without it as the back of the folder containing this file has not worked.

Alternatively if I can delete it can i rename the next most recent err log file in its place?

This is really urgent as I have no emails

Optima SystemsNetwork EngineerAsked:
Who is Participating?
Miguel Angel Perez MuñozConnect With a Mentor Commented:
Try set Exchange storage service to disabled and reboot your server.
Then, rename log file to something like e00.tmp and try repair log files, change service to auto, start service  and mount database.
Optima SystemsNetwork EngineerAuthor Commented:
I do not have an "exchange storage" service?
ALso I have now run eseutil /p and the database says it is okay.
However, when I try and mount the database I get the error message:
Couldnt mount the database that you specified. Specified database Mailbox Database; Error Code: An active Manager operation failed with a transient error. Please retry the operation. Error; database actin failed with transient error. Error; a transient ewrror occurred during a database operation Error; MapiExceptionJetErrorFilelOBBeyondE)F

Any ideas?
Miguel Angel Perez MuñozCommented:
Set your log files as original, and try with "eseutil /ml e00" to check logs.
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Adam FarageEnterprise ArchCommented:
- Remove the checkpoint file to a different directory
- Run ESEUTIL with /r and /a (so ESEUTIL /r e00 /a). /a should fill in the corrupt file with a blank limiting the dataloss.

Let us know how that goes.
Adam FarageEnterprise ArchCommented:
Sorry, I didnt read that you already ran ESEUTIL /P...

Try two these two things in this order:

- Removing the checkpoint (just rename it)
- Force mounting the database

Mount-Database DBName -Force

Open in new window

The reason I say this is because if you do not move the .chk file then the Active Manager (Primary active manager to be exact) will actually look at the dbTime on the chk file to make sure it matches the files in your directory, in this case it does not. Moving the checkpoint file should resolve this issue.
Optima SystemsNetwork EngineerAuthor Commented:
Thanks for the help. In the end I disabled all the Exchange Services, rebooted the server and was able to delete the E00.log file.

I then reset the services back to automatic and then rebooted the server. The database was successfully mounted so all is good now.

Thanks again
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.