• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 155
  • Last Modified:

Remote Desktop Connections + Server 2012 R2

When it says:  The terminal server has exceeded the maximum number of allowed connections.

How do I disconnect users who are connected.  This is server 2012 R2 Domain Controller, and I do not see anything specifying Terminal Services > TS manager etc.

I want to get away without installing of those features.

Thanks
0
techgenious
Asked:
techgenious
  • 2
1 Solution
 
Kash2nd Line EngineerCommented:
go to server Manager -> Remote Desktop Services -> Collections and on your right you will see who is connected. Right click and disconnected

also define a group policy so that disconnected users's session ends in 30 minutes.
0
 
Sajid Shaik MSr. System AdminCommented:
go to task manager  see the users and logoff.

right click on start button cmd  type Taskmgr - enter

all the best
0
 
VB ITSSpecialist ConsultantCommented:
Task Manager > More Details bottom left > Users tab is the way to go.

Microsoft have removed TS/RDS Manager starting from Windows Server 2012.

EDIT: Just tested and can confirm that you can use Remote Desktop Services Manager from a 2008 R2 server to connect to a 2012 R2 server and manage the sessions that way. This is, of course, providing you have access to a 2008 R2 server.
0
 
VB ITSSpecialist ConsultantCommented:
Managed to find this article as well where they have created a workaround to get the traditional tsadmin.msc console working in 2012 R2: http://kysysadmins.wordpress.com/2014/10/23/having-upgraded-to-server-2012-r2-i-miss-the-way-it-worked-in-server-2008-part-1/

I have not tried this myself personally so as per usual, always take backups before modifying your registry.
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now