vmworkstation 10 bridged Card no DNS

I have added a NIC to my workstation and configured it for VMWARE. ie, everything but vmware protocol is unchecked. I assigned VMNic 2 to this card and applied it to my workstation(s).  It pulls from DHCP and I can resolve by IP address inside and outside, but No resolution via DNS.  I can ping my DNS server IP and I've put in different DNS servers (8.8.8.8), but no worky.  I can add an entry to my hosts file and it DOES work.  But nothing I do with DNS allows resolution.  I'm only using IPV4.  
I thought maybe the driver was corrupted so I removed and reinstalled. Same thing.  If I configure the nic as a normal nic, it will connect to the network, pull an IP and resolves fine.  Reconfigure for vmware and no resolution.  

Any thoughts please?
David BirdPartnerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Try resetting VMware Network to Default in the VMware Network Editor (Restore Default is lower left).

Then please review the VMware Support article for multiple NICs

http://pubs.vmware.com/workstation-10/index.jsp?topic=%2Fcom.vmware.ws.using.doc%2FGUID-476EEC7C-4DBA-481B-A772-52CFC572E2A7.html

I have not done multiple NIC's but I have successfully reset VMware NIC's to solve issues.

I assume above you mean VMNet2 not VMNic 2. You would use the VMware names.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
David BirdPartnerAuthor Commented:
Yes, I meant VMnet2, sorry.  

Reset to defaults, recreated the custom bridges for the two cards, primary card still working fine. Second card (one not resolving) is still not resolving.  That was an excellent thought though.  Thank you.
0
JohnBusiness Consultant (Owner)Commented:
DHCP and DNS for card 2 come from card 2 because it is Bridged. There could be a problem with the VMware setup and so I suggest the following:

1. In VMware Network Editor, remove VMNet2 completely. Close out and restart the computer.
2. In the Host machine, update or reinstall the drivers for card 2.
3. Run TCP/IP Reset on the Host.

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
Then restart the computer again.

4. See if you can connect from the host through card 2 to its DHCP source. Does this give you DNS.

5. What is card 2 connected to?   Card 1 is likely connected to a router. What then does card 2 connect to?  Not the same router (or at least I should not think so).
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

David BirdPartnerAuthor Commented:
There was something bothering me about the NIC card that was giving me grief on DNS so I replaced the card with a Broadcom.  Issue resolved.  I may plug the old NIC into another machine and see if I can recreate the issue but for now, all is well.  Thank you for your suggestions.
0
David BirdPartnerAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for davebird's comment #a40422235

for the following reason:

Threw the baby out with the dish water and got a new one.
0
David BirdPartnerAuthor Commented:
Oops. I lied.  The VM stopped DNS'ing about 10 minutes later.  Same issue, new card. Worked for a while.  No other changes.  
daver.
0
JohnBusiness Consultant (Owner)Commented:
Please answer the suggestions I gave you (quite a number) to see if we can resolve the problem.
0
David BirdPartnerAuthor Commented:
Different direction now.  
I have determined that ONLY when you have IPV4 enabled on the Host NIC will I get consistent outside DNS when using it with the vmware bridge protocol.  The guests will work fine internally on a host nic without ipv4 enabled AND pickup dhcp.  It just won't route external traffic unless you have HOST entries (don't know why that works but DNS doesn't) OR you have to have IPV4 enabled as a communication protocol on the host.

What this does to my situation.

Let's say my primary day to day host card is on 192.168.5.x and I have a site to site tunnel to 192.168.10.x.
Everything is working.
Now I add another NIC to my machine for a bridge to another network, 192.168.15.x.  I enable the vmware bridge protocol and hard wire that to my 15.x network. IF I enable IPV4 on that card, I can no longer communicate with the site to site tunnel, 192.168.10.x.  
I have attempted to modify my interface and gateway metric on the primary NIC so that it's the first path out but that hasn't helped.  Still no tunnel access.

Ergo,
IPV4 disabled on bridge host nic, guest works but no external DNS.
IPV4 enabled on bridge host nic, guest is golden but no traffic site to site on host machine.  

I hope this is clear and you have some thoughts please sir.
thanx
daver
0
JohnBusiness Consultant (Owner)Commented:
Using IPv4 is pervasive and normal today.

4. See if you can connect from the host through card 2 to its DHCP source. Does this give you DNS

Forget VMware. What happens at the Host with 2 NIC's with respect to DNS?
0
David BirdPartnerAuthor Commented:
Agreed. vmware is NOT the issue.  Taking vmware out of the picture entirely, if I have two NICs in the machine on two different networks, the tunnels that are designed for network 1 do not work.  DNS is fine. If I can make the tunnels function with a multihomed machine, all is well.  As this issue is not vmware related, should I close it and open a new one in networking/tcpip/tunnels or do you have other ideas sir?
0
JohnBusiness Consultant (Owner)Commented:
Focus only on the Host, try new/updated drivers for each NIC, disable IPv6 (in this case) and stick with IPv4.
0
JohnBusiness Consultant (Owner)Commented:
I think another possibility is 2 NIC's in the same machine with one Workstation computer will not do what you are trying to do (internet out of one, tunnel out of the other). I use split tunneling and one NIC to do this.
0
David BirdPartnerAuthor Commented:
I setup another machine with a broadcom 4 port NIC, installed a thirty day trial of Workstation 10 under windows 8 pro, setup two windows 8 VM's on two different networks.  I did NOT enable IPV4 protocol on the physical NIC's second, or different domain, and allowed it to be a VM pass through.  It is still working properly as the two other physical licensed machines.
The machine this question was originally opened with is working as well now.  I took the primary NIC off of the integrated NIC (disabled it) and put it on one of the Broadcom ports last Tuesday/Wednesday.  It is now working as it was originally.  Possibly the internal NIC was bad.  
I DID run the solutions Mr. Hurst suggested but, it did not help.
One consistent item.  You do NOT need IPV4 enabled on the host NIC for traffic to flow from the VM's through the Host NIC.  
If there are no other responses, I'll close this ticket.  Thank you for all help that was offered.
0
David BirdPartnerAuthor Commented:
You do NOT need IPV4 enabled on the host NIC for traffic to flow from the VM's through the Host NIC.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.