Solved

HP Switch Voice Vlan

Posted on 2014-11-03
23
795 Views
Last Modified: 2014-11-09
Hi,

I have a scenario that I need to create a voice vlan and create trunk port for uplink which connects to Cisco router.

We have two switches 2810-48 and 24. They are connected via Trunk (Switch1 45-48 to Switch2 21-24)

Here is the current switch configuration:

Switch1

hostname "ProCurve 2810-48G"

trunk 45-48 Trk1 Trunk

ip default-gateway 192.168.0.254

snmp-server community "public" Unrestricted

vlan 1

name "DEFAULT_VLAN"

untagged 1-44,Trk1

ip address 192.168.0.102 255.255.255.0

exit

spanning-tree Trk1 priority 4

Switch2

hostname "ProCurve Switch 2810-24G"

trunk 21-24 Trk1 Trunk

ip default-gateway 192.168.0.254

snmp-server community "public" Unrestricted

vlan 1

name "DEFAULT_VLAN"

untagged 1-20,Trk1

ip address 192.168.0.101 255.255.255.0

exit

spanning-tree Trk1 priority 4

First of all, I need to create a trunking with vlan 100 (Voice) on uplink which connects to cisco router. Port 12 will be used to connect to uplink.

My configuration would be like this:

ProCurve 2810-48G#(Config)#vlan 1

ProCurve 2810-48G#(Vlan-1)#untagged 1-11,14-44

ProCurve 2810-48G#(Vlan-1)#tagged 12 //Enable Trunk on port 12 connecting to Router

ProCurve 2810-48G#(Config)#Vlan 100

ProCurve 2810-48G#(Config)#name "VOICE"

ProCurve 2810-48G#(vlan-100)#tagged 12 //Enable Trunk on  port 12 connecting to Router ProCurve

2810-48G#(vlan-100)#untagged 13 //Connect to IAD (VINE2000) and IAD will connect to IP-PBX which all non-ip phones are connected.

Is this correct? or am I missing something here?
0
Comment
Question by:Educad
  • 12
  • 11
23 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40421257
It's hard to say because we have a terminology issue.

In Cisco, "trunking" refers to carrying multiple VLANs on a port.
In HP, it means aggregating multiple links to behave as one link.

So when you talk about creating a trunk between a Cisco router and an HP switch, I'm not sure what you're referring to.

Can you elaborate?
0
 

Author Comment

by:Educad
ID: 40422912
I am referring to the trunk in cisco term between a Cisco router and an HP switch. This link should be able to carry more than one vlan (vlan 1 and vlan 100) so that's why there is tagged commend in my configuration.

I am talking about trucking link in Cisco term and I think I should refer to this tagged in HP term? So I added two commends to create trunk link between a cisco router and an HP switch not Link Aggregation.
vlan1 -> tagged 12
vlan 100 -> tagged 12

And I also need to add voice vlan to HP switch as there will be a phone system which connects to the switch.

Please also have a look at the screenshot.
image1.png
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40422936
The term "Voice VLAN" is just means of simplifying the management on VoIP in a Cisco network.  Functionally, there is nothing special about a VLAN used for VoIP traffic.

With respect to the HP side, you will want the native VLAN untagged and other VLAN's tagged on the port which connects to the other switch.  So if VLAN 1 is the native VLAN and VLAN 50 is for data and VLAN 100 is for VoIP, you would want the following:

vlan 1 
 untagged 45
vlan 50
 tagged 45
vlan 100
 tagged 45

Open in new window


On the Cisco side it's much easier:

int g0/1
 switchport mode trunk

Open in new window

0
 

Author Comment

by:Educad
ID: 40423042
Can I still use default vlan 1 for data vlan instead of making another vlan 50?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40423048
Yes.
0
 

Author Comment

by:Educad
ID: 40423186
Thank you for answering my questions.

One last question.
ProCurve 2810-48G#(Config)#vlan 1
ProCurve 2810-48G#(Vlan-1)#untagged 1-11,14-44
ProCurve 2810-48G#(Vlan-1)#tagged 12 

ProCurve 2810-48G#(Config)#Vlan 100
ProCurve 2810-48G#(Config)#name "VOICE"
ProCurve 2810-48G#(vlan-100)#tagged 12 
ProCurve 2810-48G#(vlan-100)#untagged 13 

Open in new window


Does above configuration seem to be correct to you?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40423733
What is port 12 connected to?  You don't have a native VLAN defined on that port.
0
 

Author Comment

by:Educad
ID: 40425193
It is connected to Cisco router. isn't native vlan default on vlan 1?
0
 

Author Comment

by:Educad
ID: 40425204
And I have untagged 1-11,14-44 for vlan 1
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40425211
It is connected to Cisco router. isn't native vlan default on vlan 1?

It is on Cisco switches.  On HP you define it by not tagging the VLAN on that port.
0
 

Author Comment

by:Educad
ID: 40425226
There is no Cisco switch Don. In Cisco router there is native vlan 1
encapsulation dot1Q 1 native -> on cisco router.

On an HP switch.  ProCurve 2810-48G#(Vlan-1)#untagged 1-11,14-44 // this is native (untagged) vlan
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 50

Expert Comment

by:Don Johnston
ID: 40425258
There is no default native VLAN on Cisco routers.  The native VLAN is defined by either using the physical interface or using a sub-interfance with the "encapsulation dot1q x native" command.

So on an HP switch, you would define VLAN 1 as native by not tagging it.

vlan 1
 untagged 12
0
 

Author Comment

by:Educad
ID: 40427390
Sorry you are right. I meant using a sub-interface with the "encapsulation dot1q 1 native" command.

vlan 1
 tagged 12
 untagged 12

Would this work? because I need a trunk port (tagged port) on port 12 as well. I think if I add port 12 as tagged port, it will automatically remove port 12 from untagged port.


cisco speak = procurve (most industry) speak
access port = untagged port
trunk port = tagged port (802.1Q)
etherchannel/FEC = trunk or LACP

Sorry about the confusion.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40427402
Well, that's not quite how is works.  You can only have one VLAN untagged on a port. If you have no VLANs tagged on that port, then it's (what Cisco calls) an access port.  

If you have any VLANs tagged for that port, then it's (what Cisco calls) a trunk port.

Adding a tagged VLAN to a port does not remove the untagged VLAN from that port. It's simply makes it a trunk port.

The VLAN which is untagged on that port is always the native VLAN.

VLAN 10
 untagged 26

Open in new window

This means port 26 is an access port that is a member of VLAN 10

VLAN 10
 untagged 26
VLAN 20
 tagged 26
VLAN 30
 tagged 26

Open in new window

This means port 26 is a trunk port with VLAN 10 being the native VLAN.
0
 

Author Comment

by:Educad
ID: 40430778
Okay Don, thanks for your answer.

Here is my final configuration on our hp swtich.

hostname "ProCurve 2810-48G"
trunk 45-48 Trk1 Trunk
ip default-gateway 192.168.0.254
snmp-server community "public" Unrestricted

vlan 1
   name "DEFAULT_VLAN"
   untagged 1-10,13-44,Trk1          //untagged port - internal PCs and servers are connected 
   ip address 192.168.0.102 255.255.255.0
   tagged 11                 //tagged port for cisco router 1941 series (inter-vlan has been configured)*
   no untagged 12
   exit

vlan 100
   name "Voice"
   untagged 12            //untagged port (access port in cisco term) for phone system -PBX
   tagged 11                 //tagged port(trunk port in cisco term) for cisco router 1941 series (inter-vlan has been configured)*
   voice
   exit
spanning-tree Trk1 priority 4

Open in new window


Does this seem to be correct to you? Unfortunately, I cannot make vlan 10 for data I have to use just default vlan 1 for data. Your help would be very appreciated Don.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40430780
Please post the config of the Cisco router.
0
 

Author Comment

by:Educad
ID: 40430786
interface GigabitEthernet0/0
 ip address 10.x.x.x 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.1
 encapsulation dot1Q 1 native
 ip address 192.168.0.250 255.255.255.0
!
interface GigabitEthernet0/1.100
 encapsulation dot1Q 100
 ip address 192.168.40.250 255.255.255.0

Open in new window

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40430815
VLAN 1
 untagged 12
VLAN 100
 tagged 12
0
 

Author Comment

by:Educad
ID: 40431621
Hi Don,

Did you mean port 11 not 12?
VLAN1
 untagged 11
VLAN
 tagged 11
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40431648
No.  Port 12.  That's the port which connects to the router, right?
0
 

Author Comment

by:Educad
ID: 40431666
No. Port 11 connects to router. And port 12 connects to Dataflex IAD (VINE2000) and this device connects Panasonic IP-PBX which all non-IP phones are connected.

hostname "ProCurve 2810-48G"
trunk 45-48 Trk1 Trunk
ip default-gateway 192.168.0.254
snmp-server community "public" Unrestricted

vlan 1
   name "DEFAULT_VLAN"
   untagged 1-10,13-44,Trk1          //untagged port - internal PCs and servers are connected 
   ip address 192.168.0.102 255.255.255.0
   tagged 11                 //tagged port for cisco router 1941 series (inter-vlan has been configured)*
   no untagged 12
   exit

vlan 100
   name "Voice"
   untagged 12            //untagged port (access port in cisco term) for phone system -PBX
   tagged 11                 //tagged port(trunk port in cisco term) for cisco router 1941 series (inter-vlan has been configured)*
   voice
   exit
spanning-tree Trk1 priority 4

Open in new window

0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 500 total points
ID: 40431677
In your original post, you stated:

First of all, I need to create a trunking with vlan 100 (Voice) on uplink which connects to cisco router. Port 12 will be used to connect to uplink.
and
ProCurve 2810-48G#(Vlan-1)#tagged 12 //Enable Trunk on port 12 connecting to Router

If you have changed which port is connected to the router, then the config I posted would be for that port.
0
 

Author Comment

by:Educad
ID: 40431684
Thank you very much Don. I really appreciate your time and answers for my questions.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Security is one of the biggest concerns when moving and migrating your data from your on-premise location to the Public Cloud.  Where is your data? Who can access it? Will it be safe from accidental deletion?  All of these questions and more are imp…
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now