Solved

Exchange 2013 DBs have Content Index State Unknown

Posted on 2014-11-04
21
2,384 Views
1 Endorsement
Last Modified: 2016-05-09
I have 2 exchange 2013 servers with 4 DBs each, exch one has 2 active mounted and 2 passive healthy.

This morning I found that all 4 DBs are mounted on ExServer2, the 4 DBs on ExServer1 are healthy but their Content index state is unknown.

1. I could active the 2 DBs back to ExServer1, I get an error about the content index state that is unknown
2. Suspend/Resume did do anything
3. Suspend/Update stated movind file and I the end I get an error:

warning
Seeding of content index catalog for database 'DB4' failed. Please verify that the Microsoft Search (Exchange) and the Host Controller service for Exchange services are running and try the operation again. Error: Could not connect to net.tcp://localhost:3863/Management/SeedingAgent-6BCDDF4B-88E9-47CE-8EB6-836714D1AE9912/Single. The connection attempt lasted for a time span of 00:00:02.0313113. TCP error code 10061: No connection could be made because the target machine actively refused it 127.0.0.1:3863. .

 

Checked: all services are running.
1
Comment
Question by:nourben
  • 11
  • 6
  • 4
21 Comments
 
LVL 19

Expert Comment

by:Adam Farage
ID: 40423668
1) Try restarting the FAST Search Service (MS Exchange Search service)
2) If this does not work, recreate the catalog file (e.g: content index)

- Stop the MSExchange Search service
- In the location of the database find the content index files (it should be a separate folder with the words like CatalogData-blahblahblah)
- Remove that folder (recommend moving it somewhere else
- Start the search service, and wait for the folder to get recreated (takes about 10 -15 minutes)
0
 

Author Comment

by:nourben
ID: 40423784
Is it the folder with numbers? see attachment
DB.JPG
0
 
LVL 19

Expert Comment

by:Adam Farage
ID: 40423797
Yes.
0
 

Author Comment

by:nourben
ID: 40427091
Nothing worked, I even removed the DB copy, deleted the folders, added the copy and the same thing.

Got this error
error
DB4
The seeding operation failed. Error: An error occurred while running prerequisite checks. Error: The specified database isn't configured for replication and therefore cannot be used to perform seed operations
0
 
LVL 19

Expert Comment

by:Adam Farage
ID: 40427622
Do me a favor, run Get-MailboxDatabase "DB Name" | Get-MailboxDatabaseCopyStatus please and post it here. Also run the following command, as I think this could be replication network related:

Get-DatabaseAvailabilityGroupNetwork | FL
0
 

Author Comment

by:nourben
ID: 40428325
I cannot post the second one because it has server's name and IP addresses
0
 

Author Comment

by:nourben
ID: 40428329
First one
0
 

Author Comment

by:nourben
ID: 40428331
First one
Issue.JPG
0
 
LVL 19

Expert Comment

by:Adam Farage
ID: 40428394
Restart fast search on the passive copy and see what happens.
0
 

Author Comment

by:nourben
ID: 40428437
I have restarted the server a couple of time already and there are no Fast Search, I see:
Microsoft Exchange Search
Microsoft Exchange Search Host controller
0
Why spend so long doing email signature updates?

Do you spend loads of your time carrying out email signature updates? Not very interesting are they? Don’t let signature updates get you down. Let Exclaimer Cloud - Signatures for Office 365 make managing email signatures a breeze.

 
LVL 19

Expert Comment

by:Adam Farage
ID: 40428462
Restart both Search Service, but on the passive node. I thought you were doing it on the active node.
0
 

Author Comment

by:nourben
ID: 40428496
Just did again, nothing changed

Server1:
DB Active Mounted
Content Index state: Healthy

Server2:
DB Passive Healthy
Content Index state: Unknown

BTW: this is test environment
0
 
LVL 19

Expert Comment

by:Adam Farage
ID: 40428963
What does your DAG network look like?
0
 

Author Comment

by:nourben
ID: 40429007
Changed servernames and IPs
DAG.JPG
0
 

Accepted Solution

by:
nourben earned 0 total points
ID: 40698806
Problem was the OS hardening, Local Policy FIPS needs to be disabled.
1
 

Author Closing Comment

by:nourben
ID: 40706970
In our environment FIPS needed to disabled.
0
 

Expert Comment

by:Arun Raja
ID: 41573830
I have two exchange Server .
ONe server content index state was healthy but another server having all the database content index state unknow status.

. i try follow all setting still same Issue
0
 

Expert Comment

by:Arun Raja
ID: 41584458
I have two exchange Server .
ONe server content index state was healthy but another server having all the database content index state unknow status.

. i try follow all setting still same Issue

how to check  the OS hardening, Local Policy FIPS needs to be disabled.
0
 

Expert Comment

by:Arun Raja
ID: 41584868
No One Answer Question?
0
 

Expert Comment

by:Arun Raja
ID: 41584869
No One answer this Question
0
 

Author Comment

by:nourben
ID: 41584877
Go to control panel
Click on Adminstration tools
Click on Local Security Policy
Under Security Settings/Local Policies/Security Options
Make sure that "System cryptography: Use FIPS compliant algorithms for encryption..." is disabled

This is what fixed my issue, hope you have the same problem
EE.jpg
0

Featured Post

Don't lose your head updating email signatures!

Do your end users still have the wrong email signature? Do email signature updates bore you or fill you with a sense of dread? You can make this a whole lot easier on yourself by trusting an Exclaimer email signature management solution. Over 50 million users do...so should you!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
Find out what you should include to make the best professional email signature for your organization.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now