Termianl Server 2003 IE8, all websites showing certificate errors

Hello,

I have a Terminal Server 2003 using IE8.  All https sites that I go to show certificate errors.

Found a few articles on it,   The time is set correctly.  Nothing seems to be clearing up this error.  It is also affecting other programs (Winrater).

Not too sure where to go from here.

Larry
laltobelliIT ConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

VB ITSSpecialist ConsultantCommented:
Are you 100% sure the time and date is set correctly?
0
Dave BaldwinFixer of ProblemsCommented:
I'm not having any problems with IE8 on XP.  Have you updated the Root Certificates on that machine?

Please give a link to a site that isn't working for you along with the error that you are seeing from it.
0
Dave BaldwinFixer of ProblemsCommented:
If you are in the US, the change from Daylight Savings to Standard time was 2:00 AM Sunday.
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

laltobelliIT ConsultantAuthor Commented:
Things are a bit stranger than I originally thought.

As I stated above the time, date, timezone and daylight savings time are all correct. 11/5/14, EST,etc.....

I have reset the security in IE8.

I ran Microsoft Fix it 51014 to sync the trusted root certificates.

All SSL websites show the error as well as some non-SSL websites such as www.yahoo.com

A bank website www.leominstercu.com is an example of an SSL site that shows the error.

It is not isolated to a user, all users logging into the terminal server see the error.

Other users logged into PCs on site do not see the error.

Larry
0
Dave BaldwinFixer of ProblemsCommented:
Yahoo http://www.yahoo.com/ switches to SSL/TLS as soon as you connect to it.  I'm having no problem connecting to Yahoo with IE8.  Or with http://www.leominstercu.com/ which also will switch to 'https' when you try to connect to it.

If you can not connect to Any 'https' sites then it sounds like port 443 (which is used for 'https') may be blocked on the terminal server.
0
Dave BaldwinFixer of ProblemsCommented:
In another question today, secure connections were being blocked because Windows XP had not been upgraded to Service Pack 3.  I don't know what the service packs are for Windows 2003 but you might check that.  Also, many sites are Not connecting with SSLv3 because of a security problem last month.  Check your internet options and disable/uncheck SSL3.
0
laltobelliIT ConsultantAuthor Commented:
Hi Dave,

I checked port 443 at www.whatsmyip.org and it is open.  

The server is completely up to date will all service packs (SP2), etc...

I tried it with SSL3 on and off, no difference.

One thing to note that this did happen over the weekend, which makes it look like the time change caused the issue.  But I know the time is correct and Windows update also works - which it would not if the time was off.

This is strange.

Larry
0
VB ITSSpecialist ConsultantCommented:
Have you tried enabling TLS 1.0 in the same area where you enabled/disabled SSL 3.0?
0
laltobelliIT ConsultantAuthor Commented:
Yes I tried it with TLS 1.0 enabled and disabled.  It did not change the cert error.
0
VB ITSSpecialist ConsultantCommented:
Can you please post a screenshot of the certificate error?
0
laltobelliIT ConsultantAuthor Commented:
Here's a doc with a screen shot of what happens when I go to www.google.com and after I click continue.
cert-error.docx
0
VB ITSSpecialist ConsultantCommented:
Looks like you may need to re-sync the Trusted Root CA list on your server. You can try using the For Windows Vista, Windows Server 2008 or Windows Server 2003 Fix it link on this Microsoft KB to address the issue: http://support.microsoft.com/kb/931125
0
laltobelliIT ConsultantAuthor Commented:
Hi VB ITS,

Ran the Fix it from the link above, deleted temp files, still got the same results....

Thanks,

Larry
0
laltobelliIT ConsultantAuthor Commented:
Updated the server and rebooted it.   Seems to have addressed the issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
laltobelliIT ConsultantAuthor Commented:
No one else suggested updating the server and rebooting.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.