Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2806
  • Last Modified:

How to deactivate Hardware-Acceleration for Chrome with Powershell-Script

I want to deactivate the Hardware-Acceleration for Google Chrome with a Powershell-Script. There may be a Registry-Key or a config for this, but I don´t know where.
0
sbitsolutionDE
Asked:
sbitsolutionDE
  • 3
  • 2
1 Solution
 
Uptime Legal SystemsCommented:
Is this for Chrome across a domain?  I typically will deploy chrome changes via Group Policy in the registry section.

You can modify the value (Default) in HKLM\Software\Classes\ChromeHTML\shell\open\command and change the %1 with any of the Chrome switches you want to use.  i.e.

Change the value from "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" -- "%1" to "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --disable-gpu
0
 
sbitsolutionDEAuthor Commented:
Thanks for the fast answer, but the new Problem is, if Chrome is your default browser the "--disable-gpu" will not work because this option is saved in HKCU\Software\Classes\http\shell\open\command. For example if you click on a link in outlook. Is there no config-file where the option to deactivate the hardware-acceleration is saved?
0
 
Uptime Legal SystemsCommented:
As far as I'm aware there isn't another way to automatically disable it-- but the default browser would use the following keys:
HKEY_CLASSES_ROOT\.htm
HKEY_CLASSES_ROOT\.html
HKEY_CLASSES_ROOT\http\shell\open\command
HKEY_CLASSES_ROOT\http\shell\open\ddeexec\Application
HKEY_CLASSES_ROOT\ftp\shell\open\command
HKEY_CLASSES_ROOT\ftp\shell\open\ddeexec\Application

In your policy you can define the --disable-gpu for these as well; specifically the key in bold above.
0
 
sbitsolutionDEAuthor Commented:
I finally found the file which activates/deactivates the Hardwareacceleration:

"%LOCALAPPDATA%\Google\Chrome\User Data\Local State" << the File is Local State

to deactivate the Hardwareacceleration insert this code:

"hardware_acceleration_mode": {"enabled": false},
0
 
sbitsolutionDEAuthor Commented:
The easiest way to solve the problem
0

Featured Post

Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now