Solved

Can't connect USB 3.0 device directly after connecting through a 4 port USB hub. Still works through adapter?

Posted on 2014-11-05
48
359 Views
Last Modified: 2014-12-03
My 2013 MBP has stopped recognising a specific WD 2TB USB3.0 drive when plugged in directly after having plugged it in through a 4 port USB hub. It still works when plugged in through the same adapter but not when plugged in through another 4 port USB hub.

It worked directly before but has stopped after having connected it through the adapter once. Other drives work directly.

Cables have been checked, other USB port, rebooted machine etc.
0
Comment
Question by:asetia
  • 21
  • 14
  • 13
48 Comments
 

Author Comment

by:asetia
Comment Utility
The USB hub is a 2.0 Hub.
Susbequently, now, other USB hard drives are not being recognised either directly (USB) or through the hub. However, USB 3.0 flash drive is.
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
what is 2013 MBP ??
an usb 3 drive is compatible with USB 2; however you may have a power problem, since usb 3 provides more power to the drive than USB 2 (max = 5 V at 0.5 A = 2.5 W)
i assume your drive does not have it's own power supply?
if that is so -  use a POWERED USB hub - here a choice :  http://lifehacker.com/five-best-usb-hubs-1414094277
0
 
LVL 27

Expert Comment

by:serialband
Comment Utility
You may have to reset the PRAM.   During boot, hold the Command Option p r keys and let the Mac chime.  I suggest disconnecting the hub first from your MacBook Pro when you do this.

The MBP should have more than enough power to run the external drive.  I have several that include a 2nd USB connector and I just use one.
0
 

Author Comment

by:asetia
Comment Utility
The drive used to work just fine until I connected it through the hub. After using it connected through the hub it doesn't work connected directly (note the hub does not have a separate power supply) but it still works through the hub.

I've reset SMC and PRAM but neither have made any difference.
0
 
LVL 27

Expert Comment

by:serialband
Comment Utility
Boot into safe mode by holding the Shift key at boot and see if new drivers need to be loaded.  Is this Yosemite(10.10) or are you still on Mavericks (10.9.x)?
0
 

Author Comment

by:asetia
Comment Utility
I tired booting in Safe Mode and still can't see the drive in Finder or Disk Utility.

There was no request for drivers.

I'm using Yosemite (10.10)

I plugged the Hard Drive into an old MBP and it shows up and works fine there.
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
read my post...
0
 

Author Comment

by:asetia
Comment Utility
Dear Nobus,

Thank you for the interest. I had read your post and thought I'd addressed the points (except MBP, which is an abbreviation I used for MacBoo Pro, it is a late 2013 model).

The drive does not have it's own power supply but it used to work when plugged in directly. Therefore, I assume it snot a power issue. Unless using the adapter has damaged the USB port's ability provide the power it used to. I have a USB pen drive which works fine but that will draw less power.

The drive is working with one USB hub (not powered) but at USB 2.0 level.

I have another USB 3 hub but the drive isn't showing up when connected through that hub (the pen drive is).

Thus, I assume, it's not a powered hub issue.
0
 
LVL 27

Expert Comment

by:serialband
Comment Utility
Have you unplugged the hub and attempted connecting the drive without the hub in place?

It's possible some drivers got corrupted on you system in /System/Library/Extensions/ but I'm not sure where it would be.  Possibly one of the following:

AppleStorageDrivers.kext
CoreStorage.kext
IOBDStorageFamily.kext
IOStorageFamily.kext
IOUSBMassStorageClass.kext

There may be a USB hub .kext entry that you may have to delete.  I'm just guessing, though.

If you have an identical MBP you might be able to compare them.

I had something similar happen with a USB to serial cable a while back.  Unfortunately, I resorted to a reinstall, even though I was able to remove/unistall the kext.
0
 

Author Comment

by:asetia
Comment Utility
I had a look and the only kext files added or modified after the date I got the the USB hub (which I ordered last month) is: AppleKextExcludeList.kext (which I think is still before I plugged it in).

If I try deleting some of these, do you know if they will reinstall?
0
 
LVL 27

Expert Comment

by:serialband
Comment Utility
DON'T delete them.  You can load and unload them with kextunload and kextload.  Move them aside if you need to, but keep them around to place them back.

sudo kextunload /System/Library/Extensions/IOUSBMassStorageClass.kext/Contents/PlugIns/IOUSBMassStorageClass

sudo kextload /System/Library/Extensions/IOUSBMassStorageClass.kext/Contents/PlugIns/IOUSBMassStorageClass
0
 

Author Comment

by:asetia
Comment Utility
There seems to be a path difference in Yosemite in Contents: System/Library/Extensions/IOUSBMassStorageClass.kext/Contents/MacOS/IOUSBMassStorageClass

When I enter:
sudo kextunload /System/Library/Extensions/IOUSBMassStorageClass.kext/Contents/MacOS/IOUSBMassStorageClass

I get an error message:
Can't create /System/Library/Extensions/IOUSBMassStorageClass.kext/Contents/MacOS/IOUSBMassStorageClass.

There is also a file IOUSBFamily.kext. Should I also try with this file.

After I've unloaded them, do I need to reboot the machine? If so, when should I reload them?
0
 
LVL 27

Expert Comment

by:serialband
Comment Utility
No, if you've unloaded them, then they're unloaded until the next reboot.  Try connecting the drive.  Then try unloading the other kext files.  Don't remove them until you're sure that they're the cause of the problem.  As I said before, I ended up reinstalling even after I found my USB to Serial Kernel Extension file.

I also wouldn't delete them after unloading them.  You may want to just move them aside, so that you can put them back.
0
 

Author Comment

by:asetia
Comment Utility
At the moment I can't unload them as I get the error message:

Can't create /System/Library/Extensions/IOUSBMassStorageClass.kext/Contents/MacOS/IOUSBMassStorageClass.


Any idea why this message is coming up?
0
 
LVL 27

Expert Comment

by:serialband
Comment Utility
Try this?

sudo kextunload /System/Library/Extensions/IOUSBMassStorageClass.kext
0
 

Author Comment

by:asetia
Comment Utility
Got the following message:

(kernel) Can't remove kext com.apple.iokit.IOUSBMassStorageClass; services failed to terminate - 0xdc008018.
Failed to unload com.apple.iokit.IOUSBMassStorageClass - (libkern/kext) kext is in use or retained (cannot unload).
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
>>  The drive does not have it's own power supply but it used to work when plugged in directly. Therefore, I assume it snot a power issue.   <<   well  - imo there is only one way to test : with a powered usb hub
look if a friend has one, and ask him to lend it for testing, if you don't want to buy one
0
 
LVL 27

Expert Comment

by:serialband
Comment Utility
I'm a bit stuck, try unloading a different kext.

@nobus
I believe that he's been saying that it only works on his non-powered hub when connecting to his Mac.  It doesn't work when connected directly or through another hub.  It's a retarded Mac driver issue.  I've encountered something similar and resorted to reinstalling because there aren't enough really technical people that can diagnose these Mac driver and kernel issues and post online.  There's still 10-20 times more Windows PC users.
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
that can be  - and i understood him fully
0
 

Author Comment

by:asetia
Comment Utility
On reflection, I'm a bit concerned about trying other kexts as I don't know which ones are safe to remove and which could turn the machine into a 'brick'.
0
 

Author Comment

by:asetia
Comment Utility
I'm rather stuck as to what to do next. There also seems to be a corruption issue:

one USB 3 .0 drive (WD 1TD My Passport Essential SE USB 3.0) which was being recognised on an old MacBook Pro (2009) is no longer lighting up. This could be a co-incidence
USB 2.0 drive's (WD 1TD My Passport Essential) Mac OS Extended partition can't be mounted anymore on this machine and the old MacBook Pro but an MS DOS (FAT 32) partition is recognised and is mounted when this is plugged in. I used this drive yesterday to look at some files in Time Machine on the Mac OS Extended partition on the MacBook Pro on which I have the USB 3.0 problem

At the moment, both my drives with backups now don't get recognised and I don't have another backup and I can't get an appointment with Apple before Friday 14 November. I dare not reformat my second drive with the backup as it could potentially be recoverable and the other one just isn't loading.
0
 
LVL 91

Assisted Solution

by:nobus
nobus earned 100 total points
Comment Utility
i suggested testing with a powered usb hub - why don't you try it
it's an easy , fast, and GOOD solution for all usb devices !
0
 

Author Comment

by:asetia
Comment Utility
Couldn't find a USB 3.0 one in the shop, all were 2.0. Ordered one from Amazon, which should arrive tomorrow.

Also picking up 2 new My Passport USB 3.0 drives to back everything up again and test.
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
post results
0
Get up to 2TB FREE CLOUD per backup license!

An exclusive Black Friday offer just for Expert Exchange audience! Buy any of our top-rated backup solutions & get up to 2TB free cloud per system! Perform local & cloud backup in the same step, and restore instantly—anytime, anywhere. Grab this deal now before it disappears!

 

Author Comment

by:asetia
Comment Utility
I've got the two new USB 3.0 drives and they work fine.

Looks like my USB adapter has done something to the circuit board on the drives when they connected to it. I tried them on a Windows laptop. One USB 3.0 and the USB 2.0 work when connected to a USB 2.0 port on the laptop but the USB 3.0 drive doesn't work when connected to the USB 3.0 port on the same laptop (the USB 2.0 drive works on both ports). Something more has gone on the other USB 3.0 drive as it doesn't connect through any port (but he light comes on and the disk spins).

I'm creating a new Time Machine backup on one and will try to retrieve the data on one of the USB 3.0 drives through my old Macbook Pro (as it has only USB 2.0) as that is currently the only way I can read off it.

I will try the old drives with the powered USB hub tomorrow when I get it to see if power does make a difference.
0
 
LVL 27

Assisted Solution

by:serialband
serialband earned 400 total points
Comment Utility
You should probably toss out that other USB 2 adapter.  It may corrupt other disks.
0
 

Author Comment

by:asetia
Comment Utility
Thanks.

I'm so irritated with the whole episode. I've already tossed it.
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
i must say - it is the first time  i hear an usb hub corrupting a drive
post results with the new hub!
0
 

Author Comment

by:asetia
Comment Utility
Dear Nobus,

It is astonishing. I didn't think hubs made much of a difference. I will never buy a cheap one again.

I have contacted Western Digital and will send one of the drives to them, which they'll check and should replace (but that will take a couple of weeks or so to resolve). The other two are out of warranty.

I'll update you to see if the powered 3.0 hub makes a difference (it didn't arrive yesterday but should arrive today).
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
thanks in advance !
0
 
LVL 27

Expert Comment

by:serialband
Comment Utility
I remember having something similar happen with a built-in hub to a Dell monitor several years ago, but it didn't cause any permanent damage.  Reboots and/or driver reinstalls fixed them.  I just taped up the ports and stopped using the USB on it, since it kept getting corrupt.
0
 

Author Comment

by:asetia
Comment Utility
I had already tried resetting the SMC and PRAM on MacBook Pro several times and updated the firmware on the 2 drives that I can read (1 x USB 3.0 drive and 1 x USB 2.0 drive) and it hasn't made a difference so far.

I've now tried the USB 3.0 hub (Anker USB 3.0 7-Port Portable Aluminum Hub with 5V 4A Power Adapter
[VIA VL812 Chipset]).

One USB 3.0 drive shows up is Disk Utility but can't be mounted, verified or repaired. The other USB 3.0 drive remains bricked. The other USB 2.0 drive seems to read properly and now doesn't show any errors but isn't registered with the Time Machine (it has old backups on it which I can see in Finder but Time Machine sees it as a new drive. Don't know if this is to do with the firmware update).
0
 
LVL 27

Expert Comment

by:serialband
Comment Utility
Mine was with Windows, back then.  It was a different beast.
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
the only way i see a hub corrupting a drive is by a short in the cable - or connector
0
 
LVL 27

Accepted Solution

by:
serialband earned 400 total points
Comment Utility
Or a failed chip circuit.  The hubs have routing circuitry.  You can't send all the signals from each of the ports at the same time on the same USB wire.  There's circuitry to manage that on a hub.
0
 

Author Closing Comment

by:asetia
Comment Utility
Thanks for all the help.
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
asetia, why the C grade?
you don't estimate we gave good advice?
on EE - a normal grade is A, only if you find that it is not good, you give a B  (and certainly not a c, unless you don't find the answers good at all)
0
 

Author Comment

by:asetia
Comment Utility
Sorry to have irritated you. I'm not aware of the grading protocol and what it's used for.

The reason I gave C was the actual problem was just faulty hardware. The advice was excellent and I really appreciate it. My impression is the grade is used for others to find suggestions for their problems.

As you've pointed out the protocol, I'm happy to change it to a Grade A as both of you went out of way and were very helpful and educative.

I now need help to understand how to change the grade.
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
just hit request attention in your Q, and ask a MOD to change the grade, or assist you

**i'm not irritated  -i merely pointed out it did not seem ok by the EE rules
0
 
LVL 27

Expert Comment

by:serialband
Comment Utility
I don't really care about the points, so grade however you like.  If it doesn't answer your question fully, then a C is appropriate.  If it doesn't answer it at all then a delete is in order.  Giving an A means we solved your problem completely, and I don't think we did, so an A is not deserved.  Points are not important.  It's the solutions that help you that are important.

Those two drives may not be dead.  It may just be the USB to SATA chip on them that went bad.  Take them out of their enclosures and get yourself one of these cables:

http://www.amazon.com/Patuoxun-Converter-Adapter-Cable-Drive/dp/B008ASF5MC/ref=pd_sim_e_3/191-3948904-6282813?ie=UTF8&refRID=0665MGP8RYCECK2J0K31

This one comes with a plastic box to hold the drive for packing and transport.  I have one and find them much more convenient than enclosures for wiping disks and other basic diagnostics.

I still have the older, bulkier USB to IDE/SATA cables for the older IDE drives or powered 3.5" SATA, but I haven't used that in 2 years.
0
 

Author Comment

by:asetia
Comment Utility
Thanks for the suggestion. You won't believe this, but a brand new WD Passport Ultra 2TB (that I bought to back everything up on) just blew with the new powered USB 3.0 hub http://www.ianker.com/product/68ANHUB-S7A (although it wasn't powered at the time). This drive has a lot of stuff I don't have backed up anywhere else. Not critical stuff but years of downloaded material, which I'd transferred from the old drive.

I'm in India at the moment and I gave it to a 'Data Recovery shop' and they can't restore it without 'ripping it apart'.

I can't understand why WD make drives that give no option for recovery if their circuit board fuses/blows that doesn't involve breaking the warranty. They are very helpful in replacing the drives but just don't seem to care about anyone's data (which is what I thought the purpose of their product is). I'm in two minds as to 'lose the data' and get the drive replaced by WD (and risk the same problem again) or to take it apart, lose the warranty and hope to recover the data and get it working in the manner you suggest above (because, if it doesn't work I've effectively thrown away a brand new 2TB drive).

I'm now wondering if there's a problem with my MacBook Pro and Yosemite and am petrified of plugging in my back WD drives. Are these drives really bad?

FYI: WD have replaced the old Ultra 2TB drive and it's being shipped.
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
i don't believe they make "bad" drives
you may have a problem on your PC -check the usb connector
or test with low cost decvices, like flash stick, or mouse
0
 

Author Comment

by:asetia
Comment Utility
I've done that. They all work fine.

Obviously I had a good impression, which is why I bought so many of them. I have to say WD customer care is excellent. Just can't understand why they make it totally proprietary and un testable. Probably to do with their security software.

(FYI: It's a MacBook Pro not a PC and I do believe there are some problems running OS X Yosemite and USB connections but they seem to be recognition issues rather than 'blowing' circuits).
0
 
LVL 27

Expert Comment

by:serialband
Comment Utility
The drive manufacturers seesaw between bad drives.  It depends on the models and batches.  A few years ago, all the 1.5 TB Seagate 3.5" drives were pretty bad, but the rest of them were stable.  Further back, there were the IBM "deathstars", etc... You may want to buy a different sized WD to get different drive geometries to test out.  You might try a new manufacturer for these 2 TB portable drives.

There's the Toshiba Canvio and Seagate Backup Plus Slim 2TB.  Maybe those might work better for the 2 TB sizes.  Don't stay married to one company.  They've all had their bad batches at one time or another.

Also, do you have electrical power fluctuations in your area.  I had to put multiple surge suppressors and UPS on mine until they replaced my line transformer after it blew up one day.  Prior to the replacement, I've actually had 2 UPS die on me, not from the battery, but the cicuitry.  It's all the fault of the Electrical company, because ever since the new line transformer, I rarely replaced any fluorescent lights now and I haven't replaced the UPS.  They actually last the full rated specs.
0
 

Author Comment

by:asetia
Comment Utility
Sorry for the delay in reply. I was travelling in India and due to the lost time on the Hard Drives I had no time to follow up.

I don't have voltage fluctuations at home.

I am having some unusual problems with my MacBook Pro and Yosemite. Powerpoint isn't opening 1 particular file. Preview crashes quite often on large PDFs.

Thanks for the info & advice. I also bought a Toshiba 2TB Canvio.
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
anymore help needed?  not sure from the above..
0
 

Author Comment

by:asetia
Comment Utility
No thanks for your help. I'll contact the administrator.
0
 
LVL 27

Expert Comment

by:serialband
Comment Utility
A reset of the PRAM and the SMC usually fixes many of the problems.  Follow that up with a disk repair.  These should fix the vast majority of your basic problems before actually needing to contact you admin.

Reset PRAM ==> Reboot, then press and hold the 4 keys, Command Alt p r during boot.  Hold it for 3 chimes to be sure that it's fully reset.

SMC reset for newer mac books without customer removable batteries ==>
Shut down mac
Plug in power
Press and hold 3 left keys, shift control alt and the power button on the top right and hold for at least 10 seconds.  Let go of the power button and 3 keys and boot normally.

For Disk repairs ==>
Start Disk Utility
then do the following 3 things
  Repair File Permissions
  Verify Disk
  Repair Disk
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now