Solved

autodiscover exchange 2010 server 2008 R2 error 500

Posted on 2014-11-06
16
1,030 Views
Last Modified: 2014-11-15
We are trying to setup autodiscover on our exchange server and are having issues. test exchange remote connectivity is failing on the last step. I have checked internal and external urls, rebuild the autodiscover virtual directory and when we go to the web address externally it asked for credentials and then displeys the error 600 which I believe is correct.

Any ideas? See output form connectivity tester below.

The Microsoft Connectivity Analyzer is attempting to retrieve an XML Autodiscover response from URL https://autodiscover.xxxxxxx.com:443/Autodiscover/Autodiscover.xml for user ohare@xxxxxxx.com.
       The Microsoft Connectivity Analyzer failed to obtain an Autodiscover XML response.
       
      Additional Details
       
An HTTP 500 response was returned from Unknown.
HTTP Response Headers:
Content-Length: 0
Cache-Control: private
Date: Thu, 06 Nov 2014 14:50:24 GMT
Server: Microsoft-IIS/7.5
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET
Elapsed Time: 364 ms.
0
Comment
Question by:YorkData
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 5
  • 2
  • +1
16 Comments
 
LVL 19

Expert Comment

by:Adam Farage
ID: 40426306
What are the permissions you have on the AutoDiscover Virtual Directory?

Get-AutoDiscoverVirtualDirectory | FL 

Open in new window

0
 

Author Comment

by:YorkData
ID: 40426332
Please see output below

[PS] C:\Windows\system32>Get-Au<wbr ></wbr>toDiscover<wbr ></wbr>VirtualDir<wbr ></wbr>ectory | FL

RunspaceId                      : d7a03a49-a3fb-40bc-9ecd-93<wbr ></wbr>47826590e6<wbr ></wbr>
Name                            : Autodiscover (Default Web Site)
InternalAuthenticationMeth<wbr ></wbr>ods   : {Basic, Ntlm, WindowsIntegrated}
ExternalAuthenticationMeth<wbr ></wbr>ods   : {Basic, Ntlm, WindowsIntegrated}
LiveIdSpNegoAuthentication<wbr ></wbr>      : False
WSSecurityAuthentication        : False
LiveIdBasicAuthentication       : False
BasicAuthentication             : True
DigestAuthentication            : False
WindowsAuthentication           : True
MetabasePath                    : IIS://server.xxxxxxx.local<wbr ></wbr>/W3SVC/1/R<wbr ></wbr>OOT/Autodi<wbr ></wbr>scover
Path                            : C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Au<wbr ></wbr>todiscover<wbr ></wbr>
ExtendedProtectionTokenChe<wbr ></wbr>cking : None
ExtendedProtectionFlags         : {}
ExtendedProtectionSPNList       : {}
Server                          : server
InternalUrl                     :
ExternalUrl                     :
AdminDisplayName                :
ExchangeVersion                 : 0.10 (14.0.100.0)
DistinguishedName               : CN=Autodiscover (Default Web Site),CN=HTTP,CN=Protocols<wbr ></wbr>,CN=server<wbr ></wbr>,CN=Server<wbr ></wbr>s,CN=Excha<wbr ></wbr>nge Administrative Group (FYDIBOHF23SPDLT),CN=Admin<wbr ></wbr>istrative Groups,CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Co<wbr ></wbr>nfiguratio<wbr ></wbr>n,DC=xxxxx<wbr ></wbr>xxx,DC=loc<wbr ></wbr>al
Identity                        : server\Autodiscover (Default Web Site)
Guid                            : 42f80cd4-ad65-4603-9d05-a2<wbr ></wbr>172b300c8a<wbr ></wbr>
ObjectCategory                  : xxxxxxx.local/Configuratio<wbr ></wbr>n/Schema/m<wbr ></wbr>s-Exch-Aut<wbr ></wbr>o-Discover<wbr ></wbr>-Virtual-D<wbr ></wbr>irectory
ObjectClass                     : {top, msExchVirtualDirectory, msExchAutoDiscoverVirtualD<wbr ></wbr>irectory}
WhenChanged                     : 06/11/2014 14:44:33
WhenCreated                     : 06/11/2014 14:44:33
WhenChangedUTC                  : 06/11/2014 14:44:33
WhenCreatedUTC                  : 06/11/2014 14:44:33
OrganizationId                  :
OriginatingServer               : server.xxxxx.local
IsValid                         : True

Open in new window

0
 
LVL 19

Expert Comment

by:Adam Farage
ID: 40426339
Does it work externally, or no? I would run outlook.exe /rpcdiag from an external client and screen shot that for us. Your permissions look fine but I would imagine if its working externally then the testexchangeconnectivity.com website is giving issues (which I have seen before).
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:YorkData
ID: 40426578
No it doesn't work externally.

I ran rpcdiag however it didn't display any connections to the Exchange server at all. We're only enabling autodiscover to migrate over to to Office365 frustratingly!

Any other ideas?
0
 
LVL 2

Expert Comment

by:Vinod Pawar
ID: 40428158
Please Set External and Internal Url for Autodiscover and also Make sure there is proper Entry of DNS for Autodiscover.*.domain.com.
After Setting this both check internally if your URL is working properly or you can check with Outlook with holding Cntrl key and Right click on Outlook Icon and click Test Email Autoconfiguration and you will found errors and get to root cause.
0
 
LVL 19

Expert Comment

by:Adam Farage
ID: 40428311
@Vinod.. the AutoDiscover InternalURL and ExternalURL are *not* used at all. They are there due to the way the Exchange schema objects are extended for Virtual directories.
0
 

Author Comment

by:YorkData
ID: 40428338
I've done all of this however internally I am still getting the same error from test email autoconfig.

See attached image - we keep getting this error code 500. Out of office is also no longer working from within outlook.
0
 

Author Comment

by:YorkData
ID: 40428344
I've set the autodiscovery urls within the client access not the autodiscovery virtual dir.
0
 
LVL 19

Expert Comment

by:Adam Farage
ID: 40428966
no image attached, but if you have one with the Test-EmailAutoconfig I would love to see it. it would help us further troubleshoot this issue.
0
 
LVL 31

Assisted Solution

by:Gareth Gudger
Gareth Gudger earned 200 total points
ID: 40430929
Hey York,

What accounts are you testing with? Your own? If so, they may be a protected account and you may need to set the Security Inheritance check box to enabled in Active Directory Users and Computers.

Active Directory Users and Computers >> Properties of your user >> Security tab >> Advanced button >> make sure Security Inheritance is checked >> Retest.

Protected accounts (those that are domain admins, etc.) will revert back to unchecked after about 15 minutes.
0
 

Author Comment

by:YorkData
ID: 40431539
I have tested this with multiple accounts, my admin one and normal user. I have also tried checking the inheritance tick box and removing admin count 1.

Please see image attached this time, how do I run the test-emailautoconfig? It doesn't seem to be a command in shell for Exch2010

I've rebooted the server this weekend to see if this helped but it hasn't.

Thanks for your help.
Capture.JPG
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40431904
What happens if you try to browse to your autodiscover URL in a browser?
0
 

Author Comment

by:YorkData
ID: 40432155
I get an authentication screen and then the below - which I believe is correct

This XML file does not appear to have any style information associated with it. The document tree is shown below.
      <Autodiscover><Response><Error Time="08:25:09.8583711" Id="2245846463"><ErrorCode>600</ErrorCode><Message>Invalid Request</Message><DebugData/></Error></Response></Autodiscover>

Open in new window

0
 
LVL 19

Assisted Solution

by:Adam Farage
Adam Farage earned 200 total points
ID: 40432454
Try resetting the autodiscover virtual directory. Sounds like something is hosed up in there.
0
 

Accepted Solution

by:
YorkData earned 0 total points
ID: 40432878
I've worked it out - there was a binding on port 80 in IIS which was bizarrely causing the issue. It temporarily broke the EMC but its all now working. Thanks for your input guys.
0
 

Author Closing Comment

by:YorkData
ID: 40444278
I found my own solution from other websites. I have added the solution to this thread.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Find out what you should include to make the best professional email signature for your organization.
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question