Opening .jpg files - Could not complete your request because an unknown or invalid JPEG marker type is found.

Hello Experts - Someone in the Marketing department called me this morning, he was unable to open most of the .jpg files on the server.  When I tried I had the same problem.  There are tens of thousands of pictures on the archive, most of them are giving us this error which just started today.  There have not been any recent changes so I'm at a loss as to what the problem might be, please advise!
danbrown_IT ManagerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Here is an Adobe KB on the problem:

The most likely cause is a wrong file extension
Phillip BurtonDirector, Practice Manager and Computing ConsultantCommented:
I would suggest try posting one of them, and see what others can see.

If you can't, then it would also be interesting if you can read the metadata. To do this singly, right-hand click on it and go to Details. You should see document properties similar to what is shown in on this page. To do this en masse, use a metadata extractor such as Filecats Professional. It will enable us to see how corrupt the files are (if they are), and to what extent.

Alternatively, try another viewer. I would suggest downloading IrfanView and see if it can open it.
Phillip BurtonDirector, Practice Manager and Computing ConsultantCommented:
Sorry - didn't get that it was Adobe Photoshop.
OWASP Proactive Controls

Learn the most important control and control categories that every architect and developer should include in their projects.

danbrown_IT ManagerAuthor Commented:
It is not a problem with the wrong extension, we've opened these files many, many times over the years and nothing has changed on the share.

I've attached one here for you guys to check out:


The only metadata that appears on the file is the basic stuff like last access date.

I've tried a number of viewers, they all give various errors.
It is also possible that the files were saved with the wrong extension and are not in fact jpegs.  

Are you on a Mac or a PC?

On a Mac, try right-clicking on a file and choose Open With Preview. Then pull down the tools menu to "Show Inspector" to see what type of file it actually is. If it will open in Preview, you should be able to do a "save as" and save it as a jpeg with a new name.

On a PC, you may be able to do much the same by opening it in MS Paint.
danbrown_IT ManagerAuthor Commented:
strung - as I mentioned we've opened these files numerous time in the past and nothing has changed...they all have the correct extension.

I am on a PC, the files will not open for any application that I have tried including MS Paint.
EirmanChief Operations ManagerCommented:
This is a serious problem

I presume that no workstation is able to open the files in any image viewer.
Assuming that the files have not been renamed/changed they must have been corrupted.
If jpgs have been corrupted, then other files have been corrupted.
jpegs are more prone to corruption than other file types.

It's time go to backups and consider hardware / hard disk problems.
There are programs that will repair some corrupt jpegs.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
I agree with Eirman. I was unable to open your attachment with anything other than a text editor. It seems to be that the file is likely corrupted.
Do you have backups on another volume? Can you open the backups? If you can then the drive that the jpegs are on is likely corrupted. Check the server drive for corruption.

Alternatively, there is a remote possibility that it is a network problem. Can you open the files directly on the server?
danbrown_IT ManagerAuthor Commented:
They live on a NAS, no interface to open them with.  I do have backups but they are not current and don't cover many of them.  Thanks for the assistance.
EirmanChief Operations ManagerCommented:
Hi danbrown, I don't think this is now an "Image / photoshop" issue.

I would recommend that you post another question in the windows OS / Hardware / Server sections
and give a link back to this question.

Good luck.
EirmanChief Operations ManagerCommented:
danbrown, I do not agree with the way you closed this question.
Point 'distribution' was unfair.
I agree. Points should be split with  Eirman.
EirmanChief Operations ManagerCommented:
Thanks for your intervention strung.
danbrown_IT ManagerAuthor Commented:
Sorry guys, that's what I had meant to do.  I'll fix it.
danbrown_IT ManagerAuthor Commented:
All fixed, thanks guys!
EirmanChief Operations ManagerCommented:
Thanks danbrown,
I hope you get your photos back.
Looks like I'm screwed.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Adobe Creative Suite CS

From novice to tech pro — start learning today.