Installing mod-auth-mysql on Ubuntu 12.04 LTS

After I upgraded to the latest version of PHP, mod-auth-mysql stopped working. When I try to install it, I get:

root@l1:/var/log/apache2# apt-get install libapache2-mod-auth-mysql
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libapache2-mod-auth-mysql : Depends: apache2.2-common (>= 2.2.3-3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Open in new window


Please advise, thanks.
MarkProgrammerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dr. KlahnPrincipal Software EngineerCommented:
Your debian-based linux system requires that the module "apache2.2-common" be installed before "libapache2-mod-auth-mysql" can be installed.

Apache 2.2 may not be installed, or the apt database may be corrupt, or you may be running some other version of Apache rather than 2.2, or Apache may have been built from sources rather than installed by debian.  There are probably other possibilities as well but these are the ones which come to mind.

IF:
Apache 2.2 may not be installed
Do a full system backup so that if anything goes wrong, you can restore the system to its current state.  Then issue the command apt-get install apache2.2-common.  After Apache 2.2 is properly installed you should be able to install the module.

IF:
The apt database may be corrupt
Same as above, but back up your current Apache configuration first.

IF:
Running some other version of Apache rather than 2.2
Upgrade to Apache 2.2 or find a version of the module compatible with your current version.

IF:
Apache may have been built from sources rather than installed by debian.
Install "libapache2-mod-auth-mysql" from a source kit instead of as a debian install.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MarkProgrammerAuthor Commented:
Trying to the simplest suggestion (I'm not sure how to do the others): I get the following

root@l1:/var/log/apache2# apt-get install apache2.2-common
Reading package lists... Done
Building dependency tree
Reading state information... Done
[b]apache2.2-common is already the newest version.[/b]
The following packages were automatically installed and are no longer required:
  libterm-readkey-perl libdbd-mysql-perl
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@l1:/var/log/apache2#

Open in new window

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.