Solved

WD MyCloud (External HD) not easily accessed.

Posted on 2014-11-06
12
2,807 Views
Last Modified: 2014-11-11
This is an example of how "Technical Support" is an oxymoron: WD refuses to admit its problems with Java; and, Netgear (WNDR3400v3) refuses to acknowledge its difficulties with a WD External HD. With that kind of attitude how can anything be resolved???
THE PROBLEM: If I attempt to access the MyCloud drive through "Network" in Windows Explorer, everything is fine.
However: the WD MyCloud is directly connected to my Netgear router with a static address (192.168.1.5); thereby making the drive accessible to both my laptop and my wife's laptop on our wireless network.
I have heard the words "ports" "certificates" thrown around but nothing conclusive.
Each time I attempt to access the WD MyCloud drive through the WD MyCloud icon, the connection stops with a message about secure networks and certificates??? Having dealt with these 2 companies over their hardware and connection problems, I admit 2 things: (1) I am frustrated by their less than professional behavior; and (2) with so many ideas thrown at me, I admit I am terribly, awfully confused.
Please!  Please!  If there is anyone who can help me: I need you!!!
Also, please find the jpg image of the message I receive each time I attempt to access the WD MyCloud drive through the MyCloud desktop icon.
In advance, I THANK YOU!
GadgetDude
Secure-Connection.jpg
Secure-Connection.jpg
0
Comment
Question by:GadgetDude
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 3
  • 2
12 Comments
 
LVL 36

Expert Comment

by:Kimputer
ID: 40427347
Press view certificate, upload screenshot again. Also show which url is in the address bar.
0
 

Author Comment

by:GadgetDude
ID: 40427506
Please find enclosed the 3 screenshots on a certificate which, I must tell you, I have already installed 3 times. The installation of said certificate accomplished nothing.
I saw no URL at the top of the screen. I hope this information is helpful.  Thank You.
Certificates.jpg
0
 
LVL 31

Expert Comment

by:Frosty555
ID: 40427590
The WD MyCloud program is a Java applet which connects to your WD external hard drive using a secured, encrypted connection.

The technology that secures the connection (SSL) requires the device to present you with a certificate that proves it's identity and provides information needed to perform the encryption. This certificate is supposed to be signed by a trusted third party authority so that you can be assured that it is genuine.

The WD devices use certificates, but they are not signed by an authority that you trust. This is normal, because certificate signing would cost a annual fee and it's purpose is to prove the identity of the remote party (e.g. PayPal's website would use a properly signed SSL certificate that proves that it really IS PayPal, and not an imposter). This isn't particularly important to you with the WD external hard drive, and the hoops that you and they would need to jump through to achieve it aren't worthwhile.

So, as a result, you see this certificate error message, which is normal.

Can you not just click the "yes" button and push past the error?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:GadgetDude
ID: 40427826
Yes, I can "yes."  LOL
What is driving me crazy is this annoying extra step; because:
(1) 10 days ago I could access the drive without any "yes;" and
(2) the certificate I am asked to install does not do so (even though I installed it six times, unsuccessfully) and "yes" reappears.
So, my question is: WHAT CHANGED from an easy access to now a Security "yes?"
I understand what you were saying; I just don't understand the difference – what changed?
0
 
LVL 36

Expert Comment

by:Kimputer
ID: 40428079
It could be some settings in Internet Explorer that has been reset. While it's a java applet, I think you're using IE, and the screens look like IE. Therefore:
Import the certificate to your Trusted Root Certification Authorities store of the Local Machine  (not the default/auto)
Put the URL in the Trusted Sites.
If the URL really matches the certificate, this warning screen should now be ignored (though I think higher IE versions still show it, due to higher security standards)
Chrome will also always show a warning screen. Only Opera (12.17) will allow you to check the "ignore warning next time" option.
Firefox might have an option to put this site in an exception list also, but didn't try it out myself yet.
0
 

Author Comment

by:GadgetDude
ID: 40430012
I will Try your suggestions.
I am extremely dubious about the results. Especially since yesterday, when I read an article that said Microsoft is quietly moving away from windows seven; and we will be forced to Windows 10. And when that happens: for all of us – all bets are off. In fact, I'm thinking why even bother with this if Windows 10 is coming out next six months, maybe sooner. But I do thank you for your help and for everything you have done. I am grateful.
0
 

Author Comment

by:GadgetDude
ID: 40430016
We shall see what happens. I'll get back to you after the weekend.
GadgetDude
0
 
LVL 31

Expert Comment

by:Frosty555
ID: 40431524
Hi GadgetDude,

Java and Internet Explorer have both recently gotten a lot stricter in recent times with regards to how SSL certificates are validated, and how difficult it is to "ignore" the errors. This is part of how the underlying technology of SSL certificates work. Windows 10 isn't going to introduce any changes to the way this works, it's a separate technology.

For an SSL certificate to be transparently accepted and work properly, you need several things to be in place:

1) The certificate must have a valid expiry date in the future
2) The certificate must be signed by a trusted certificate signing authority
3) The certificate must not be revoked
4) The certificate must use a sufficiently strong hashing algorithm accepted by the browser
5) The certificate's "common name" or one of the "subject alternative names" must match the hostname you are connecting to

Your computer contains a default list of "trusted root certificate authorities", a handful of companies in the world who are entrusted with the responsibility of signing SSL certificates. This certificate is not signed by one of those entities. It looks like it is self-signed, so you need to import the certificate into your "Trusted Root Certification Authorities" store on the machine.

#1, #3 and #4 are probably fine.

You might also be stumbling on #5. Your certificate's common name is "*.device1565045.wd2go.com", meaning you must connect using that hostname. What hostname are you using (what's in the address bar in your browser?).
0
 

Author Comment

by:GadgetDude
ID: 40431886
I am feeling so stupid that I am thinking of closing this inquiry. This is more complex than I realized.
How do I import "*.device1565045.wd2go.com" to a "Trusted Root Certification Authorities" store on the local machine (Registry Editor)? I don't know where any of this stuff is. What is hostname?
Again, I am embarrassed to show my ignorance. I feel humiliated and old.
I have IE on my Laptop, I only use Chrome or Firefox.

I am still googleing a way out of this?!?
GadgetDude :(
0
 

Author Comment

by:GadgetDude
ID: 40431929
Kaplaa!  ("Success" in Klingon). I think...I will have to test this for a couple of days before I can confirm Problem Solved.
I took everything that has been offered, read it 2 or 3 times in an effort to understand, and this was the result:
[1] When asked to Install Certificate, I browsed and found "Trusted Root Certification Authority" selected it and hit Finish. It seemed to work; however, when I restarted the laptop, apparently the install did not take.
[2] I repeated the certificate install a second time; although I installed BOTH "Trusted Root Certification Authority" and "Untrusted Certificate." Hitting Finish and than restarting the computer it seemed the problem was solved. Whether I was in the Admin account and/or my Personal standard account, each time I accessed the WD MyCloud it was successful with no "Security Alert" or Certificate problem. What most important is that this fix worked for both my laptop and my wife's laptop. Imagine that: 1 problem, 2 laptops: one solution.

For now, it seems to have been solved. But I am going to wait and test this for 2 days. If, by Tuesday, it is still working, I will than declare Kaplaa!

Thanks!  GadgetDude (will contact on Tuesday)
0
 
LVL 31

Accepted Solution

by:
Frosty555 earned 500 total points
ID: 40433182
Glad you got it working!

Don't worry, SSL is not an easy concept to wrap your head around. In general, it is supposed to be the server administrator's job to make sure all their ducks are in a row. In your case, though, YOU have become the server administrator, because you are managing the WD MyCloud Device, so the task has suddenly been thrusted onto you.  Not exactly fair, but really it just underscores the idea that "having your own cloud" is actually a much more complicated affair than WD would like you to believe.

This youtube video does a good job of quickly explaining in a fun way how SSL encryption works:
https://www.youtube.com/watch?v=SJJmoDZ3il8

In the context of this video, remember that WD MyCloud is technically just a website. So in the video, "Bensel's Pencils" is your WD Device, and the "customer" is... you!


This one's a good watch, too, although it is a little more boring, it jumps right into the whole "trust" thing right away: https://www.youtube.com/watch?v=LRMBZhdFjDI
0
 

Author Closing Comment

by:GadgetDude
ID: 40436705
Kaplaa!
Having tested WD MyCloud for 2 days, on 2 laptops, access is successful with no certificate issues.
I will not pretend to understand completely; but fun video was so silly Iaughed so hard tears ran down my leg (LOL).
My only concern now is that having installed a "Trusted Certificate Authority" perhaps I should not have installed the "Untrusted Certificate" and should uninstall this second certificate.
This is all very complex

I am very grateful.  Blessings!  GadgetDude :)
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
#Citrix #Citrix Netscaler #HTTP Compression #Load Balance
This is a high-level webinar that covers the history of enterprise open source database use. It addresses both the advantages companies see in using open source database technologies, as well as the fears and reservations they might have. In this…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

690 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question