Exchange 2013 2 node DAG, why are 65 ReplicationDagNetwork showing up in the ECP?

We have Exchange 2010 in place, trying to install Exchange 2013 in a 2 node DAG.   Running Exchange 2013 on Server 2012 R2 as a Hyper-V guest on a 2008 R2 Hyper-V host.

In my ECP under database availability groups for my DAG on my new Exchange 2013 nodes it show 65 ReplicationDagNetworks.  I actually only have one replication network and have verified in powershell that replication is using the correct network.

Also the command get-databaseavailabilitygroupnetwork fails with a "could not load file or assembly" error.

Not sure if that is related.
Who is Participating?
jasonbrandt3Connect With a Mentor Author Commented:
All but the ReplicationDagNetwork01 have empty IP settings.

Cumulative update 6 for Exchange 2013 SP1 is installed.

I have (2) iscsi connections to mount volumes for the database and log directories.  Those connections attach to a single SAN network and I disabled replication . (I have "ManualDagNetworkConfiguration" set to "True".

I cannot delete these extra ReplicationDagNetworks in ECP, nor can I disable replication over the MAPI network via ECP

Since I ran the command:
 Set-DatabaseAvailabilityGroupNetwork -Identity DAG2\DAGNetwork02 -ReplicationEnabled:$false -IgnoreNetwork:$true

I am now able to see info when I do a get--databaseavailabilitygroupnetwork as it looks like it opened a new powershell session with more permissions.

The remove command seems to have quite a delay when I try to remove the networks.  Even after specifying a domain controller that is NOT read-only.
Remove-DatabaseAvailabilityGroupNetwork -Identity DAG1\DAGNetwork04 -domaincontroller mydc.mydomain.lcl

I'll try removing all the invalid ones and waiting a few minutes, this problem may be resolved.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.