Exchange 2010 meeting requests from external domains

The organization I'm at currently moved to exchange 2010, the environment was originally 2003, it was moved to 2007 and now is 2010. Everything is working except the fact that when we get a meeting request from outside the organization it doesn't put it in the calendar as tentative as it does with meeting requests that come from within the exchange organization.

I can't for the list of me figure out why it's happening.
Brandon_VVP, Systems InfrastructureAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jamie McKillopIT ManagerCommented:
Hello,

By default external meeting request are not processed. You can change this setting for all your mailboxes by running this powershell command:

Get-Mailbox -Server -ResultSize Unlimited | Set-CalendarProcessing -ProcessExternalMeetingMessages $true -AutomateProcessing AutoUpdate -AddNewRequestsTentatively $true

Open in new window


-JJ

*Edited to correct powershell

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Joshua GrantomSenior Systems AdministratorCommented:
Each time you create a new mailbox you will have to rerun the command. There is no way to set it as default.

You can however, set a scheduled task to run this. It finds mailboxes that do not have it enabled and then enables it


Get-CalendarProcessing | Where {$_.ProcessExternalMeetingMessages -eq $false} | % {Set-CalendarProcessing $_.Identity -ProcessExternalMeetingMessages $true}

Open in new window

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.