Solved

Exchange 2013 PF migration:  OAB

Posted on 2014-11-08
20
174 Views
Last Modified: 2014-11-09
Hi,

I am migrating from Exchange 2007 to 2013.  The 2007 server is an SBS2008.  Public Folders are not used.  However, the database exists.  I tried to delete it but received a message that sais the public folder database contains the public address book, and I need to migrate this address book to another location before I can delete the database.  
I have started reading the articles on exchange migration.  Also I saw the scritpts that create the files for later comparison and so on.
The list on my file is very short and it also contains only folders with size 0.

Is there a simpler way of getting rid of the old public folder database on the legacy server?

Thanks,
Ralph
0
Comment
Question by:Ralph Scharping
  • 11
  • 6
  • 3
20 Comments
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 250 total points
Comment Utility
Reconfigure the OAB to use web distribution only.
Then follow the steps in this TechNet article to remove the last public folder database.
http://technet.microsoft.com/en-GB/library/cc164367(v=exchg.80).aspx

No point migrating something that you don't need.

Simon.
0
 
LVL 2

Author Comment

by:Ralph Scharping
Comment Utility
Hi Simon,

I have done that, thank you.
Now, when trying to remove the public folder database, I am told that I need to remove all public folders.  The public folder administration console from the emc-toolbox in 2007 shows only two empty folders:  public standard folders and public system folders.  Nothing inside.

Get-PublicFolderStatistics

Name                                     ItemCount               LastAccessTime
----                                     ---------               --------------
Default                                  0                  08.11.2014 10:30:21
EX:/o=First Organization/ou=Exchange Adm 20                 08.11.2014 01:00:01
inistrative Group (FYDIBOHF23SPDLT)
EX:/o=First Organization/ou=Exchange Adm 0                  08.11.2014 01:00:01
inistrative Group (FYDIBOHF23SPDLT)
exchangeV1                               401                08.11.2014 10:30:21
globalevents                             0                  08.11.2014 10:30:21
internal                                 0                  08.11.2014 10:30:21
microsoft                                0                  08.11.2014 10:30:21
OAB Version 2                            32                 08.11.2014 02:03:41
OAB Version 3a                           32                 08.11.2014 02:03:41
OAB Version 4                            2                  08.11.2014 02:03:41
OWAScratchPad{C9F1DA9E-545B-4BEA-8078-B4 0                  08.11.2014 10:30:21
8E52775079}
schema-root                              0                  08.11.2014 10:30:21
StoreEvents{C9F1DA9E-545B-4BEA-8078-B48E 0                  08.11.2014 10:30:21
52775079}
/o=First Organization/cn=addrlists/cn=oa 0                  08.11.2014 01:00:01
bs/cn=Standard-Offlineadressbuch

If I run
Get-PublicFolder -Server MX "\Non_Ipm_Subtree" -Recurse -ResultSize:Unlimited | Remove-PublicFolder -Server MX -Recurse -ErrorAction:SilentlyContinue

I am told that there is no public folder that matches the identity  "\NON_IPM_SUBTREE"

And idea?

Thanks,
Ralph
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
Comment Utility
Try

Get-PublicFolder -Server MX "\" -Recurse -ResultSize:Unlimited | Remove-PublicFolder -Server MX -Recurse -ErrorAction:SilentlyContinue

Then run

get-publicfolderstatistics

Once that returns no results, you are ready to drop the store.

Simon.
0
 
LVL 2

Author Comment

by:Ralph Scharping
Comment Utility
It sais it can't find a public folder that matches the identity "\".
I had tried that before, but didn't think much of it since there were no user folders in the first place...

Publicfolderstatistics shows all the system folders as posted earlier.
0
 
LVL 2

Author Comment

by:Ralph Scharping
Comment Utility
This is the output:

[PS] C:\Windows\system32>Get-PublicFolder -Server mx "\Non_Ipm_Subtree" -Recurse -ResultSize:Unlimited | Remove-PublicFolder -Server mx -Recurse -ErrorAction:SilentlyContinue
Get-PublicFolder : Es ist kein 'PublicFolder' vorhanden, das der folgenden Identität entspricht: '\NON_IPM_SUBTREE'. Stellen Sie sicher, dass die richtige PublicFolder-Identität angegeben wurde und dass Sie über die erforderlichen Berechtigungen zum Anzeigen von PublicFolder verfügen.
Bei Zeile:1 Zeichen:17
+ Get-PublicFolder <<<<  -Server MX "\Non_Ipm_Subtree" -Recurse -ResultSize:Unlimited | Remove-PublicFolder -Server dns-sbs -Recurse -ErrorAction:SilentlyContinue
    + CategoryInfo          : NotSpecified: (0:Int32) [Get-PublicFolder], MapiOperationException
    + FullyQualifiedErrorId : 5F7E8718,Microsoft.Exchange.Management.MapiTasks.GetPublicFolder
0
 
LVL 30

Expert Comment

by:Gareth Gudger
Comment Utility
If you are sure there is no data in the Public Folders. Or at least nothing you want to keep.

You can try the method in Pete Long's article. Check Step 7 in the second set of steps in the bottom half of this page.
http://www.petenetlive.com/KB/Article/0000816.htm
0
 
LVL 2

Author Comment

by:Ralph Scharping
Comment Utility
Hi Gareth,

this is pathetic.  I did exactly what Pete suggested, but I STILL get the same message.  
get-publicfolderstatistics still shows the same result - except that some of the system folders that previously had a few bytes content are now empty.  
This is the output now:

[PS] C:\Windows\system32>get-publicfolderstatistics

Name                                     ItemCount               LastAccessTime
----                                     ---------               --------------
Default                                  0                  09.11.2014 09:06:02
EX:/o=First Organization/ou=Exchange Adm 0                  09.11.2014 09:06:00
inistrative Group (FYDIBOHF23SPDLT)
EX:/o=First Organization/ou=Exchange Adm 0                  09.11.2014 09:06:00
inistrative Group (FYDIBOHF23SPDLT)
exchangeV1                               401                09.11.2014 09:06:02
globalevents                             0                  09.11.2014 09:06:02
internal                                 0                  09.11.2014 09:06:01
microsoft                                0                  09.11.2014 09:06:02
OWAScratchPad{C9F1DA9E-545B-4BEA-8078-B4 0                  09.11.2014 09:06:02
8E52775079}
schema-root                              0                  09.11.2014 09:06:02
StoreEvents{C9F1DA9E-545B-4BEA-8078-B48E 0                  09.11.2014 09:06:01
52775079}

Do you have another idea?  I feat this will even still be the case after I do the entire migration...

Thanks,
Ralph
0
 
LVL 30

Expert Comment

by:Gareth Gudger
Comment Utility
How far did you get with Pete's instructions? Did it let you create a blank Public Folder database? Were you then able to remove the blank database?
0
 
LVL 2

Author Comment

by:Ralph Scharping
Comment Utility
I dismounted the database, renamed the containing folders, mounted it again and received the warning that a new database was going to be created.
Then, an instant after it showed online, I deleted it.  Again the same message:  It cannot be deleted - it still contains folders.

I found another page where someone sais that you need to leave on system administrator account on the mailbox folder in order to do this, so I re-created a system administrator user ("admin") and the message store, and I logged on to the server as this account.  Same thing.
The two commands that are supposed to delete all user and all system folders state that the identitis "\" and "\Non_Ipm_Subtree" don't exist.  I have posted the get-publicfolderstatistics output.  At the same time the public folder management console in 2007s EMC shows now content in neither user nor system folders.

There are only two servers on the organisation, one 2007 and one 2013.  The 2013 does not contain any public folder configuration.

I'm getting panicky.  This needs to be finished by Monday morning...!

Any ideas you might have would be greatly appreciated.

Thanks,
Ralph
0
 
LVL 30

Expert Comment

by:Gareth Gudger
Comment Utility
That's so weird. I can safely say I have used both Simon's method and Pete's method.

Just for a sanity check, you are substituting MX for your own server name right?

Also, does the 2007 server still have a Mailbox Database? I have seen it where the Public Folders will not delete if the Mailbox Database was removed first.
0
Are your corporate email signatures appalling?

Is it scary how unprofessional your email signatures look? Do users create their own terrible designs and give themselves stupid job titles? You can make this a lot easier for yourself by choosing an email signature management solution from Exclaimer today.

 
LVL 2

Author Comment

by:Ralph Scharping
Comment Utility
*smile*
right.
0
 
LVL 30

Assisted Solution

by:Gareth Gudger
Gareth Gudger earned 250 total points
Comment Utility
One last resort is to kill it with ADSI Edit.
http://blog.dargel.at/2012/01/19/remove-public-folder-using-adsiedit/
0
 
LVL 2

Author Comment

by:Ralph Scharping
Comment Utility
I noticed one thing:
doing copy-paste from web to powershell sometimes gives me ASCII-crap.  I am running a German installation with German keyboard-layout.  So sometimes, when things go strange, I need to type the commands rather than paste them to the shell.
When I do that, the error message changes depending on what excactly I write.

If I type
Get-PublicFolder -Server MX "\Non_Ipm_Subtree" ...

I get Get-PublicFolder : Es ist kein 'PublicFolder' vorhanden, das der folgenden Identität entspricht: '\NON_IPM_SUBTREE'....

But if I type  
Get-PublicFolder -Server MX "Non_Ipm_Subtree" ...

i get Get-PublicFolder : Es ist kein 'PublicFolder' vorhanden, das der folgenden Identität entspricht: 'Non_Ipm_Subtree....

In the error message the path is capitalized if I spell it right and spelled the way I spell it when it is not.
Could it be this is a rights issue?
Did I mention the 2007 is SBS208?

Thanks,
Ralph
0
 
LVL 2

Author Comment

by:Ralph Scharping
Comment Utility
Is the option including ADSIedit going to affect my 2013-server?  Currently I cannot create public folder mailboxes there save with the -holdformigration switch...
0
 
LVL 30

Expert Comment

by:Gareth Gudger
Comment Utility
0
 
LVL 2

Author Comment

by:Ralph Scharping
Comment Utility
This really could be applicable.
But I don't understand this:

Wir haben mittels ADSiEdit den HomeMDB Attribute von System Attendant konfigurieren und dort den  DistinguishedName der Mailbox Store hinzugefügt.

( We have configured the HomeMDB-Attribute of System Attendant using ADSIedit and added the DistinguishedName of the message store)

Where do I find this System Attendant?  What excactly is meant by DistinguishedName of the Mailbox Store?  Is that the LDAP-Path?

Do you speak German?
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
Comment Utility
You have to include the \ at the start of any paths for public folders. Otherwise it doesn't work.
The adsiedit method shouldn't affect the Exchange 2013 platform, but it is always the last resort. Public Folders are slow, you can make a change and nothing appears to happen for hours.

Simon.
0
 
LVL 2

Author Comment

by:Ralph Scharping
Comment Utility
With a little help from Dr. Google I found how to determine the Mailbox Store's destinguished name and how to set the HomeDB-value of System Attendant.  It was okay, though.  It is set to the Message Store that is hosted on the same server that I am trying to remove the public folder db from.
I'm going to reboot the machine just in case.
Because this is a message store I just re-created a while ago.  I had already removed all mailboxes plus the mailbox store from this server.
0
 
LVL 2

Author Closing Comment

by:Ralph Scharping
Comment Utility
Thanks, guys.
I ended up deleting the store using ADSIedit.  It worked just fine an did not cause any trouble with my 2013-installation, either.

Can't say I understood what happened, but I got there thanks to you guys.  You saved my weekend.  Thank you so much.
0
 
LVL 30

Expert Comment

by:Gareth Gudger
Comment Utility
You are most welcome!
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now