Solved

Problems with Trunk Port and VLANS

Posted on 2014-11-08
7
304 Views
Last Modified: 2014-11-10
I have two Cisco SG300 Series switches that I'm trying to get setup. I only need a couple VLANS steep, but can seem to get the trunk port to work....a little over my head and not sure where to start.  I've created the VLANS, tagged them on my trunk ports, but cant even ping one switch from the other.
0
Comment
Question by:Brennan Wilkins
  • 3
  • 3
7 Comments
 
LVL 26

Expert Comment

by:Predrag Jovic
ID: 40431057
There is always same place to start check problem with trunk.

To check what ports are trunk ports, trunk mode, and what are allowed VLANs, and since it is dot1q encapsulation check is native VLAN same on both switches

#show interface trunk

If you still have no clue - post configuration of trunk ports , and show interface trunk command output from both switches.
0
 

Author Comment

by:Brennan Wilkins
ID: 40431357
Here's more info.  If anyone would be willing/ available I could setup a remote session if it's easier than trying to explain it all.

On both switches I have 3 VLANs 5, 10, 100, and then vlan 1, the cisco default.

5 and 100 I need to span across both switches.  On my trunk ports I have the clans tagged, except for vlan 1 (the default(


Here's the running config on the switches, this is just one, but both of them should be identical...

vlan database
vlan 5,10,100
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
hostname switch714c71
no passwords complexity enable
username cisco password encrypted 7af78c911d5b48bea1dc2449d9d89513abeb4be5 privilege 15
!
interface vlan 1
 ip address 10.0.1.3 255.255.255.0
 no ip address dhcp
!
interface gigabitethernet1
 switchport mode access
!
interface gigabitethernet2
 switchport mode access
!
interface gigabitethernet3
 switchport mode access
!
interface gigabitethernet4
 switchport mode access
!
interface gigabitethernet5
 switchport mode access
!
interface gigabitethernet6
 switchport mode access
!
interface gigabitethernet7
 switchport mode access
!
interface gigabitethernet8
 switchport mode access
!
interface gigabitethernet9
 switchport mode access
!
interface gigabitethernet10
 switchport mode access
!
interface gigabitethernet11
 switchport mode access
!
interface gigabitethernet12
 switchport mode access
!
interface gigabitethernet13
 switchport mode access
!
interface gigabitethernet14
 switchport mode access
!
interface gigabitethernet15
 switchport mode access
!
interface gigabitethernet16
 switchport mode access
!
interface gigabitethernet17
 switchport mode access
!
interface gigabitethernet18
 switchport mode access
!
interface gigabitethernet19
 switchport mode access
!
interface gigabitethernet20
 switchport mode access
!
interface gigabitethernet21
 switchport mode access
!
interface gigabitethernet22
 switchport mode access
!
interface gigabitethernet23
 switchport mode access
!
interface gigabitethernet24
 switchport mode access
!
interface gigabitethernet25
 switchport mode access
!
interface gigabitethernet26
 switchport mode access
!
interface gigabitethernet28
 switchport trunk allowed vlan add 5,10,100
!
0
 
LVL 26

Expert Comment

by:Predrag Jovic
ID: 40431437
This should work - cause it sets trunk mode unconditionally on port

interface gigabitethernet28
 switchport mode trunk
 switchport nonegotiate  
 switchport trunk allowed vlan 1,5,10,100  ////////(not add VLAN - if those are only VLANS)

output down (code) tells a lot mode - auto/trunk/desirable & status - non trunking/trunking
If both ends are configured as auto (I guess that's in your case) trunking will not work. Auto mode waits for other side to start trunk negotiation. Besides ping maybe don't work since in your case VLAN1 could be forbid on trunk (although default is allowed VLAN all - and when you add VLANs you really didn't do anything)
Switch# show interface trunk
Port          Mode      Encapsulation      Status       Native vlan
Fa0/28        auto          802.1q       not-trunking          1

Open in new window

0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 
LVL 45

Expert Comment

by:Craig Beck
ID: 40431607
@Predrag - the SG-series switches use a slightly different code to standard IOS switches and the VLAN configuration is also slightly different.  The add command is required and it will just add it back into the code when the switch reboots.

You're right about the switchport mode trunk command though - these switches will set the port as a General port by default (IIRC) so it won't do automatic trunking by default.
0
 

Author Comment

by:Brennan Wilkins
ID: 40431669
Think I'm over my head on this one...I'll probably find some one local to come help me get it setup. I really appreciate your time, and I don't want to waste any more of it.

-B
0
 
LVL 26

Accepted Solution

by:
Predrag Jovic earned 500 total points
ID: 40432137
Brennan, it is simple, don't quit - your almost there. :)

so, config on both switches (with Craigback suggestion) trunk ports should be

interface gigabitethernet28
 switchport mode trunk
 switchport nonegotiate    //// this one is optional  :)
 switchport trunk allowed vlan add 1,5,10,100

and then reboot

If this don't work, you can still call someone. :)
0
 

Author Comment

by:Brennan Wilkins
ID: 40433603
haha...so good news. I was able to figure it all out, and here come the strange part.

I had a bad port on the switch. It would light up fine, work as an access port, etc….but as soon as I set it to be the trunk it shut down and wouldn’t work.  To test and see if it was a hardware or settings issue, I copied its setting to another port and it worked instantly....really strange to say the least.

-B
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Suggested Solutions

The article explains the protocols and technology which is involved when two computers on different TCP/IP networks communicate with each other. In the diagram, a router is used to segregate two networks. The networks are 192.168.1.0/24 and 192…
Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now